Synology - Running, but not adding folders

Thank you all for these reports.
I’ve now released the new beta versions (Studio and Origin that now skips these @aeDir and files starting with ._
This fixes on our NASes both sync and playback issues.

Please tell us if this release fixes this for you too


Unfortunately, this didn’t change anything for me. I still get the Request Error when using my main library volume.

2024-05-13 09:42:09.767 [info]: ============= Started Logging, Audirvana Origin linux =============
2024-05-13 09:42:09.767 [info]: No language set in settings, using system language: en_US.UTF-8
2024-05-13 09:42:09.831 [warning]: EULA not accepted yet, showing it
2024-05-13 09:42:09.841 [info]: RemoteServer: Server started and advertised on port 33928
2024-05-13 09:43:40.425 [error]: Not logged to Audirvana account: need to sign in
2024-05-13 09:44:57.361 [info]: UPnP stack initialized using default interface
2024-05-13 09:44:57.561 [info]: UPnP web server started on
2024-05-13 09:44:57.563 [warning]: ALSA output: No /dev/snd (kernel module snd not loaded) => disabling local audio devices playback
2024-05-13 09:45:30.800 [error]: Local Library Sync: Files synchronization: error Permission denied opening watching directory: /volume1/Darren Music

Edit: Looking at my directory more closely, the only file I see that may be an issue is a .DS_Store, but I’d have assumed these were already ignored. I’ll remove it and see.

Edit 2: No, removing the .DS_Store file did not fix the issue.

Edit 3: Just noticed that every folder has 2 files that accompany them (found using ls @*) :
I don’t seem to be able to do anything with them and I’m not sure what they are for, but they are the only odd thing I see in this directory.

What are the permissions of your folder /volume1/Darren Music ? The user audirvana-origin shall be able to at least read and execute it.

It should be wide open. I don’t see an actual user for audirvana in the DSM UI, but I assumed that was normal.

Edit: In case it helps…
drwxrwxrwx+ 1 root root 24708 May 13 09:52 ‘Darren Music’

And inside this folder ?

All look like this:

drwxrwxrwx+ 1 darren users 124 May 25 2021 Yes
drwxrwxrwx+ 1 darren users 96 May 25 2021 Yazoo
drwxrwxrwx+ 1 darrenes users 66 May 17 2023 Yaz
drwxrwxrwx+ 1 darrenes users 48 Sep 30 2022 XYZ
drwxrwxrwx+ 1 darrenes users 22 Dec 7 2022 Xentrix

One thing I remembered is that when I first installed Origin, I had an option to “Hide sub folders and files from users without permission” on the main Darren Music folder. I’ve since removed that option, but it didn’t make a difference.

Go to Control Panel, Shared Folder, select the desired folder, edit, permissions, use dropdown to select System internal user:

For you, it may be audirvana-origin as the user. My example is for the folder “Additional Music” and user “audirvana-studio”.

Yea, that’s where I didn’t see it in the UI. Like it’s not there, but the system does work if I use a different folder for my music.

You have to change the dropdown from “Local users” to “System internal user” (if you haven’t tried already).


Ah, yep there it is. I completely missed that. Set it to read/write and that got me to where I can select the folder. It’s puking on the #recycle folder now. I thought I had that turned off, but it should probably ignore it if it’s on.

Thanks for the nudge in the right direction!

Edit: Looks like it’s syncing now!

1 Like

Agree that it should ignore #recycle. I didn’t have it turned on. Glad you’re making progress.

The update works! My first of 3 music folders are loading now in iOS Remote App.

Just fyi, the offending file that needs to be skipped is “@eaDir”. A typo can mean all the difference in success vs failure. :laughing:

Thank you for providing the update. More feedback to come once I actually use it.

When I install the new package, it starts, and then stops after a while with the message ‘manually stopped’. Any idea for a fix for this?

Have you installed the package for your NAS CPU architecture ?
Be sure to use the x86_64 for all Intel ones

How silly of me, I downloaded the wrong package. Sorry!

I have Audirvana version running on a Synology DS418 NAS with a Realtek ARM processor and 2Gb of RAM.

I use the Album ‘Talkie WAlkie’ from Air as the illustration of the problem.

When I try to add the the folder in ‘Add folders’ under the tab local, I navigate to the music folder and then move down to the album folder. It is shown in the three next screenshots from the iPad:

I end up at an empty folder!

When I open the same folder on my Mac (it is mounted as an AFP:// folder), which is used by Audirvana on the Mac I see there are music files:

There was someone else who commented in another thread that he saw that the files appeared to be inside the @eaDir folder. I thought I saw the same. So, there must be something going on with symbolic links or another trick which confuses Audirvana on the Synology, but which is corrected by the file sharing protocols that you enable on the Synology.

Can you log using ssh on your nas, and check the actual folder structure? That is to check if those missing folders are in @eadir ?

When I navigate in Audirvana remote to add a folder, only the folders are shown, not the individual files. This seems normal to me as you are only looking for folders…

Maybe I"m misunderstanding the problem.

I have. I made screenshots.

This is what I see when listing the directory of the Air Album
Scherm­afbeelding 2024-05-15 om 18.53.18

And when I change to the @eaDir folder it says

I thought that peculiar, so I did a ‘ls -ltr’ command to get more details:

In the last screenshot, the upper part is the @eaDir folder and it has a 4096 byte file with the same name as the .m4a files, but in the actual dir the actual files with larger file sizes are stored. I think within the @eaDir file, the indexing services of Synology creates some representation of the actual file, which is highlighted in green by the MacOS terminal.

I can confirm I have the same behaviour here: only folders are appearing as you need to synchronize folders not individual files.
Only folders but never @eaDir folders that are not visible either via the File Station on Syno (at least by default).