Synology - Running, but not adding folders

I just dropped the Synology build onto my DS1621+ running DSM 7.2.1. I’m able to see the server in the app (iOS), but when I try to add a folder, I just get a Request Error popup on the phone.

Not entirely sure where to go to extract the logs, but if someone can assist I’m more than happy to post them.

Edit: Seems I can add folders, but only if they do not contain too many subdirectories. I noticed that when I navigate into my main library folder to add it, it never shows any subfolders. Going into a different one that has just a few subfolders worked fine.


I have the exact same issue. I can add folders with less content, but not my “music” folder. I get “Request error” popup at the bottom of the screen.

Music folder is 383 GB, 8243 files, 756 folders.

audirvana-studio user has RW access.

2024-05-07 18:05:19.043 [error]: Local Library Sync: Files synchronization: error Permission denied opening for watching directory: /volume1/music/@eaDir/SYNO@.fileindexdb

It’s the @eaDir files that Audirvana is choking on. These need to be ignored when scanning.

Synology automatically indexes “video” “music” and “photos” if any of the multimedia packages are installed and running (i.e. Audio Station, etc). That’s why these directories are created.

Edit: Just saw your response above. I’ll look for that file and see if I have it in the non-working directory.

I don’t understand this at all. I just copied my entire library over to a different, previously existing folder on a different volume, and it let me select the folder and seems to be syncing it now.

The library is identical, all I did was make a copy of it. The permissions appear to be the same for both folders. The only difference I found was the option for Don’t Show Subfolders to Unauthenticated Users was previously checked on the folder that doesn’t work. But changing it didn’t make any difference. Maybe some folder permission is set when Audirvana is first installed?

My copied folder is still syncing, but playing fine. I do see a ton of @files that were copied over, but maybe I’m not looking at the right thing.

I have the same issue which I posted in the “main” thread topic and now just saw this thread.

I am not about to reorganize folders to make the libraries work. There has to be a better way to add the content AND no file sub folder number limit.

I have the same issue, while the same music folder is mounted on my MacBook without a problem.

Is there a fix for this? The message is indeed ‘request error’ when trying to add the standard music folder on Synology: /volume1/music

UPDATE 1: I was inspecting the music folder in the File Station app on Synology. There was a folder called ‘.TemporaryItems’ (preceded by a dot), which was empty. I deleted it, removed some other 0 byte files from the main folder (probably left there by Apple Music when I mounted the NAS folders as remote library in Apple Music).

Then I tried to add the music folder again, and now it is indexing the folder!

UPDATE 2: Audirvana has indexed local files, but it won’t play a single file. There’s work to do it seems, local files in the music folder on the Synology NAS won’t play on my NAS.

Although I can’t be sure of the root cause, deleting the @eaDir’s and the contents is what fixed it for me. It’s a hidden file created in every directory (kind of like thumbs.db in windows). It’s created if you have used any of the stock Synology multimedia apps.

Having to go in and delete numerous “@eaDir” files is a royal p-i-t-a. Once deleted and Audirvana successfully loads the library folder(s), what happens if a “@eaDir” returns somewhere? Does re-indexing get affected? Not a good solution.

No other NAS-based media software I’ve used has had this issue.

Yes, the issue needs fixing (ignoring these folders). Synology won’t re-index as long as you don’t start multimedia packages (Audio Station, Video, Station, Photos, or Media Server).

I used this command from ssh terminal to clear mine out. They haven’t returned but those packages above are stopped. I use other packages like Minimserver anyway.

find "/volume1/music" -type d -name "@eaDir" -print0 | xargs -0 rm -rf

Audirvana should fix this. I won’t “fix” my Synology, it is something that should be addressed by an update. It is beta software, so this feedback on the @eaDir problem is welcome I suppose.

Totally agree. I was just looking at the logs and figured out what was going on… But it works now.

MacOS is also leaving files starting with ._ on linux samba shares, these files should be ignored:

2024-04-28 09:44:37.436 [warning]: Local Library Sync: Not synching unreadable file /media/music/AC-DC/Power Up/._01-12-Malcolm_Young-Code_Red-SMR.m4a

From time to time I have to clean these files:

find . -type f -name ‘._*’ -delete

Being able to configure ignore patterns would be great.

1 Like

Likely I’m doing something wrong but when I tried this today it did not work. :man_shrugging:

Maybe take a look at the log file and see what errors are logged. It certainly could be that we are having different issues. I’m not really sure how many different variables there are that may cause problems, just what I saw on my particular DS918+.

Settings, my account, open log file.

Thanks for this Rick,
Coud you tell us where to find the log file? I look at /volume1/@appdata/audirvana-studio, /var/log but I could not find it.


I just opened the log file from the Audirvana remote UI. It’s under settings, my account, open log file. I saw the permission errors when trying to add /volume1/music.

Yes, thanks! That is so obvious! I wasted my time trying to find the location of the log file…
Sorry for being so stupid :wink:


Actually I looked for it in the file system also and couldn’t find it before I saw it in the UI. :wink:

In case you are curious:


Old ones are there also.

I appreciate all the info and help. Since this is still in beta (really it’s alpha) stage I’m just going to wait for @audirvana to fix this. Not worth my time although I am excited to eventually use it.