System optimizer

Hi Everyone, first post here. I’m also having problems with the System Optimiser. Sine I’ve updated to the latest version of Audirvana I’ve had the same error message appearing. I’m running a MacBook Pro with the latest Catalina OS. I’ve tried all of the above fixes suggested above & nothing has worked so far. Anyone have any other suggestions? Thanks for your help, Matt

This is the error that I’m getting

Hello @Matt_Cave, do you mean the two commands line didn’t fixed your issue?

Yes I tried the command lines as well as the other options of copying the library files, checking security setting etc

Hello @Matt_Cave, can you try the command line bellow in Terminal and give us the result you get from it here?

sudo ls -al /Library/PrivilegedHelperTools

Thanks Damien for your help. This is what was generated when I ran that command line;

total 3744
drwxr-xr-t 3 root wheel 96 12 Sep 16:25 .
drwxr-xr-x 67 root wheel 2144 26 Aug 19:00 …
-rwxr-xr-x 1 root wheel 1915760 10 May 12:18

Hope that’s helpful

You are supposed to have a file called com.audirvana.SysOptimizerTool in this folder, can you go to this folder and try to find this file?

hmm ok well the only place com.audirvana.SysOptimizerTool appears is in LaunchDaemons. How do I fix that? I downloaded Audirvana again but chose not to update to the new version to see if that made a difference & it didn’t so I’m still on version 3.5.38

Can you reboot your Mac, remove the file form the LaunchDameons and install Sysoptimzer again?

Hi Damien,

I have tried doing that but then ran into other computer issues so deleted audirvana and downloaded it again & updated to the latest version then reinstalled the SysOptimiser. I now have com.audirvana.SysOptimizerTool in the PrivilegedHelperTools folder however I’m still getting the following error:

There was an error executing SysOptimizer. Not all optimizations may be done.
Error = The operation couldn’t be completed. (CFErrorDomainLaunchd error 9.)

You are asked to install the SysOptimiser every time you start up playing a new album.

Okay, can you do ls -al /Library/PrivilegedHelperTools so we can see if you have the proper rights for the file.

here it is

total 3832
drwxr-xr-t 4 root wheel 128 17 Sep 12:17 .
drwxr-xr-x 67 root wheel 2144 26 Aug 19:00 …
-r-xr–r-- 1 root wheel 43904 17 Sep 12:17 com.audirvana.SysOptimizerTool
-rwxr-xr-x 1 root wheel 1915760 10 May 12:18

Can you close Audirvana and do the three commands below in Terminal?

sudo launchctl load -w /Library/LaunchDaemons/com.audirvana.SysOptimizerTool.plist

sudo rm /Library/PrivilegedHelperTools/com.audirvana.SysOptimizerTool

sudo rm /Library/LaunchDaemons/com.audirvana.SysOptimizerTool.plist

After doing this, can you open Audirvana and play a track?

Yay! Thanks Damien its now working. Appreciate your efforts to get this fixed.

1 Like

I’m getting the same message. Will try the fix recommended by Damien3

me too. Did you find any solution

Have tried this a million times, might have worked on the older mac’s but definitely not working on Big Sur. The very first command will returnNo such file or directory, seems to be an issue with permissions; or the file not even installing in the first place.

1 Like

Same here. It seems to be a permission handling issue with big sur. Even if you give rw permissions to wheel to LaunchDaemons and PriviledgedHelperTools & below, it won’t give it properly.
So I’ve done the following:
0. gave audirvana full disk access (just for fun…never hurts)
0.5: closed audirvana

  1. Copied the files linked above to the respective folders
  2. Run the following commands
    sudo chown root /Library/PriviledgedHelperTools/com.audirvana.SysOptimizerTool
    sudo chgrp wheel /Library/PrivilegedHelperTools/com.audirvana.SysOptimizerTool
    sudo chown root /Library/LaunchDaemons/com.audirvana.SysOptimizerTool.plist
    sudo chgrp wheel /Library/LaunchDaemons/com.audirvana.SysOptimizerTool.plist
  3. Run sudo launchctl load -w /Library/LaunchDaemons/com.audirvana.SysOptimizerTool.plist
  4. Started audirvana. Played with sysopt enabled flawlessly
1 Like