System optimizer

Why am I getting this now. Haven’t upgraded to a point .27 or .28 Because everything was working OK not great but OK.

Damien can you help me out here

try deleting is preferences…

Close Audirvana

Go to the Main Library Folder… PrivilegedHelperTools folder…
Trash All the files in that folder from Audirvana (that folder install SysOptimizer)
Go to the Main Library Folder… LaunchDaemons Folder…
Trash All the files in that folder from Audirvana (SystemOptimizer and prefs files)

Restart MAC. Restart Audirvana…

Thx :blush::+1::+1::+1: will give it a shot

The SysOptimizer installation error message tells another application had created a security hole by setting the wrong permissions for this PriviledgedHelperTools folder.
To fix this permission issue, you can use the Terminal application and enter the following commands:

sudo chgrp wheel /Library/PrivilegedHelperTools

sudo chmod 1755 /Library/PrivilegedHelperTools

All I did was restart my computer everything is fine now. I did not understand what you were telling me to do with the latter comment you had sent me. Now it seems like I have a problem with Qobuz loading through Audirvana Remote… I go to the app“ Qobuz app everything is just fine. So to me this has something to do with the Audirvana ® remote app. Also the remote is very sluggish and slow and I am on the latest version. Once again I think Audirvana is the best sounding software I’ve ever heard. And I have tried them all.
Also last week I could not get him MQA titles to play and now they play fine no problem. And I have not updated to the latest to software offers from a Audirvana because I’m scared they’re going to introduce glitches because they are for Catalina. Now this week I have the Qobuz problem.Im just at a lose of what to do. Also navigating the Qobuz app and getting some help has been very disappointing. So I thought I would send a direct email to Sebastian and I have not heard from him which is again very disappointing. I also think that should be a concern of you since you’re implementing Qobuz through your fabulous music software.

this is what im getting … i tried deleting files that were in my PrivilegedHelperTools folder LaunchDaemons Folder, that didn’t work… then tried terminal commands , again no joy. even deleted the whole program and did a new install with no success .
this what i keep getting as the error message;

There was an error executing SysOptimizer. Not all optimizations may be done.
Error = The operation couldn’t be completed. (CFErrorDomainLaunchd error 9.)

You tried everything i wrote in order ?

1 Like

yes i did and still didn’t work

So after the restart when trying to play a song Audirvana tried to reinstall sys opt ?

with every song, album, and playback device

I know it doesn’t work, but after deleting the files and restarting the computer. Opening audirvana for playing a song at first, it duppose to tell you that it needs to install sys opt…
Did it ask?

and i keep getting the same error message each time. it get it to play i have to shut off sysop and just let it play back in the normal format.

first to be reinstalled it has to be open in Audirvana i think…
so, put it all like me in my picture here…

then close Audirvana

Go to the Main Library Folder… PrivilegedHelperTools folder…
Trash All the files in that folder from Audirvana (that folder install SysOptimizer)
Go to the Main Library Folder… LaunchDaemons Folder…
Trash All the files in that folder from Audirvana (SystemOptimizer and prefs files)

Restart MAC.
Restart Audirvana
it should ask to reinstall it upon trying to play the first song… say yes :slight_smile:

1 Like

I followed exactly all the instructions that the kind RunHomeSlow gave in the various discussions, but I can not install the System optimizer in any way …

iMac 27 “” 2015 catalina

Hello @incursore61, ahve you tried this? System optimizer

Hi damien and thanks for your reply. I tried what you indicate, but still in my Library / PrivilegedHelperTools there was nothing to delete…it just seems never installed …

Since the error says it couldn’t communicate with the helper, check your Security & Privacy System Preferences in your Mac since you have more secure Catalina installed… nothing unchecked there for Audirvana?

I’m also on Catalina, if you want to try to put my files there to see if it is working… they are just preferences files installed by Audirvana… i put a .zip file in my dropbox for you to try:

If you don’t trust me, do a backup before to restore… but they are genuine, no worry. If it still doesn’t work after, remove them.

If you try mine, close Audirvana, put the 2 files in the folder i wrote, and the other 2 in the other folder i wrote… if you don’t have these folders in your main Library, create a new folder and paste the name i wrote. After putting the 4 files in the 2 folders, restart your Mac. Then restart Audirvana and play a song… check in the lower right bottom of Audirvana window if you see the SysOpt in green.

1 Like

This worked for me, thanks!!!