Technics ST-30G Music Server DLNA

Newbie to this forum and DNLA music servers.

While I can stream and play Tidal MQA to the SU-G30 (all-in-one) with Audirvana, I cannot figure out how to connect my ST-30G DNLA capable music server to Audirvana.

Any help would be appreciated.

Because it is a music server, Audirvana needs to access music files from local drive, usb drive or nas.
Can your ST G30 share the hdd/folders over the network as it were a nas? Audirvana cannot access a dlna music server … like MinimServer for example

I can see the ST G30 in the finder under Network … but it will not open.
No sure if it works as a nas.

I found this link.

Did you enabled the sharing function on ST G30 as described on pages 17-18?

Thanks for your help.

Yes file sharing is toggled on and I entered a password.
Back over at Finder/Network/TechnicsSTG30, no joy, it shakes and will not accept my password.

… maybe a silly question …
Are you trying to connect to the share entering user name “User” and the password defined in st g30?
… and … is your computer macOS or Windows?

Yes - user name “User” then password.
I tried changing password no help. MacOS.

macOS Catalina or something else?

Yes - Catalina 10.15.4

I was trying to find the issue … I am on High Sierra and have two servers sharing folders on the network and can access them without any issue … maybe Catalina is different … cannot help you anymore, sorry.
I suggest you to contact Techincs or someone where you bought your st g30, maybe they can help you
… good luck

Well - you actually found the problem - Catalina OSX.

I went over to the wife’s iMac which is still rocking High Sierra like you … works like a champ.
Problem is I don’t want Audirvana on her computer, I need it on my MacBook Pro.
What to do now?

I could find on the net several issues reported about nas connection with Catalina starting from 10.15.1 release, without a definitive solution.
Someone is reporting that a static IP address instead of using dhcp on the nas did solved the issue, but it seems to not be true for others … I think that Apple support is the way to try to solve the issue

Thanks Stefano.

I will report back if I find a solution.

Catalina no longer support SMB 1 and SMB 2. Enable SMB 3 in you server.

The Technics ST-30G is a consumer grade music server there is no such provision to change the SMB support.

I dug out my old Sony HAP-Z1ES music server and it exhibited the same exact problem. I went through the settings and just like the Technics ST-G30, all you can do is toggle on & off the Music Server button. If fact it doesn’t even have a password screen that the G30 provides. I performed a software upgrade dated Apr. 12, 2019 and now the HAP-Z1ES shows up in Finder as an ejectable drive under Locations and inside Network. Still would not connect. Next I changed the user name to Guest, no password, and boom the drive opened up and I was able to Sync all the music folders into Audirvana. I can stream HiRez files, 2X DSD’s, and even MQA CD’s I purchased in Japan. Audirvana even displays the MQA logo and the SU-G30 fully unfolds the files to 352.8kHz. Very impressive!

My conclusion is that Technics has yet to provide a software update to enable SMB3.

I checked the firmware update page.
No surprise the last update was Mar. 22, 2018, horrible support for a $5K music server.
Shame on you Technics!

Today a firmware update came for the Technics ST-G30 music server, installed but guess what … still cannot connect to macOS Catalina.

Considering the last update came on Mar. 22, 2018 … I was really hoping Technics had resolved this SMB 3 connection issue. Apparently Not!

No problem connecting with any previous macOS versions … just not Catalina.

Very very frustrating!

Have you tried to mount the share using cifs:// instead of smb://?

If that doesn’t work try enabling NetBIOS in Catalina. Type the commands below and restart the Mac:

echo “[default]” | sudo tee -a /etc/nsmb.conf
echo “port445=both” | sudo tee -a /etc/nsmb.conf

If it still doesn’t work turn off the packet signing:
echo “signing_required=no” | sudo tee -a /etc/nsmb.conf

More on how to turn off the packet signing: