This should be simple

New user. Long time Roon user but for two months now I’ve been unable to use it due to bugs “they’re dealing with” so here I am. Now…I have a large drive with many files and am unable to connect is as my local library. No matter what I do. No problem with streaming services. I tried another drive with some files. No luck. Any ideas?

Hey @gclayton Welcome. Seems unusual but things happen sometimes.

Perhaps you could provide details of your setup as this might give users a bit more information to consider. Eg Mac or Windows, what type of drive is music located on etc etc…

Hi @gclayton,

Can you give us more information about what is going on so we can help you properly? DO you get an error or something? What is happening in the app?

Good point.

Mac Mini M2. 16 GB RAM. MacOS 13.5
CalDigit AVPro2 12TB Drive
eero networking…both wi-fi and wired are very fast…test at just shy of a gig in either mode.

No error messages. It simply does nothing. I’ve added, removed and re-added the drive and tried with others with no luck. I’ve changed the database file path. Nada.

As I mentioned, streaming (Tidal) works fine.

Can you go in the Audirvāna settings and in the My account section? You will see a button ‘Start Log Session’, click on it and then reproduce your issue. After you reproduced it, click on ‘Stop Log Session’ and then send me the log file you can find by clicking on the button ‘Open Log Folder’ at

Done and sent. Thanks for the quick followup.

Are you able to locate this folder?


2023-08-11 08:46:24.977 [error]: Local Library Sync: error recursively enumerating /Volumes/Music/.Spotlight-V100 : Error Domain=NSCocoaErrorDomain Code=257 "The file “.Spotlight-V100” couldn’t be opened because you don’t have permission to view it." UserInfo={NSURL=file:///Volumes/Music/.Spotlight-V100, NSFilePath=/Volumes/Music/.Spotlight-V100, NSUnderlyingError=0x60000020a580 {Error Domain=NSPOSIXErrorDomain Code=1 "Operation not permitted"}}

Yes. Delete?

or is there a way to rebuild?

I’m rebuilding…will see if this helps.

This seems to have done the trick. The albums are now starting to appear. Thanks for your assistance on this Antoine.

Oops. Not so fast…after a few albums it stopped importing. Back to square one.

Hi @gclayton,

Can you create logs again and check if you vet an error like the one I sent you earlier?

Yes. Different drive but same issue. How do I resolve?

Any new files I add I can see. It’s loaded maybe 100 local albums (out of 20,000) and stops.

Maybe the 101 albums as somethings special in its name that Audirvana doesn’t like? That album is locked?

1 Like

Only 100 or so albums of the 20K albums are showing.

i know you said that, but usually Audirvana load albums in A-Z order,
so, what is the last album loaded? then see the next one if it has something special to block loading the others

Good idea but the distribution is random.

I rebuilt spotlight index but still no help.