TIDAL MQA bitrate not correct on Audirvana

There are several MQA titles on Tidal that when playing are marked by Audirvana as FLAC 24/192KHz MQA (bottom left of the Audirvana UI) , but are sent to the DAC at 96KHz (bottom right of the Audirvana UI) even though the DAC is capable of >192KHz (tested and verified). I’m using the Audirvana built-in MQA decoder

Why is that?

ps: it would be great to be able to attach images to posts

Hello @BitPerfectAudio, I changed your profile to be able to send picture in a post :wink:

Can you send me a copy of the “Debug Info” while you are listening to this music? You can get it in Audirvana Settings>General>Debug Info

Note: By clicking on the Debug Info Audirvana button automatically copies all its content, all you have to do is paste it in response to this message

The only authorised file types are images (LOL), no text files, so I took snapshots of the debug info as well. Please let me know

when you click debug info in Audirvana it is already copied in the clipboard (as noted in the window)… you have nothing to do except come here and paste it in reply window :slight_smile: it will be text…

Damien, did you have a chance to look at my post yesterday with the info you requested? I have a feeling that the 96Khz playback limit is related to the “Tidal limit streaming quality to Master” on the Audirvana preferences, and/or the MQA decoder.
Is Audirvana going to release a fix asap, can you please confirm your findings?
Until a fix is released, it’s not really Nirvana…

1 Like

RunHomeSlow, thank you for the tip. I can still read and understand enough to be able to do my engineering job even though I’m getting older by the hour :grinning:. An attached file would have been neater, plus I thought attached images were going to show a link rather than embed the content, like on other forum software, to keep the message body tidy

Hello @BitPerfectAudio, As per MQA decision, software players can only make the first unfolding of a MQA signal, so decode it only up to 96kHz.

But you can upsample this after to whatever you want, like 768kHz, or DSD, by enabling upsample at the bottom of the audio settings page.

1 Like

Thanks Damien. I’ve not studied the MQA specifications yet, however I keep on being negatively surprised by it.
There is no point in upsampling, but thank you for the clarification

Which DAC are you using?

Your debug info shows (under MQA capability header) that you aren’t using an MQA enabled DAC or at least have it set that you don’t have an MQA capable DAC and looks like it is not set to autodetect if you do… best you are going to get in that case is one software unfold to 88.2 or 96kHz depending on the base rate; to unfold it to 176.4/192kHz or higher you need MQA hardware to do the second or subsequent unfolding. MQA hardware also has a specific filter for MQA encoded content. I have read that there could be a partial benefit to doing the single software unfold; though personally, I generally just use the HiFi/CD quality setting with non-MQA equipment and leave MQA to capable hardware since it is less fuss and uncertainty.

It’s kind of like watching a 4k HDR BluRay on a non HDR capable 4k TV, you won’t ever truly be able to judge it since it isn’t capable of displaying what the disc and player are able to output. Slightly different scenario, but similar enough to understand the situation.

Also, upsampling would destroy the MQA encoding as far as I know, as you said there is no use in doing so.

1 Like

Can you explain to me how to use Audirvana as an MQA decoder? I am not streaming or playing MQA files since I cancelled my Tidal sub after the free trial and am only using Qobuz, but it would be good to know, since my Rega DAC doesn’t have MQA ability.

I see there is a setting where “DAC not detected as MQA, use as” with the options

Not MQA
MQA renderer
MQA decoder

I had it set to Not MQA. If I change it to MQA decoder then what will that do? And I haven’t a clue what MQA renderer is or does. Please point me to a page where this is explained, assuming there is one.

Not MQA -> unfolds to 24/88.2 or 24/96 respectively
MQA renderer -> unfolds and passes encoded stream to the DAC for full unfolding
MQA decoder -> passes bit-perfect stream to the DAC, and the DAC does everything

So what is the preferred setting when streaming MQA files to my DAC which doesn’t do MQA?

Not MQA. You get the first unfold that includes de-smearing of the recording equipment.

1 Like

Hello BitPerfectAudio. I had the same „problem”. But thanks to the FB group

I think it was solved. IT DEPENDS ON THE DAC. Please read my post in this Group dated 6th of February 2020. Maybe it will help you to understand the output matter. The result I reached is attached picture.

I hope my pictures are visible. If not let me know. I will try to upload them again. Good luck

To clarify a bit: MQA is an end to end system, taking care of the complete digital path from analog input to analog output. Thats why “Full MQA” must include output DAC as hardware. Software can’t control final timing errors happening in DAC if thats not part of chain. If people just listen and read some explanation of MQA before posting about disappointment, discussion would be more mature.