Tidal - Some Albums only play 1 track

When some albums are played by clicking on the play icon “>” only the first track plays not all tracks on the album. This can be reproduced by:

Hover the mouse over the album cover “Brokeback Mountain soundtrack” then hit the play button. It plays the first track of the album and then stops. Clicking “…” and selecting “add to play queue” adds only the first track.

I noticed other albums play to their entirety - and that this album has some tracks that Tidal has restricted - could this be the problem?

Has occurred for some time, currently on version 3.5.28

Hello @LikesToys,

I tried to add the album you quote in example to my play queue and it worked. Are you sure you are not trying to add only one track and not the entire album?

please see www.jeffgardner.ca/play_issue.mov for an example of my problem.

I am on the Mac version.

Thank you for the video. When you are in the playlist you used in the video, can you click on the Track view? I think you only have one track of this album in your playlist, that’s why you don’t have all of the tracks automatically added in your track queue

You are correct in that there is only one track in the playlist. However when you click on the album for that playlist, all tracks are displayed, yet it plays just the one track in the playlist. Would it not be better to display just the tracks in the playlist for that album when Album view is displayed, rather than display all the tracks but only play one of them. It seems this is back to basics - what I see is what I get, however in this case I see many tracks but it only plays one of them. Something not right there.

Thanks for following up so quickly with this issue.


1 Like

We had other feedback like you done. This is actually a bug that could occur. in the mean time if you want to play this entire album you can actually click on the name of the album and start the first song of it to have all of it added to your play queue.