Tidal Stream stops playing after ~20 minutes

Process: Audirvana Studio [7211]
Path: /Applications/Audirvana Studio.app/Contents/MacOS/Audirvana Studio
Identifier: com.audirvana.Audirvana-Studio
Version: 1.5.6 (10506)
Code Type: ARM-64 (Native)
Parent Process: ??? [1]
Responsible: Audirvana Studio [7211]
User ID: 501

Date/Time: 2021-07-13 20:27:26.402 -0600
OS Version: macOS 11.4 (20F71)
Report Version: 12

Mac mini (M1, 2020) w/8GBmemory → Simaudio Moon USB DSD HD Audio (240i)
Exclusive Access is enabled and set to Extreme.

Prior to the latest Studio update, streaming from Tidal worked flawlessly. With the recent update, content stops playing altogether after about 20 minutes (16/44.1k up through MQA content). DAC display indicates no input device (no signal). Previously, even when not streaming, the DAC indicated 32bit/384k connection over USB was present.

The Mac mini is running the latest OS. When Studio is running - nothing else on the computer is running.

Any insights or recommendations would be greatly appreciated!

I don’t have Mac but I have 2 suggestions:

  1. Send an email to support@audirvana.com
  2. Free some space, maybe I am wrong but this works on many cases.

Ive had a similar problem on Windows but only with longer pieces.

If its just normal songs and anything under 15 minutes or so it will play album after album, song after song, for days with no issues or even needing to reload the program. I used to use the same instance of 3.5 for weeks and apparently it’s the same with Studio.

But any single file over 15-20 minutes, regardless of when I play it, will usually stop about 15-20 minutes in and freeze everything up until I close the program and start again. Especially at DSD512 which i keep Audirvana on but it also does it at slightly lower rates.

I’ve tried increasing the buffer even slightly but then you start to get problems with tracks getting cutoff, stuttering, extra seconds of silence, etc.

I find Studio and 3.5 work best for me with absolutely no buffer at all in my house with a 40-80 mpbs and about a 5ms ping using a powerline adapter from our router upstairs so i still get a “wired” connection in my listening room. I bring in any buffer and it just causes issues.

But yeah audirvana seems to not like longer files, especially at high conversion rates.

Thank you for the suggestions.

I will definitely send a note to support@audirvana.com.

Interestingly, the Mac mini is solely used for audio streaming. Other than Audirvana Studio, I don’t have a single additional application loaded onto the machine (beyond the basic Apple apps that come pre-loaded).

Thank you for the insights.

I’m only trying to play normal songs (nothing over 9 minutes). The previous version of Studio as well as the original Audirvana app both previously played all of the content I’m trying to play now for days on end (as you indicated).

I’ve got the play buffer set to 5GB - thinking that would be useful for pre-loading the content prior to playing. I’ll adjust it down to zero and see if that helps (will certainly ensure keep-alive is current!).

On the networking side - I’ve got a wireless static IP address set on the mini. Ping time to the router (sitting 15 feet away) is ~13.5ms. I will move my power line adapter from an older printer over to the mini and see if I can improve the delay (5ms is pretty impressive). SpeedTest shows 117Mbps down from the ISP.

Thanks again for the suggestion on the buffer - will adjust that first and see what happens.