Tracks stop playing a few seconds before the end

Since a few days (latest Audirvana update ?), I have noticed that some tracks stop playing a few seconds before the end.

My setup is Audirvana (PC Win10) => Qobuz streaming => Hegel H390 via UPnP.

Upsampling is activated but this seems to have no effect on this issue:

Audirvana 3.5.45

SIGNAL PROCESSING:

Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

UPSAMPLING:
SoX with Power Of Two upsampling
SoX filter parameters
Bandwidth at 0dB = 99.5
Filter max length = 30000
Anti-aliasing = 100
Phase = 66

AUDIO VOLUME:
Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

LIBRARY SETTINGS:
Sync list: 0 folders
Library database path: C:\Users\Nicolas\AppData\Local\Audirvana\AudirvanaPlus\AudirvanaPlusDatabaseV2.sqlite

ACTIVE STREAMING SERVICES
Qobuz: Connected as Qobuz Studio

=================== AUDIO DEVICE ========================

Preferred device: H390_D499A6 Model UID:Hegel H390_D499A6 UID:uuid:2076dd38-1dd2-11b2-a08d-31a6380329ce

Selected device:
UPnP device at http://192.168.1.25:38400/description.xml
H390_D499A6 Manufacturer:Hegel
Model UID:Hegel H390_D499A6 UID:uuid:2076dd38-1dd2-11b2-a08d-31a6380329ce

6 available sample rates up to 192000Hz
44100
48000
88200
96000
176400
192000
Volume control: No
MQA capability
Auto-detect MQA devices: Yes
Not a MQA device, user set to not MQA
DSD capability: Unhandled
Device audio channels
Preferred stereo channels L:0 R:1
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1
UPnP/DLNA supported protocols:
http-get::audio/L16;rate=44100;channels=1:DLNA.ORG_PN=LPCM
http-get:
:audio/L16;rate=44100;channels=2:DLNA.ORG_PN=LPCM
http-get::audio/L16;rate=48000;channels=1:DLNA.ORG_PN=LPCM
http-get:
:audio/L16;rate=48000;channels=2:DLNA.ORG_PN=LPCM
http-get::audio/mpeg:DLNA.ORG_PN=MP3
http-get:
:audio/x-ms-wma:DLNA.ORG_PN=WMABASE
http-get::audio/x-ms-wma:DLNA.ORG_PN=WMAFULL
http-get:
:audio/x-ms-wma:DLNA.ORG_PN=WMAPRO
http-get::audio/mp4:DLNA.ORG_PN=AAC_ISO
http-get:
:audio/3gpp:DLNA.ORG_PN=AAC_ISO
http-get::audio/mp4:DLNA.ORG_PN=AAC_ISO_320
http-get:
:audio/3gpp:DLNA.ORG_PN=AAC_ISO_320
http-get::audio/vnd.dlna.adts:DLNA.ORG_PN=AAC_ADTS
http-get:
:audio/vnd.dlna.adts:DLNA.ORG_PN=AAC_ADTS_320
http-get::audio/flac:
http-get::audio/x-flac:
http-get::audio/wav:
http-get::audio/x-wav:
http-get::application/ogg:
DLNA 1.5: Yes
Gapless playback: Yes
Missing events workaround: No
Can play native DSD: No
Number of channels: 2
Use as stereo device only: No

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1
2 ch Integer PCM 16bit little endian 44.1kHz
2 ch Integer PCM 24bit little endian 44.1kHz
2 ch Integer PCM 16bit little endian 88.2kHz
2 ch Integer PCM 24bit little endian 88.2kHz
2 ch Integer PCM 16bit little endian 176.4kHz
2 ch Integer PCM 24bit little endian 176.4kHz
2 ch Integer PCM 16bit little endian 48kHz
2 ch Integer PCM 24bit little endian 48kHz
2 ch Integer PCM 16bit little endian 96kHz
2 ch Integer PCM 24bit little endian 96kHz
2 ch Integer PCM 16bit little endian 192kHz
2 ch Integer PCM 24bit little endian 192kHz

Current device transportInfo:
CurrentTransportState: NO_MEDIA_PRESENT
CurrentTransportStatus: OK
CurrentSpeed: 1
Current device MediaInfo:
NrTracks: 0
MediaDuration: 0:04:24.000
CurrentURI:
CurrentURIMetadata:
nextURI:
nextURIMetadata:
PlayMedium: NONE
RecordMedium: NOT_IMPLEMENTED
WriteStatus: NOT_IMPLEMENTED

Current device AVT service description:

<?xml version="1.0"?> 1 0 SetAVTransportURI InstanceID in A_ARG_TYPE_InstanceID CurrentURI in AVTransportURI CurrentURIMetaData in AVTransportURIMetaData GetMediaInfo InstanceID in A_ARG_TYPE_InstanceID NrTracks out NumberOfTracks MediaDuration out CurrentMediaDuration CurrentURI out AVTransportURI CurrentURIMetaData out AVTransportURIMetaData NextURI out NextAVTransportURI NextURIMetaData out NextAVTransportURIMetaData PlayMedium out PlaybackStorageMedium RecordMedium out RecordStorageMedium WriteStatus out RecordMediumWriteStatus GetTransportInfo InstanceID in A_ARG_TYPE_InstanceID CurrentTransportState out TransportState CurrentTransportStatus out TransportStatus CurrentSpeed out TransportPlaySpeed GetPositionInfo InstanceID in A_ARG_TYPE_InstanceID Track out CurrentTrack TrackDuration out CurrentTrackDuration TrackMetaData out CurrentTrackMetaData TrackURI out CurrentTrackURI RelTime out RelativeTimePosition AbsTime out AbsoluteTimePosition RelCount out RelativeCounterPosition AbsCount out AbsoluteCounterPosition GetDeviceCapabilities InstanceID in A_ARG_TYPE_InstanceID PlayMedia out PossiblePlaybackStorageMedia RecMedia out PossibleRecordStorageMedia RecQualityModes out PossibleRecordQualityModes GetTransportSettings InstanceID in A_ARG_TYPE_InstanceID PlayMode out CurrentPlayMode RecQualityMode out CurrentRecordQualityMode SetPlayMode InstanceID in A_ARG_TYPE_InstanceID NewPlayMode in CurrentPlayMode Stop InstanceID in A_ARG_TYPE_InstanceID Play InstanceID in A_ARG_TYPE_InstanceID Speed in TransportPlaySpeed Pause InstanceID in A_ARG_TYPE_InstanceID Seek InstanceID in A_ARG_TYPE_InstanceID Unit in A_ARG_TYPE_SeekMode Target in A_ARG_TYPE_SeekTarget Next InstanceID in A_ARG_TYPE_InstanceID Previous InstanceID in A_ARG_TYPE_InstanceID GetCurrentTransportActions InstanceID in A_ARG_TYPE_InstanceID Actions out CurrentTransportActions TransportState string STOPPED PAUSED_PLAYBACK PLAYING TRANSITIONING NO_MEDIA_PRESENT TransportStatus string OK ERROR_OCCURRED PlaybackStorageMedium string UNKNOWN CD-DA DVD-VIDEO HDD NETWORK NONE RecordStorageMedium string NOT_IMPLEMENTED PossiblePlaybackStorageMedia string UNKNOWN CD-DA DVD-VIDEO HDD NETWORK PossibleRecordStorageMedia string NOT_IMPLEMENTED CurrentPlayMode string NORMAL SHUFFLE REPEAT_ONE REPEAT_TRACK REPEAT_ALL NORMAL TransportPlaySpeed string 1 RecordMediumWriteStatus string NOT_IMPLEMENTED CurrentRecordQualityMode string NOT_IMPLEMENTED PossibleRecordQualityModes string NOT_IMPLEMENTED NumberOfTracks ui4 0 1 CurrentTrack ui4 0 1 1 CurrentTrackDuration string CurrentMediaDuration string CurrentTrackMetaData string CurrentTrackURI string AVTransportURI string AVTransportURIMetaData string NextAVTransportURI string NextAVTransportURIMetaData string RelativeTimePosition string AbsoluteTimePosition string RelativeCounterPosition i4 AbsoluteCounterPosition i4 CurrentTransportActions string LastChange string A_ARG_TYPE_SeekMode string ABS_COUNT TRACK_NR REL_TIME A_ARG_TYPE_SeekTarget string A_ARG_TYPE_InstanceID ui4

Current device RootDevice description:

<?xml version="1.0"?> 1 0 DMR-1.50 QPlay:2 urn:schemas-upnp-org:device:MediaRenderer:1 H390_D499A6 Hegel http://www.hegel.com H390 H390 1.0 http://www.hegel.com uuid:2076dd38-1dd2-11b2-a08d-31a6380329ce http://192.168.1.25 urn:schemas-upnp-org:service:RenderingControl:1 urn:upnp-org:serviceId:RenderingControl /RenderingControl.xml /RenderingControl /RenderingControl/eventSub urn:schemas-upnp-org:service:AVTransport:1 urn:upnp-org:serviceId:AVTransport /AVTransport.xml /AVTransport /AVTransport/eventSub urn:schemas-upnp-org:service:ConnectionManager:1 urn:upnp-org:serviceId:ConnectionManager /ConnectionManager.xml /ConnectionManager /ConnectionManager/eventSub urn:schemas-tencent-com:service:QPlay:1 urn:tencent-com:serviceId:QPlay /QPlay.xml /QPlay /QPlay/eventSub http://192.168.1.25:38400

UPnP devices found : 1
Device #0H390_D499A6 UID: uuid:2076dd38-1dd2-11b2-a08d-31a6380329ce Location: http://192.168.1.25:38400/description.xml

Max. memory for audio buffers: 2986MB

Local Audio Engine:WASAPI

Local devices found : 1
Device #0: Realtek Digital Output (Realtek High Definition Audio) Manufacturer: Model UID: Realtek Digital Output (Realtek High Definition Audio) UID: \?\SWD#MMDEVAPI#{0.0.0.00000000}.{6b3a2422-42bc-4a23-adac-b6429454ee14}#{e6327cad-dcec-4949-ae8a-991e976a79d2}

Thanks in advance!

1 Like

Many with the same issue since update. Five days now. No fix.
Poor communication as always.

Bonjour,
Je rencontre également le même problème sur les services de streaming vec qobuz et Tidal.
Quand je lance une piste sur qbuzen Hi-res this last se stoppe spontanément à 7 de la fin sans passer au morceau suivant.
Je précise que j’utilise les plug-in HAF et Room shaper, et depuis la dernière mise à jour V. 3.5.45 je suis obliger de désactivé room shaper car il accetue le problème.
Il n’y que sur Tidal avec les fichiers 16 bits 44.1 kHz que cela fonctionnne en désactivant room shaper, les fichiers MQA 24 bit se bloquent également.
J’ai diminué et augmenté le tampon mais cela ne chande rien, j’ai l’impression que le préchargement des dernières secondes de la piste ne se fait pas.
Et par moment l’application se bloque et je suis obligé de redémarrer audirvana.
Je précise que tout fonctionnait normalement avant la ise à jour.
Merci pour votre aide.

This was happening before the latest updates (for about a year now) with me, all seems random.