Unable to add tracks into playlist

I am using 3.5.9 and have tried adding tracks into a created playlist, but is unable to do so. I tried right clicking, or click on the 3 dots, on the track, there is no such option. I tried dragging files or tracks to the playlist, it doesn’t appear there and it actually crash the application.

Is it a bug or am I doing it wrong? Thank you.

I think that I am having the same problem. I can’t locate the bottom toolbar (which controls these actions). I did not have this problem when creating new playlists last month.

3.5.33 with MAC OSX Catalina

Hello @bigdave and @odyas, have you created smart playlist or manual playlist?

I think I have figured out what I was doing wrong. I was successful in making a manual playlist Thanks for responding so quickly.

Oh, I know what is the problem, I created a smart playlist and it is not working. I created a manual playlist and now I can add songs into it.

Can I ask what is a smart playlist in this case?

A Smartplaylist is a playlist that is based on criteria you put . If you add music to your library afterwards then if this music match the criteria of your Smartplaylist, it’ll be automatically be added to your playlist.