Unable to connect to MacMini

Previous versions of Remote never been the most reliable but most of the time it worked, the latest version of remote is the worst and actual times it works is very low.
Mostly it refuses to connect. Remote says connection in progress to My Macmini, so click select a computer. It then says no Connection and under Available Computers no computers.
Sometimes exiting remote and restarting other times stopping audirvana on Macmini will allow connection.
I usually have to restart Macmini which is no solution at all really. I mean you don’t have to switch the house mains on and off to switch a light on would you?
Sometimes it just starts to work after many failures, not good enough. If I’m missing something on my system so be it but I don’t think so.
MM mid2010 running OSX10.11.6 El Capitan. Audirvan 3.5.46. No idea what remote version is on l7th gen iPad, OS 14.6.

Are you using iOS or Android device?

I have updated my post. 7th gen iPad OS 14.6

Have you checked the firewall? Do you run some third party security software? Which router you have at home?

BT Smart Hub 2. Don’t think I’m running any 3rd party Security S/W.
As I said it worked well enough prior to latest Remote S/W update.