Unable to delete a track

I was trying to replace a 24/192 FLAC album in my local library with a 24/192 ALAC version so that it would transfer to my iPhone and iPad via macOS sync.

So I closed out AS and moved the album folder from my local library to the trash. I added the new ALAC version using iTunes to keep the iTunes sync files up to date). I don’t sync AS with iTunes.

I opened AS and saw the new tracks were there, but the album had a duplicate track.

I checked the files metadata and saw FLAC version was located in my Trash folder.

I went to Preferences-Local and hit the Sync button (I use a folder, not my iTunes database). Nothing changed. I closed out AS again and moved the unwanted file from my Trash folder to a folder on my desktop.

Same problem, AS “followed” the unwanted track from the trash to my desktop. WTH?!?

The option to delete this track via AS is grayed out.

How does AS follow the location of this track from my music folder to the trash and then to my desktop?

I made it a point to quit AS before I made changes to my music folder because I’ve seen this happen before but I can’t spot any pattern to when and why this happens, it just seems like random gremlins.

How do I force AS to only sync the files in my Music folder???

The last time this happened I deleted and rebuilt the AS sql file - and finally had to de-link AS from my music folder and then re-link it and wait for half a day while it rescanned everything. This is beyond frustrating.

(Later: I opened 3.5. The album is there, correct version, no duplicated tracks.)

Hello @LJK,

We have made this function to not break the playlists with tracks that are located in a NAS for example.

Have you tried to remove the duplicated track when you are in the track view?

I used track view but the Delete option was still grayed out.

I had the album set as a favorite so I tried un-favoriting the album and the delete function was active and I deleted the track successfully.

My primary question is how do I stop AS from retaining the filepath to tracks and albums I move to my trash folder???

This is so weird. Today I tried to delete two albums via AS. The delete option was greyed out for both.

I quit AS and moved both albums folders to the trash using macOS finder.

Restarted AS - Both albums remained (same album different resolutions). The Delete option was active for the FLAC 24/192 version so I simply deleted them. In the ALAC 24/48 version of the Delete option was greyed out and the metadata tool showed the file location as .Trash

I went to Preferences - Local and manually ran the sync (folder sync, not iTunes) and then ran the Database Integrity check. The results???

The album is still in AS, but only one track, still pointing to .Trash …

But the delete option is now available so I deleted it. Seems like the “scan on start” didn’t.

Later: I now see that how I look at an album matters. Going to Local - Albums and the tracks can be deleted. Going to My Music - Albums and delete is greyed out.

While this may be proper way to delete tracks, I still ask why AS “Follows” a track when it is manually moved to .Trash???

Hello @LJK, after further analysis of the issue on our side, it seems there is a bug in the analysis of tracks that keep the path of tracks and the result is what you actually have. It should not behave like this. Audirvāna Studio need to ignore to analyze the track if it isplaced in Trash.

I will come back to you next week or Damien will do later this week as I will be off for the rest of the week tonight.

1 Like

Thank you!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.