Unable to open an audio file for playback - error for some Tidal tracks

Hello! I recently started experiencing issues not being able to play some songs that previously played just fine, getting error (Unable to open an audio file for playback). I need some help with this please.

I’m using Tidal as streamer. I have already tried reinstalling the app, making sure that Tidal is no open while using Audirvana, but, the issue persists. The strange thing is that this is only happening when playing some specific songs; however, when I use the Tidal app, or the web version of Tidal, those same songs start playing without any issues. The issue only happens on Audirvana.

Just as a reference, one of the songs I’m having issues with is Joga by Björk, along with many others from different artists.

Below I attached the Debug info from Audirvana right after getting this error.

Audirvana 3.5.42

SIGNAL PROCESSING:

Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

UPSAMPLING:
SoX not in use
SoX filter parameters
Bandwidth at 0dB = 99.5
Filter max length = 30000
Anti-aliasing = 100
Phase = 66

AUDIO VOLUME:
Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

LIBRARY SETTINGS:
Sync list: 0 folders
Library database path: C:\Users\rodri\AppData\Local\Audirvana\AudirvanaPlus\AudirvanaPlusDatabaseV2.sqlite

ACTIVE STREAMING SERVICES
TIDAL: Connected as HIFI

=================== AUDIO DEVICE ========================

Max. memory for audio buffers: 6000MB

Local Audio Engine:WASAPI

Preferred device:
Speakers (AudioQuest DragonFly Cobalt v1.0)
Model UID:Speakers (AudioQuest DragonFly Cobalt v1.0)
UID:\?\SWD#MMDEVAPI#{0.0.0.00000000}.{5e0b0efb-372b-4bb7-b8bd-fb362eb937ef}#{e6327cad-dcec-4949-ae8a-991e976a79d2}

Active Sample Rate: 44.1kHz

Bridge settings:
Sample rate limitation: none
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:
Local audio device
Speakers (AudioQuest DragonFly Cobalt v1.0) Manufacturer:
Model UID:Speakers (AudioQuest DragonFly Cobalt v1.0) UID:\?\SWD#MMDEVAPI#{0.0.0.00000000}.{5e0b0efb-372b-4bb7-b8bd-fb362eb937ef}#{e6327cad-dcec-4949-ae8a-991e976a79d2}

4 available sample rates up to 96000Hz
44100
48000
88200
96000
Volume Control
Physical: Yes
Virtual: No
MQA capability
Auto-detect MQA devices: Yes
MQA Renderer device
DSD capability: Unhandled
Device audio channels
Preferred stereo channels L:0 R:1
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: No

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1
2 ch Integer PCM 24bit little endian 44.1kHz
2 ch Integer PCM 24bit little endian 48kHz
2 ch Integer PCM 24bit little endian 88.2kHz
2 ch Integer PCM 24bit little endian 96kHz

Local devices found : 3
Device #0: SAMSUNG (NVIDIA High Definition Audio) Manufacturer: Model UID: SAMSUNG (NVIDIA High Definition Audio) UID: \?\SWD#MMDEVAPI#{0.0.0.00000000}.{caa7c1a2-7e6b-42cb-a87a-ef03af497821}#{e6327cad-dcec-4949-ae8a-991e976a79d2}
Device #1: Realtek Digital Output (Realtek High Definition Audio) Manufacturer: Model UID: Realtek Digital Output (Realtek High Definition Audio) UID: \?\SWD#MMDEVAPI#{0.0.0.00000000}.{eb128ddd-f4f1-49f1-b0bc-7c9d47a6c661}#{e6327cad-dcec-4949-ae8a-991e976a79d2}
Device #2: Speakers (AudioQuest DragonFly Cobalt v1.0) Manufacturer: Model UID: Speakers (AudioQuest DragonFly Cobalt v1.0) UID: \?\SWD#MMDEVAPI#{0.0.0.00000000}.{5e0b0efb-372b-4bb7-b8bd-fb362eb937ef}#{e6327cad-dcec-4949-ae8a-991e976a79d2}

UPnP devices found : 2
Device #0[TV] Samsung 7 cuarto UID: uuid:297c05f6-ea5e-460d-854e-15f199056906 Location: http://192.168.1.6:9197/dmr
Device #1[TV] Samsung 7 Series (43) UID: uuid:5f55407a-4a4b-4a2b-9751-61195ae15c29 Location: http://192.168.1.11:9197/dmr

Hello,
I have the same problems when playing Wilco albums (MQA files). I recently updated my MacBook Air to Big Sur.

Hello @greg1 and @Rodrigoiki, can you make a screenshot of Audirvana while you have this issue?

Hi @Damien3, thanks for the reply. I can confirm the issue is no longer happening. What I would assume is that this might be similar to one of those error messages you get when you try to open many tabs in some websites, and you get locked out for 24hrs for making too many requests to the server.

Hopefully, this won’t be something recurrent. Thanks again!

HI there,

same issue for me today many times (e.g. James Taylor albums and many others), before with 3.5.41 never had problems.

Thank you in advance for the precious help

Cristian