Unable to re-install Audirvana 3.5

I am trying to re-install Audirvāna as I had a corrupted library file, but although I have deleted this file, when I try to restart the app, I get a message that the corrupted file is still there - which is not the case! I have discussed this problem with Apple support, who helped me to successfully open the app in a separate user account, but we couldn’t open it in my main account - this could be because a file still in the account is preventing it. Please provide an “uninstall “ app which will clear any such files, or any way to enable me to re-install the app.

Hi, i am not familiar with apple PC systems, but you should uninstall Audirvana first. In Windows 10 it is via menu start, look for Audirvana in the menu, rightclick and choose uninstall.
It will be helpfull to clean up the operatief system nu the use of for instance Ccleaner.
Look on the Audirvana site for the latest installer link with the highest version nummer and re-install Audirvana again.
You will be asked for your license number, so keep it on hand.
Hopefully this info will help to overdone your problem, so lot’s of succes.

Since you don’t tell which file it is, i guess it is the .sqlite database… or it could be also your Audirvana preferences…

Try this:

If you have Playlists that are important export them first to desktop and save them in a folder… when Audirvana is reset, you can re-import them back in one shot. Sadly to this day, the folders they were in if so, are not back, you have to do them again…

Apple hide the Home Folder in User Library at some time depending on OS System… When you have clicked your Home Folder, and cannot see the Library Folder in there, just do a ‘‘cmd J’’ to show the folder settings preferences and see at the bottom… click Show Library Folder and then you’ll have access to the rest forever.

Go in Audirvana preferences panel and remove your database(s) there (all the folder(s) of music you have there) delete them with minus sign.

Close Audirvana.

Go to User… Home Folder… Library… Applications Support… Audirvana Folder… Trash All the files in that folder (that is your database of music, back it up! or not) the one specifically for Audirvana 3.5 is: AudirvanaPlusDatabaseV2.sqlite
if you tried Studio, leave the rest there.

If the message was your preferences files that are corrupted, trash those two, if not, leave them there… Go to User… Home Folder… Library… Preferences… trash com.audirvana.Audirvana-Plus.plist and com.audirvana.Audirvana.plist in that folder
(those are A+ software preferences, back them up or not)

If you trash the preferences files, you will need you serial number.

Restart Mac.

Open Audirvana, choose a library folder (or add one or as many you want in the preferences panel, same place where you delete the faulty one) at first it will sync in top middle of main window…
LET IT GO, even better don’t try to adjust windows or edit files, even playing music while it is not finished… you’ll see the progress bar going… Could be long the first time depending on how large your library is, and your Mac is fast or not… go to sleep if it is too long :slight_smile:

Then when finished, shut down Audirvana, yes close it before playing a song

That way you will have your database from scratch saved without crashing.

Then copy that new .sqlite file to somewhere else on your mac as a backup, if a bug occur again, just close Audirvana and put in the .sqlite file from your latest backup in Applications Support… Audirvana Folder…
and reopen Audirvana… you will be there as the last backup was.

then reopen Audirvana, and try to play a song. :slight_smile:

1 Like

Thanks, I had tried all that, the Apple support guy helped me to track down and delete as many files as possible, but the problem is still there.

I’ve finally tracked down the files that were preventing the app from opening, and successfully re-opened. Quite a performance. It would have been a lot easier if there was an uninstall program available.