Unusual behavior upsampling to DSD in version 2.7

I’ve been experiencing a new behavior in my normal playback scenario…

I upsample/modulate all PCM files to DSD128 via r8Brain, and since installing version 2.7, when opening Audirvana Studio and selecting any track (PCM) the player does not initiate my DAC (TEAC UD-501) for playback via USB (something it has never done in previous versions).
Audirvana sees the DAC and when playback starts, the output sample-rate display shows playing as DSD128, but DAC doesn’t initiate for playback (It sits waiting)

To get Audirvana to initiate the DAC for playback, I must Deactivate upsampling and then reactivate upsampling “To DSD”, shutdown Audirvana, restart Audirvana, and then the DAC will be initiated as expected for playback. After this, playback continues to behave as expected…

Is this unique to me or has anybody else experienced this behavior?
I will do some more investigating…If I can’t solve this, will post my debug info and any new observations…

macOS 12.7.3

:notes: :eye: :headphones: :eye: :notes:

What DAC are you using?

I have removed my 2 comments…

Tried to reproduce your issue with my Chord DAC upsampling to DSD128. Played individual songs for an hour or so. I have been unable to reproduce your issue. Not much help I know…macOS 14.3.1 running 2.7.0

I should add that yesterday I was playing music to KEF speakers upsampling to DSD128 via UPnP to the KEF’s without any issues.

Thanks… :sunglasses:
Made some adjustments to the Audirvana bridge settings (iFi Audio iGalvanic 3) and Audio MIDI Setup… this seems to have cleared this behavior… still monitoring…

(2/26) – Seems that realigning the Bridge maximum sample-rate to ‘No Limit’, and increasing the sample-rate change latency to 1.5s, and also realigning the sample-rate settings in Audio MIDI Setup to the DAC maximum sample-rate of 384kHz, and trashing the Studio log file in the Audirvana ‘Application Support’ folder has solved the unusual behavior… So far, playback is as expected. :sunglasses:

:notes: :eye: :headphones: :eye: :notes:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.