uPNP issue

So I’ve been using A+ for about 6 weeks without issue. I use it in conjunction with an Allo Digione Signature with the Volumio OS on the Digione. A+ has always seen the Digione as the active uPNP network device. However, yesterday A+ crashed when I was doing some disc clean up on an attached external HD where music is stored. No music was playing at the time. However I had to close and restart A+. Since then the Digione no longer shows up as a network device in A+; however, the digione is on the network and operable, as I can use the Volumio network sorftware for music playback but it doesnt sound as good without A+. I have uninstalled and reinstalled A+ as well as reset the W10 OS to a date three days ago and neither solved the problem. The digione still does not show up as a network device in A+. One other thing I tried, but to no avail, was using the Dietpi OS on the Digione. At this point I’m pretty sure the issue is with A+. Greatly appreciate any help in solving this issue.

Do you have more than one network adapter? If so, disable all but the one you wish to use. Restart Audirvana as it uses the first one it sees.

Did as you suggested and all is well. Thanks for the suggestion.

I understand that the developer will in a future release enable Audirvana to be able to select a particular network adapter to use. Currently I guess you could call this a bug since it uses the first network adapter it sees as its default. If this adapter is not being currently used by the OS as your main network device then Audirvana will not show any UPNP devices to play to. That’s my understanding of the issue.

Well, this is a bug, most certainly.

I am an App / WEB developer, and have several Virtual Machines in my host Windows 10 system. I use the VM Network Adapter to bridge my Virtual Machines and have internet access in them.

If I run Audirvana Plus on the host machine, it will not see ANY of my UPnP renderers. I need to disable the VM Network Adapter and then UPnP devices are now selectable.

But disabling a network adapter is not a ‘fix’, its a temporary workaround and not one I can live with in the long term. I need to be able to keep my VMs running and have internet access. I cannot resort to withdrawing their network adapter from the mix just to be able to listen to music through audirvana.

Is there a timeframe for this fix? I am still on my trial period (which I have reported in a different thread as not working either and can no longer log into Audirvana) but I cannot see myself moving forward with a purchase if I am going to keep on disabling the network adapters every time I want to listen to music in my UPnP renderers.

Also, this should be documented on the FAQ, as I wasted 3 days of my trial period not being able to do anything due to this bug until I found a thread o a different forum detailing the possible work around. Even more problematic than the issue not being in the FAQs was that support issues are not replied at all, and even access to this forum was delayed pending activation.

So, I am wondering if, when this issues arise, will I be stranded with days and or weeks not being able to listen to music in the regular flow I expect to have with audirvana? If that is the case, it hardly seems like a solution that would be worth $75 + $10 of the remote app. I consider this to be a moderately expensive software given that most solutions are almost free or even open source. I am willing to pay a bit for having the first unfold of MQA done locally and then sent to the UPnP renderer, but, at this price point, and with all the issues, a yearly subscription to Roon costs almost as much, and I get all the added functionality.

I hope this is just an unfortunate series of events that just happened to coincide all together and that it is not the usual procedure for Audirvana support, as I have read good things from the community.

Looking forward to any answers regarding this issue and my other one (which is far more critical, as I am now unable to log into Audirvana with my trial license).

Best regards,

Good luck, the dev may read these messages but is pretty silent. There are unfixed bugs outstanding for a long time with this beta (my opinion) software. I’m not going to list them, I find it’s a waste of time. You’ll see the issues by reading the forum.