Upsampling setting used for downsampling - perceived bug

Hello,

  • I am playing a 88.2/24 FLAC file.
  • I use a pair of B&W MM-1s on my desktop which have a maximum resolution of 48/16.
  • I have set the [Upsampling] settings such that 88.2 => 44.1
  • To my surprise, 88.2 is played @ 48/16. This is clearly suboptimal.
  • Re-performed the test with a 192/32 file, which is mapped 192=>48 and it was fine.

Thanks for your attention,

Cheers,

Zsolt

Hello @OZZsolt, you don’t have to use upsampling for this, Audirvana will automatically use the maximum sample rate available for your device. Can you try without upsampling?

Hello Damien,
Thank you for your reply. You are saying, that “Audirvana will automatically use the maximum sample rate available for your device”, which is good, but I would think, that this may not be the optimum solution in some cases.
Let’s just take my case, that the B&W MM1 is capable of a maximum resolution of 48/16. Wimpy, I know, but I believe you know how this little fella performs on an office desktop. :slight_smile:
So when I am playing a 44.1 source, it is converted to the max resolution of the dac, which is 48/16 in this case. Even with upsampling deactivated.
1.) I think it would be better without resampling, 44.1 => 44.1
2.) If the source file has a higher resolution than the dac’s max resolution, then maybe an even number downsampling could bring better results. 88.2 => 44.1 and not 88.2 => 48.
I am not criticising, just this is what I have read so far.
Thank you and Kind Regards,
Zsolt

Please find an example here. I think what happens under the hood is:
44.1 MQA => First Unfold => 88.2 => max supported => 48.

I would have expected:
44.1 MQA => First Unfold => 88.2 => even number downsampling => 44.1.

Can you send me a copy of the “Debug Info” while your MM1 is selected? You can get it in Audirvana Settings>General>Debug Info

Note: By clicking on the Debug Info button, Audirvana automatically copies all its content, all you have to do is paste it in response to this message

Hi Damien,
Here we go, please find below.
Thank you and Kind Regards,
Zsolt

Audirvana Mac Version 3.5.44 (3574)
macOS 11.2.2 with 16384MB RAM

Trial version using demo license

SIGNAL PROCESSING:

Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins ACTIVE in offline mode
	AU plugin #0: Effect - Apple AUGraphicEQ ()
	AU plugin #1: None
	AU plugin #2: None
	AU plugin #3: None

UPSAMPLING:
SoX custom frequencies
SoX filter parameters
Bandwidth at 0dB = 99.5
Filter max length = 30000
Anti-aliasing = 100
Phase = 49

AUDIO VOLUME:
Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

LIBRARY SETTINGS:
Sync list: 1 folders
AUTO: /Users/zsoltboczen/Desktop/MusicCollection
iTunes/Music library synchronization: not synchronized
Library database path: /Users/zsoltboczen/Desktop/MusicCollection/AudirvanaSync/AudirvanaPlusDatabaseV2.sqlite

ACTIVE STREAMING SERVICES
TIDAL: Connected as HIFI

=================== AUDIO DEVICE ========================

CoreAudio audio path, buffer I/O frame size: 512

Max. memory for audio buffers: 1998MB

Local Audio Engine:
Exclusive access: Disabled
Integer mode: Disabled

Preferred device:
MM-1
Model UID:MM-1:19B5:0004
UID:AppleUSBAudioEngine:Bowers & Wilkins:MM-1:304:1

Currently playing in standard 32bit float mode
Device: 2ch Mixable linear PCM Interleaved 32bits little endian Signed Float, 8 bytes per frame 48kHz

Active Sample Rate: 48kHz
Hog Mode is off

Bridge settings:
Sample rate limitation: 96kHz
Sample rate switching latency: 0.5s
Limit bitdepth to 24bit: OFF
Mute during sample rate change: ON

Selected device:
Local audio device
ID 0x3b MM-1 Manufacturer:Bowers & Wilkins
Model UID:MM-1:19B5:0004 UID:AppleUSBAudioEngine:Bowers & Wilkins:MM-1:304:1

3 available sample rates up to 48000Hz
32000
44100
48000
Audio buffer frame size : 14 to 4096 frames
Current I/O buffer frame size : 512
Volume Control
Physical: Yes
Virtual: Yes
MQA capability
Auto-detect MQA devices: Yes
Not a MQA device, user set to not MQA
DSD capability: Unhandled
Device audio channels
Preferred stereo channels L:1 R:2
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: Yes

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1

Stream ID 0x3c 2 channels starting at 1
6 virtual formats:
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 48kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 44.1kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 32kHz
2 ch Non-mixable linear PCM Interleaved 16 little endian Signed Integer 48kHz
2 ch Non-mixable linear PCM Interleaved 16 little endian Signed Integer 44.1kHz
2 ch Non-mixable linear PCM Interleaved 16 little endian Signed Integer 32kHz

6 physical formats
2 ch Mixable linear PCM Interleaved 16 little endian Signed Integer 48kHz
2 ch Mixable linear PCM Interleaved 16 little endian Signed Integer 44.1kHz
2 ch Mixable linear PCM Interleaved 16 little endian Signed Integer 32kHz
2 ch Non-mixable linear PCM Interleaved 16 little endian Signed Integer 48kHz
2 ch Non-mixable linear PCM Interleaved 16 little endian Signed Integer 44.1kHz
2 ch Non-mixable linear PCM Interleaved 16 little endian Signed Integer 32kHz

Local devices found : 2
Device #0: ID 0x31 Built-in Output Manufacturer: Apple Inc. Model UID: AppleHDA:57 UID: AppleHDAEngineOutput:1F,3,0,1,1:0
Device #1: ID 0x3b MM-1 Manufacturer: Bowers & Wilkins Model UID: MM-1:19B5:0004 UID: AppleUSBAudioEngine:Bowers & Wilkins:MM-1:304:1

UPnP devices found : 0

Can you limit to 44,1 in the Bridge settings of Audirvana in the Audio device capability?

Hi Damien,
Sure, that certainly solves the issue for that specific case. I am not terribly worried about my simple desktop setup, I am just trying to convey, that I think integer upsampling or downsampling should be preferred over non-integer. You have great understanding of this, that is why I expected preference to integer sample rate conversion.
Anyway, Audirvana sounds great, actually I did not expect improvement from the Tidal client, but to my surprise it was immediately audible.
So just to reiterate, my dac’s limitation is 48kHz, but it is the principle, that counts.

  • when I play a 44.1 or 48 kHz file, then the corresponding 44.1 and 48 kHz outputs are selected respectively.
  • If however the source file, or stream has a higher sample rate, then the output sample rate is the maximum of the dac, which may result in non-integer downsampling.
  • In my example the source was a 44.1 MQA file, which was unfolded most probably to 88.2 internally, but then due to the limitation of the dac, signal was output as 48kHz. So we have gone through a non-integer interpolation, which is generally frown upon.
    In any case, beautifully sounding software, congratulations!
    Kind Regards,
    Zsolt