Using Windows Audirvana with GeekOut 1000

I have configured the DAC to use the ASIO type and all appears correct in the detected functionality. When I select a DSD64 file to play I get a consistent white noise and no music. The DSD indicator on the DAC does not light up.

I use this same DAC on the same computer with J River Media Center (24-26) with the same configuration and the DSD light comes on and the music plays fine. I have tried it before and after installing Audirvana to ensure it wasn’t a conflict between the two.

The computer is running Windows 10 X64 Build 1909.
Audirvana is version 3.5.10

Check that software volume control is disabled.

Are you using Native DSD or DoP?

I believe that this DAC does DSD over PCM. I don’t know how to change this in the Audirvana settings if it is possible. The settings for the DAC driver itself does not specify and I don’t believe I specify in Media Center settings either.

I do have the software volume control disabled. Same requirement for Media Center.

Oh I see where you specify PCM over USB to do DSD and it is set properly.

Native DSD steaming method: None: convert to PCM.

Nope, you need to select DoP 1.0.

I’m finding that most of the time when I start Audirvana and look at the settings for the device that it doesn’t always show configuration option to Native DSD steaming method. This is why initially I didn’t see the option. I have opened the app and closed it and even unplugged and replugged in the DAC and the option doesn’t appear.

Native DSD option might not appear if the DSD capability is not recognized, but DoP should always be available. Stick to DoP and you should be OK.

I don’t see the option. I notice that j river media center shows as a DAC as well and that does show the option.

Click in the speaker icon in the bottom right corner, and select your DAC. You’ll find it there.

I think the problem is that Audirvana doesn’t think it should allow me to choose the Native DSD streaming method for the GeekOut since it doesn’t show the option (see the attachments). The JRiver DAC (software) shows the option and allows me to select but that doesn’t solve my problem with the GeekOut.

DAC choices
JRiver DAC options:
GeekOut DAC options:

Now I get it, the whole DSD section is missing in Audirvana for GeekOut.

Try to switch the DAC to USB Audio Class 2 (profile 2) mode.

That’s it is now working!

I noticed that when I select ASIO configuration for the DAC that it shows the proper capabilities of the DAC but I cannot select the Native DSD streaming to select over PCM. In JRiver Media this option is available.

When I select WASPI I can select the streaming for DSD but the options for the DAC as a subset of it’s capability. It only shows DSD64 and not DSD128 or DSD256 supported by the DAC.