VST graphics issues

Audirvana updated to the latest version this morning and now VST plugins are running at about 3 frames per second. What happened?

Hello @WillieB,

What plugins are you using?

I use a package from Melda Production. I mostly use the MAnalyzer and Stereo Scope, which I believe can be downloaded for free at:

I also use fabfilter Pro-Q3 for parametric EQ. The visualizer in Pro-Q3 hasn’t worked since the early days of Studio, MAnalyzer has worked fine (except for some window sizing glitches that affect all VSTs) until now today.

Also, GPU usage on my system is running at 50% now, which is abnormal. I have an Nvidia RTX3090 GPU.


That’s really strange, your GeForce Experience driver is up to date?

Yes, I updated it this morning hoping that it would fix the issue, but no such luck.

Now that I have let Audirvana play for a while, the GPU usage does drop down to about 15%. That’s similar to how it has been in the past, so likely not an issue. Not sure why it was spiked up earlier. VST 's are still running slow, though.

i also use fabfilter Pro-Q3, works always well even in real time mode that i don’t use…
Maybe you are on PC, i’m on a Mac Ventura 13.0.1

1 Like

Different issue than my main concern at this point, buy yes, it works because you’re on a Mac. The problem is on PC only as far as I know.

1 Like

Ok so GPU is indeed still spiking. It’s been at 50% for quite some time now(most of the day) so when it spikes up, it stays there for a long time. It’s actually the exception where it calms down to 15-20%. As far as I’m concerned, a 2D application should not even be using 5%. It just doesn’t make sense.

After further testing, I have found that the problem only happens when in Kernel Streaming mode. my Digital Interface (Audio-dg DI20HE) uses Amanero 384 USB interface card. It appears that what is on the screen is actually ahead of what I’m hearing. I can see the transient occur on the analyzer plugin before I hear it, etc…

When I switch to WASAPI mode, I don’t experience the issue.

ASIO mode has NEVER worked with this Amanero interface/ASIO if trying to run VST in real-time mode. It’s fine if you disable real-time mode, which is pointless for Analyzers. It doesn’t work on 3.5 either. (not really the issue here anyway, but just more information that may be helpful)

Can you try to switch for the Standard Kernel Streaming optimization settings in the audio output settings and cehck if you have the same behavior.

Yes, it works fine under Standard. I never really noticed that setting. It was set to Extreme, but I don’t recall ever changing it. What does that setting do?

The main reason that I use Kernel Streaming is so I can enable “mute during sample rate change”.


It’s a new setting we added in the latest 2.2 update. Extreme can give you the best quality possible for Kernel Streaming. The Standard it how it was before 2.2 and High is the in between.

Interesting. In testing all three levels, the issue does worsen as the level goes up as expected. Standard shows the Analyzer exactly in time with the audio I’m hearing with normal frame rates. High shows the Analyzer slightly behind what I’m hearing with slightly degraded frame rates. Extreme shows the greatest delay between the audio and the Analyzer with the lowest frame rate. The audio sounds fine on all, it’s just the plugin performance that seems to degrade. As for the GPU spikes that I saw, is that because it is being used for additional processing?

The GPU spikes are not related to Audirvāna but more on the optimization of the plugin to handle bigger audio buffer.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.