VST3 issue with Windows (looks like a postage stamp)

I am using the Reveal+ Plugin from Audeze. Installed correctly and when I select it it shows up like a tiny postage stamp in the corner of a larger white window. I did not have any issues on my Macbook with the same plugin. This has to be an issue with Audirvana? What am I missing here? Any ideas?


Hello @RadDoctor, i have the same plugin on Windows and i don’t have this issue, are you using the latest version of the plugin?

I am using the latest plugin from 1/20 I think. I don’t see anything newer. I have tried everything. I downloaded a free EQ VST3 plugin and it works fine. Only the Reveal+ looks like a postage stamp. This is on my 4K Lenovo C940 laptop. I tried changing the resolution to 1920 which helps only minimally. It is still shrunk into the corner. Any ideas?

Hi RadDoctor.

It appears this issue is related to HiDPI support, and is common to many plug-ins that are still lacking such support on Windows. The reason this issue does not appear on macOS or Windows when the screen resolution is sufficiently low, if because macOS handles Retina resolutions at the OS level, and most Windows plug-ins are built/tested initially for 1080p or lower on a 1080p screen and/or in hosts that have not added HiDPI support yet.

With higher resolution screens and hosts adding HiDPI support coming into the picture fairly recently, it is the responsibility of the plug-in developers to update their plug-ins to add HiDPI support for Windows, except in the case where the host can disable HiDPI mode (as is the case for the Reaper 6 DAW, but seemingly not for Audirvana).

Therefore, it seems the temporary solution is to lower the screen resolution as much as possible when configuring the plug-in, and waiting for a future update to the plug-in to add HiDPI support (it is in the short term pipeline, so the wait should not be long).

PS: What is the name of the EQ VST3 plug-in that works correctly at a high screen resolution?

SonEQ works perfectly.