Wasapi and HDMI Audio

Hi nice to be here all. Trying the Windows Audirvana Beta.

I have a dedicated HTPC, Windows 10 64 bit, 16 GB DDR4 RAM, Nvidia 1050ti GPU, Samsung SSD system drive where applications installed. Music and all media on WD Red NAS drives in same HTPC. Connected via HDMI to an Onkyo RZ820 AV processor which has AKM DACs supporting up too 24/192. Connection to AVR from the HTPC is via HDMI connected to the Nvidia GPU .Sound device is pass through /bitstreaming via WASAPI Nvidia Onkyo AVR all setup in exclusive /bitstreaming mode. So the Onkyo is my DAC via HDMI and I pass audio using WASAPI from the PC which is the Windows 10 setup. The sound device is the Onkyo AVR from Nvidia GPU using WASAPI (I hope I am explaining correctly) I have a 7.1 speaker setup connected to the Onkyo.
I have currently Jriver MC 24 (set to Wasapi in Audio options) and Kodi 17.6 (Also Wasapi) which use this same Windows Wasapi sound device for music playback with no issues.

Audirvana sound device is set to WASAPI as well and it sees the same device as used by Jriver MC 24 and Kodi. Under the setup of this device it defaults to Stereo and will not allow me to choose 7.1 or anything else. It does display the connection as 24/192. It also does connect to the sound device. When attempting as step one to play any music I get the “cannot open device message” and that’s where it ends.

I have made sure that Jriver and Kodi release the device when not in use. As a double check I reboot the HTPC and try launching Audirvana first before launching anything else to work around the possibility that another application is still holding the device in exclusive mode. That does not help either.

Thank you. I hope I was clear.

Thanks for this report.
The issue seems to be the AVR offers both 2.0 and 7.1 streams.
Can you set in Windows sound settings, the output to the AVR in 7.1, and try again?

Hi Damien

Thank you for the response. The Windows sound settings are 7.1. I apologise I should have included this in my first email.

There must be some other application or service already using the device.
I’ve just tested here in 2.0, 5.1, 7.1 though HDMI to an AVR and all work.

Can you also check in the Advanced statistics panel of the properties of the AVR in Windows 10, that both “Exclusive mode” options are selected?

Hi Damien following on from my previous response, I confirm that under Windows Sound Settings I am already set to 7.1 when having the reported WASAPI to HDMI issues.

I since have done more testing to see if I can give you more information.

In Audirvana when playing to the WASAPI device I disabled upsampling completely in the settings for the WASAPI device, and I also as an alternative set upsampling to custom but set for example 44.1 to 44.1 , 48 to 48 etc etc so not really upsampling. In both these cases the WASAPI audio device is opened and the track is loaded. On the bottom left of the Audirvana Window you see 16/44.1 and on the right you see 16/44.1 so no upsampling. But playing is still a problem, the sound stutters continually and there are drop outs. Changing bit depth has no effect though so only the upsampling seems to have an effect or be a cause. If I again enable upsampling using X2, X4, or 192 the maximum for the AVR DAC the issue again is cannot open the audio device.

If I play to the Onkyo RZ820 as a UPnP device. That works and music plays upsampled as well but that results in the AVR changing mode to Onkyo Music server and switching away from Audirvana and PC screen on the TV. Switching back to Audirvana using the mode switch on the AVR remote control restores the Audirvana input and Window but this is not the behaviour I want. I wish to use WASAPI (or ASIO at a later stage but no ASIO drivers for latest series NVIDIA cards currently, blame NVIdia for that).

Please note as part of the test I confirm that Jriver MC24 plays upsampled files to the WASAPI device with no issue. Have not tried that with Kodi (playing upsampled). In Jriver I tested upsampling using SOX (their implementation of SOX is not as complete as that in Audirvana) and using the built in JRiver upsampling engine. In Jriver I upsampled 2X , 4X and all inputs to the device maximum being 192. JRiver handles bit depth automatically, or that’s their recommended method for Bit Depth ie automatic, so I did not play with bit depth settings. So no issues playing upsampled files to WASAPI HDMI audio devices using JRiver MC24. I am not by the way making this a JRiver vs Audirvana thread at all, I hope it does not look like that. I am using JRiver to test the environment. If Audirvana does not play and JRiver does not play, well then the issue is in the environment and not related to the Audirvana media software.

Phew sorry for all the detail, I hope I am clear.

Thank You.

Regards from Mike.

Hi Mike,

Have you checked that both “exclusive access” options are selected in the Windows properties for the audio device?

(Right click on the spearker icon in the taskbar, then select “sound settings”, then “device properties”, then “Advanced statistics”).

Also, can you try with the “large wasapi I/O buffer” option disabled in the low level playback options, in Audirvana Plus detailed audio settings?


Hi Damien,

I can confirm that both “exclusive access” options are selected in the Windows properties for the audio device.

I can confirm that I tried with the “large wasapi I/O buffer” option disabled in the low level playback options, in Audirvana Plus detailed audio settings. I tried this with upsampling “on” as both 2X, 4X and maximum for the device(192). The audio device opens, the track loads but I get the stuttering, and the dropouts that I do sd reported previously when no upsampling is selected. At times it actually even seems that the track is playing to fast while it stutters. Tried using both a 320 mp3 file, and a 16/44.1 FLAC file

Note that the Audirvana Audio channels in the WASAPI device setup still shows stereo and no option to change to 7.1 even though under Windows settings the audio device is set to 7.1 and under Windows properties when testing the test tone does cycle through through all 8 speakers correctly.

I am reasonably sure that my audio device setup in Windows is correct otherwise Jriver and Kodi would also have issues.

Thank You again


Can you send me by PM the Debug Info?
For this, go to the settings, general section. Then click on “Debug Info”. This copies its content to the clipboard.
Then do a paste in a PM.

We need to find out what is different in your setup, as here it plays nicely in all channel configurations to my 2 AVRs (Marantz SR-7002, Pioneer VSX-1131)

Hi Damien

Sending the debug info straight after this

Thank You

Hi Damien

As a further test to assist you I did the following

I uninstalled audirvana and then downloaded and installed again (build 1012 I think it is). I did not delete the library files so after reinstall my library was still there.

Under audio device settings I now have the option use as stereo device only and can leave that unchecked so now the device is seen as 7.1 channels. I have for now left it as 7.1, not tried stereo.

When playing with no upsampling, it now plays as it should no stuttering, no speed issues, no drop outs. 16/44.1 on the left as the file input and 16/44.1 on the right as the output per the device.

The minute I change the WASAPI audio device settings to upsampled, any upsampled settings I get the cannot open audio device error when trying to play a track. Change back to no upsampling and the track plays.

I have done no other testing beyond the above.

Further testing.

I noticed that the device was set to 7.1 channels but was only playing stereo (front L and R only). No upsampling as that causes the issue with “unable to open the device”

Then in the settings for the WASAPI sound advice I changed the 7.1 to Stereo. After doing that I cannot change back to 7.1 , no option. And when playing tracks I am back to stuttering, speed issues and drop outs.

So in summary

  1. Upsampling causes the "unable to open device " issue.
  2. System plays stereo even if device is set to 7.1
  3. Setting the device to stereo results in stuttering, drop outs etc on playing 16/44.1 tracks.