Win10 + Hugo2 + DSD512 playback issue

Hi friends,

I’m having some trouble playing a DSD512 (.dsf) file on Audirvana. The file is 3.05GB in size, stored locally on an nvme SSD. Other DSD512 files also fail to play.

I have successfully played DSD64/128 files previously. The drivers for the Hugo2 are installed and I’m using the ASIO output. The buffer size is much greater than the file size, so I don’t see that as the issue either.

The DAC is capable of DSD512 and Audirvana reports this too. I’m really struggling to figure this one out, so any help would be greatly appreciated.

Thank you all for your time and help.


Audirvana 3.5.44


Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

SoX not in use
SoX filter parameters
Bandwidth at 0dB = 99.5
Filter max length = 30000
Anti-aliasing = 100
Phase = 66

Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

Sync list: 0 folders
Library database path: C:\Users\user\AppData\Local\Audirvana\AudirvanaPlus\AudirvanaPlusDatabaseV2.sqlite

TIDAL: Connected as HIFI

=================== AUDIO DEVICE ========================

Max. memory for audio buffers: 68648MB

Local Audio Engine:ASIO 2 driver version 2

Preferred device:
ASIO Chord 1.05
Model UID:ASIO Chord 1.05
UID:ASIO Chord 1.05

Active Sample Rate: 1411.2kHz

Bridge settings:
Sample rate limitation: none
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:
Local audio device
ASIO Chord 1.05 Manufacturer:
Model UID:ASIO Chord 1.05 UID:ASIO Chord 1.05

12 available sample rates up to 1536000Hz
Volume Control
Physical: No
Virtual: No
MQA capability
Auto-detect MQA devices: No
Not a MQA device, user set to not MQA
DSD capability: DSD via PCM 1.0
Device audio channels
Preferred stereo channels L:0 R:1
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: Yes

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1
2 ch Integer PCM 32bit little endian 44.1kHz
2 ch Integer PCM 32bit little endian 48kHz
2 ch Integer PCM 32bit little endian 88.2kHz
2 ch Integer PCM 32bit little endian 96kHz
2 ch Integer PCM 32bit little endian 176.4kHz
2 ch Integer PCM 32bit little endian 192kHz
2 ch Integer PCM 32bit little endian 352.8kHz
2 ch Integer PCM 32bit little endian 384kHz
2 ch Integer PCM 32bit little endian 705.6kHz
2 ch Integer PCM 32bit little endian 768kHz
2 ch Integer PCM 32bit little endian 1411.2kHz
2 ch Integer PCM 32bit little endian 1536kHz

Local devices found : 2
Device #0: ASIO Chord 1.05 Manufacturer: Model UID: ASIO Chord 1.05 UID: ASIO Chord 1.05
Device #1: Realtek ASIO Manufacturer: Model UID: Realtek ASIO UID: Realtek ASIO

UPnP devices found : 0

Hello @vincantox,

Have you tried to drag and drop your track in the play queue? Does the track works this way?

Hi Damien,

Thank you for your message, I have tried drag and drop within the play queue, but unfortunately this does not work. The file is added to the queue and you can click play but unfortunately there is no output and the play time stays at zero for the track.

Can you remove the DoP setting you have enabled in your output settings in Audirvana?

Has the 2GB file size limitation now been fixed or could this be the problem?

With DoP turned off and the software converting to PCM, the file plays with a 32/352.8 kHz output, with the following from the debug:

Currently playing in Integer Mode:
Device: 2ch 32bits Integer, 8 bytes per frame 352.8kHz

Active Sample Rate: 352.8kHz

But this still isn’t the PCM bit-depth and sampling rate that would encapsulate the DSD512 signal. 32 * 352.8kHz is 11.29MHz, which is a DSD256 sampling rate; which I guess means a down-conversion is happening still.

I’m not sure if the comparisons can be made, but it sounded intuitive.

I have also just tried DSD64 .dff tracks which work fine. Audirvana’s upsampling also works up to, but not including DSD512.

That being said, I have been able to play DSD512 on this DAC on this computer for other purposes.

I wonder if there is a more verbose log file which looks into the ASIO engine and DoP process which could identify a possible issue?

Actually a ASIO driver should have the possibility to decode DSD natively, there is a problem with the driver from Chord and you should ask them to fix it as its’ not normal to not have the full capabilities of your DAC using ASIO.

Many thanks for the advice, I’ve contacted Chord about the ASIO driver.

A little further testing shows that DSD 512 transported with DoP simply will not work across the board with my setup. But as you mentioned native DSD works fine for 512 and I have tested this fairly extensively.

Are there any plans to implement non-DoP DSD transport in Audirvana?

I appreciate the support thus far, at least now I can certainly say that there is an issue with DSD512 & DoP for my particular setup.

It’s already implemented, just the driver needs to explicitly support it. There is no override feature for that.

I see, I hope I’ve understood correctly, if Audirvana sees the ASIO driver explicitly support native DSD, then it will offer this in addition to DoP within the drop down menu?

When testing other software, I am able to choose not to transport DSD over DoP and the stream works perfectly over ASIO for DSD512. I hope this is something I can do in Audirvana in the near future!

Yep, that’s correct. In Audirvana you can’t override this.