Android Remote v4.0.1, crash every time

Using Android remote v4.0.1 that I just updated today (2023-01-12). Connects fine but immediately crashes every time I try to do anything like bring up the player or tap search, playlists or settings at the bottom of the screen. It is completely unusable at this time.

I tried uninstalling and reinstalling the app, and also tried deleting both “cache” and “data”. None of it makes any difference. Connects and then crashes when I try to do anything. It was not crashing at all when I used it last night with the older version.

My phone specs:
Samsung Galaxy S22 5G (Unlocked / USA)
Android v13

Maybe I can download .apk of the previous version, please?

1 Like

Hi @dh2571,

You are talking about any item you have at the bottom of your screen, right?

It actually crashes about 2-3 seconds after connecting and showing the “My Music” page, with menu items at the bottom. I don’t even need to touch anything and it will still crash. Android says “Something went wrong with Audirvana because this app has a bug”. I also tried disconnecting all paired remotes in the Windows App under Settings > Appearance. I disabled the option “Ask for a pairing code” in case that helps. It does indeed connect correctly, only to crash 2-3 seconds later. My Audirvana Windows App is v2.2.3.

I have the same issue too. The android version remote keeps crashing after connection to my pc. Luckily, I am still trialling Audirvana Origin. I am now reluctant to buy Audirvana.

I have the same problem. App connects and starts normally but crashes as soon as I try to engage with it.

Both Audirvana Origin and Samsung Galaxy S22+ updated within 24 hours of one another and the remote stopped working after the Galaxy updated… Android OS now says that “app has bug” and that I should contact the developer.

In case it helps developers, I hadn’t installed any phone updates prior to the app starting to crash. The only thing that changed from before and after crashing started was the Android remote update. I did update the Origin Windows app very recently but I had successfully run the older remote version with the new Origin update.

Edit: Just remembered another weird issue with the new remote. When I enable the remote pairing code option in Origin, the remote app asks me to enter the code, which I do, but it tells me “identification token is invalid”. I obviously tried several times making sure I entered the code correctly. Perhaps an authentication issue with the new android remote?

I had the authentication issue, too. I typically authenticate by switching my phone to a remote access app that allows me to see my headless NUC that hosts the Audirvana app. Unfortunately, this last time, if I switched away from the Audirvana app to the remote app, something disconnected, the authentication code changed, and entering the code I last saw resulted in the token error.

I only was able to authenticate the Audirvana app by taking my phone to my office, attaching a monitor and mouse to my NUC, and then entering the authentication code into the app as I sat at the monitor.

IPad app still is working properly.

Same issue
After connection to the server . Crash

I try to open remote app with my tablet and phone and from today just crashes all the time.
I am definitely not buying app that has so many bugs, and company which invests so little into programming of basic simple things.

Hi guys. Maybe i Can help some of you

Yesterday, i have purchased the origin license after my trial period ended the day before.
Right after i installed the new purchased audirvana version 2.2.3. the remote app started crashing.
I was so frustrated because till then everything Worked perfectly.
I tried everything to fix the crashing.
Reinstall audirvana, tryed the previous 2.2.2 version. Reinstall the app. Firewall settings. Same wi-fi 2g vs 5g. Four different smartphones. Nothing helped.
The app only Worked for 2 or 3 seconds after connection attempt. Once i managed to quickly dial in the screen code to connect with my computer. It did connect but crashed right after the connection. So the app was completly useless. I was hopeless.

Today i was thinking about it with fresh mind.
Maybe it is the new app version, the 4.0.1. version. So i opened Google and searched audirvana remote app versions and found a website with 10 different remote app versions.
It is called There i chosed the latest 4.0. version. I first had to install the aptoide app and than it let me to install the 4.0. remote app version. Later i uninstalled the aptoide and only kept the remote app.

I dont know how safe it is to install the aptoide but the remote app 4.0. is now working perfectly as it did before the update.
Give it a try if you are as hopeless as i was.
Hope it helps some of you guys.

Have a nice day


It helped to me. Thanks. So obviously new “upgrade” messed thing up and made app even more buggier (Who knew that would be possible? :roll_eyes:)
It is unbelievable that it is so complicated to make such simple app working. I suspect the company is unwilling to put any decent money into programing (but asks a lot of money for such buggy experience).

1 Like

Thanks, @TomasJedno. That worked for me, as well.

1 Like

So, it is a new day morning and i have bad news guys.
Turned my system on to enjoy some music and the remote app started crashing again.
I tried all the versions available on aptoide and none of them is working.
I am really starting to regret my audirvana purchase. The remote app was the main reason a decided to go with audirvana because controlling these things with Team viewer on smartphone screen is a pain.
Should have gone with Jriver or something like that. Gosh, i am so frustrated. I want my money back if this is not getting fixed soon.

Is anybody using the remote app on iphone?
Is it crashing on iOS aswell?

Edit: some 15 minutes or so after posting this the remote app decided to work again and stopped crashing. I am listening and remotly controlling since then. I am keeping my fingers crossed haha. Using the version 4.0 from aptoide right now

Hi guys,

We are looking at the data we get from Google Console and are in contact with our developer on this.

I will report you back if I need more information from you.

I found that the Google Store automatically updated the 4.0 version from Aptoid, so it again would not work. I deleted the Store updated version and reinstalled the Aptoid one. I had the invalid remote access authentication issue again, so had to hook the NUC up to a monitor again, but I got it working.

Now, I have a new issue. The 4.0 version says that it is not a licensed product and therefore needs to be replaced with the Store version.

Also, no issues on an iPad with ios 16.2.

The Android version app needs addressing. I hope that it happens soon.

New version of the remote app (v4.0.2) seems to have fixed the issue, will report any further problems but it’s working ok as of right now. Cheers!

Hi guys,

for those having the crash, can you try to reproduce your issue with the 4.0.2 update of the Remote we have made yesterday?

@dh2571 , thanks for your feedback, good to know it fixed your issue :wink:

Unfortunately, version 4.0.2 is also not stable on Android 13
It is difficult to give a specific example because it happens in various circumstances - recently, for example, during a search.

NEW PROBLEM with v4.0.2: It appears to be unstable on Android 13 just like @lwojtulewicz mentioned. Error is “Audirvana isn’t responding”. Another weird thing is while the remote was running in the background, I was unable to do certain unrelated app updates in the Play Store. As soon as I manually closed Audirvana, I was able to perform the updates. Very weird indeed.

1 Like

Thus far, 4.0.2 seems to be working fine, although I haven’t spent a lot of time with it. Thank you for the update.