Audirvana MacOS UPnP problems with Big Sur 11.3

Using UPnP to stream to Volumio on a RasPi. Until 2 days ago, all was good. Then I updates MacOS and now there’s a problem. Audirvana sees Volumio and attempts to stream but fails. Volumio shows “HTTP Error 0” and “Error Failed to decode (file path)”.

I’m guessing something weird is happening at system level that’s borking UPnP?

Audirvana output direct to a DAC works perfectly fine.

Any help would be appreciated. Thanks!

Some more info - I have Audirvana running on two different machines. Both instances are the latest version, all settings are the same. One machine streams to RasPi/Volumio without problem, the other gets the Volumio “failed to decode (file path)” message.

Hello @music4me,

Can you check the firewall settings: In System Preferences > Security and Privacy > Firewall > Firewall Options > Automatically allow signed software to receive incoming connections check that this setting is selected and “Block all incoming connections” is not selected.

Have you also tried to restart your WiFi router ?

You can also try to disable IPV6 in the network adapter of your device

Thanks. Audirvana has Firewall privileges and I restarted the router just in case. IPV6 is off on the router and the Mac. Any other ideas?

Have you tried to reset the network configuration of your Volumio?

Yup, reset Network as well. Still no good.

Flashed another card with MoOde on it and I get the same issue - hit play on Audirvana, nothing happens, MoOde gives:

“Failed to decode http://XX.X.X.X:XXXXX/audirvana/audio_1_17.wav; CURL failed: Connection timed out after 10009 milliseconds”

I’m at a loss. I have two Mac machines running the same versions and settings of Audirvana, same wi-fi and ethernet settings, same firewall settings, IPV6 disabled on both, same everything I can think of. Both are using the same source (Qobuz) and playing the playing the same file/song. One machine works, the other doesn’t. On the non-working machine, MoOde gets the song title and artist name but doesn’t play and gives an error.

Here’s the error:

MPD error

Failed to decode http://XXXXX/audirvana/audio_0_26.wav;
avformat_open_input() failed: Invalid data found when processing input

I have a similar problem, MacBookPro to AlloUSBridge Sign running moOde (6.7.1 or 7.1.0 - both behave the same)

The moOde shows:

MPD error:
Failed to decode http:/xxxxx/Audirvana/audio_O_41.wav; CURL failed: The requested URL returned error:404 Not found

or

…CURL failed: Failed to connect to … port xxxx : Connection refused

But:
This happens in my case only, when I play a larger playlist (>120 titles in the play queue) and when I go in the remote app to the play queue and want to play a title, that was already played. So in other words I go back upwards in the queue.

When I restart moOde it takes a long time, best is to kill the power and a cold start.

But it will not solve the problem, since at this time always Audirvana is frozen and shows : “track loading”.
I have to quit A+ on the MBP and restart.

1 Like

Thanks I’ll play around and see if I can replicate what you’re doing. If I can get it to play even a single track one time it may give clues as to what’s happening.

Hi

I am having similar issues.
As soon as I upgraded to the latest version of Big Sur yesterday (11.3), Audirvana recognises the renderer, load the track, but does not play - stuck at 0.
Chg back to USB, and all Ok. Something in the new Big Sur update is causing an issue with upnp. Nothing else has changed. Was working perfectly for the past few years.

Thanks
Grant

Debug info belowAudirvana Mac Version 3.5.44 (3574)
macOS 11.3.0 with 8192MB RAM

Registered to Grant Butcher

SIGNAL PROCESSING:

Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

UPSAMPLING:
SoX with device max frequency upsampling
SoX filter parameters
Bandwidth at 0dB = 99.5
Filter max length = 30000
Anti-aliasing = 100
Phase = 66

AUDIO VOLUME:
Max allowed volume: 81.0812
Replay Gain: None
SW volume control: OFF

LIBRARY SETTINGS:
Sync list: 1 folders
AUTO: /Volumes/music/
iTunes/Music library synchronization: not synchronized
Library database path: /Users/grantbutcher/Library/Application Support/Audirvana/AudirvanaPlusDatabaseV2.sqlite

ACTIVE STREAMING SERVICES
TIDAL: Connected as HIFI

=================== AUDIO DEVICE ========================

Preferred device: CP-800 Model UID:B&W Group Ltd CP-800 UID:uuid:5f9ec1b3-ed59-1900-4530-d81ede20b93c

Currently playing to UPnP device at 24 bits 192kHz
Selected device:
UPnP device at http://192.168.1.16:8080/description.xml
ID 0x0 CP-800 Manufacturer:B&W Group Ltd
Model UID:B&W Group Ltd CP-800 UID:uuid:5f9ec1b3-ed59-1900-4530-d81ede20b93c

6 available sample rates up to 192000Hz
44100
48000
88200
96000
176400
192000
Volume control: No
MQA capability
Auto-detect MQA devices: No
Not a MQA device, user set to not MQA
DSD capability: Unhandled
Device audio channels
Preferred stereo channels L:0 R:1
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1
UPnP/DLNA supported protocols:
http-get::audio/L16;rate=44100;channels=1:DLNA.ORG_PN=LPCM
http-get:
:audio/L16;rate=44100;channels=2:DLNA.ORG_PN=LPCM
http-get::audio/L16;rate=48000;channels=1:DLNA.ORG_PN=LPCM
http-get:
:audio/L16;rate=48000;channels=2:DLNA.ORG_PN=LPCM
http-get::audio/mpeg:DLNA.ORG_PN=MP3
http-get:
:audio/x-ms-wma:DLNA.ORG_PN=WMABASE
http-get::audio/x-ms-wma:DLNA.ORG_PN=WMAFULL
http-wavetunes:
:audio/x-ms-wma:*
http-get::audio/vnd.dlna.adts:DLNA.ORG_PN=AAC_ADTS
http-get:
:audio/vnd.dlna.adts:DLNA.ORG_PN=AAC_ADTS_320
http-get::audio/mp4:DLNA.ORG_PN=AAC_ISO
http-get:
:audio/3gpp:DLNA.ORG_PN=AAC_ISO
http-get::audio/mp4:DLNA.ORG_PN=AAC_ISO_320
http-get:
:audio/3gpp:DLNA.ORG_PN=AAC_ISO_320
http-get::audio/x-caf:
http-get::audio/x-aiff:
http-get::audio/aiff:
DLNA 1.5: Yes
Gapless playback: Yes
Missing events workaround: No
Can play native DSD: No
Number of channels: 2
Use as stereo device only: No

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1

Stream ID 0x0 0 channels starting at 0
12 virtual formats:
2 ch Non-mixable linear PCM Interleaved 16 big endian Signed Integer 44.1kHz
2 ch Non-mixable linear PCM Interleaved 24 big endian Signed Integer 44.1kHz
2 ch Non-mixable linear PCM Interleaved 16 big endian Signed Integer 88.2kHz
2 ch Non-mixable linear PCM Interleaved 24 big endian Signed Integer 88.2kHz
2 ch Non-mixable linear PCM Interleaved 16 big endian Signed Integer 176.4kHz
2 ch Non-mixable linear PCM Interleaved 24 big endian Signed Integer 176.4kHz
2 ch Non-mixable linear PCM Interleaved 16 big endian Signed Integer 48kHz
2 ch Non-mixable linear PCM Interleaved 24 big endian Signed Integer 48kHz
2 ch Non-mixable linear PCM Interleaved 16 big endian Signed Integer 96kHz
2 ch Non-mixable linear PCM Interleaved 24 big endian Signed Integer 96kHz
2 ch Non-mixable linear PCM Interleaved 16 big endian Signed Integer 192kHz
2 ch Non-mixable linear PCM Interleaved 24 big endian Signed Integer 192kHz

0 physical formats

Current device transportInfo:
CurrentTransportState: STOPPED
CurrentTransportStatus: ERROR_OCCURRED
CurrentSpeed: 1
Current device MediaInfo:
NrTracks: 1
MediaDuration: 0:03:48
CurrentURI: http://192.168.1.8:49152/audirvana/audio_0_0.aif
CurrentURIMetadata:

dc:titleTrouble’s Coming</dc:title>
dc:creatorRoyal Blood</dc:creator>
upnp:artistRoyal Blood</upnp:artist>
upnp:genre</upnp:genre>
upnp:albumArtURIhttp://resources.tidal.com/images/b48e332a/2ddf/43ee/aa91/fb704b6e96f9/640x640.jpg</upnp:albumArtURI>
upnp:albumTyphoons</upnp:album>
upnp:originalTrackNumber1</upnp:originalTrackNumber>
upnp:classobject.item.audioItem.musicTrack</upnp:class>
http://192.168.1.8:49152/audirvana/audio_0_0.aif

nextURI: http://192.168.1.8:49152/audirvana/audio_1_1.aif
nextURIMetadata: <DIDL-Lite xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:upnp="urn:schemas-upnp-org:metadata-1-0/upnp/" xmlns="urn:schemas-upnp-org:metadata-1-0/DIDL-Lite/" xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/">
Oblivion Royal Blood Royal Blood http://resources.tidal.com/images/b48e332a/2ddf/43ee/aa91/fb704b6e96f9/640x640.jpg Typhoons 2 object.item.audioItem.musicTrack http://192.168.1.8:49152/audirvana/audio_1_1.aif
PlayMedium: NETWORK
RecordMedium: NOT_IMPLEMENTED
WriteStatus: NOT_IMPLEMENTED

Current device AVT service description:

<?xml version="1.0"?> 1 0 SetAVTransportURI InstanceID in A_ARG_TYPE_InstanceID CurrentURI in AVTransportURI CurrentURIMetaData in AVTransportURIMetaData SetNextAVTransportURI InstanceID in A_ARG_TYPE_InstanceID NextURI in NextAVTransportURI NextURIMetaData in NextAVTransportURIMetaData GetMediaInfo InstanceID in A_ARG_TYPE_InstanceID NrTracks out NumberOfTracks MediaDuration out CurrentMediaDuration CurrentURI out AVTransportURI CurrentURIMetaData out AVTransportURIMetaData NextURI out NextAVTransportURI NextURIMetaData out NextAVTransportURIMetaData PlayMedium out PlaybackStorageMedium RecordMedium out RecordStorageMedium WriteStatus out RecordMediumWriteStatus GetTransportInfo InstanceID in A_ARG_TYPE_InstanceID CurrentTransportState out TransportState CurrentTransportStatus out TransportStatus CurrentSpeed out TransportPlaySpeed GetPositionInfo InstanceID in A_ARG_TYPE_InstanceID Track out CurrentTrack TrackDuration out CurrentTrackDuration TrackMetaData out CurrentTrackMetaData TrackURI out CurrentTrackURI RelTime out RelativeTimePosition AbsTime out AbsoluteTimePosition RelCount out RelativeCounterPosition AbsCount out AbsoluteCounterPosition GetDeviceCapabilities InstanceID in A_ARG_TYPE_InstanceID PlayMedia out PossiblePlaybackStorageMedia RecMedia out PossibleRecordStorageMedia RecQualityModes out PossibleRecordQualityModes GetTransportSettings InstanceID in A_ARG_TYPE_InstanceID PlayMode out CurrentPlayMode RecQualityMode out CurrentRecordQualityMode Stop InstanceID in A_ARG_TYPE_InstanceID Play InstanceID in A_ARG_TYPE_InstanceID Speed in TransportPlaySpeed Pause InstanceID in A_ARG_TYPE_InstanceID Seek InstanceID in A_ARG_TYPE_InstanceID Unit in A_ARG_TYPE_SeekMode Target in A_ARG_TYPE_SeekTarget Next InstanceID in A_ARG_TYPE_InstanceID Previous InstanceID in A_ARG_TYPE_InstanceID SetPlayMode InstanceID in A_ARG_TYPE_InstanceID NewPlayMode in CurrentPlayMode GetCurrentTransportActions InstanceID in A_ARG_TYPE_InstanceID Actions out CurrentTransportActions LastChange string TransportState string STOPPED PLAYING PAUSED_PLAYBACK TRANSITIONING NO_MEDIA_PRESENT TransportStatus string OK ERROR_OCCURRED PlaybackStorageMedium string NETWORK RecordStorageMedium string NOT_IMPLEMENTED PossiblePlaybackStorageMedia string PossibleRecordStorageMedia string CurrentPlayMode string NORMAL NORMAL SHUFFLE REPEAT_ONE REPEAT_ALL TransportPlaySpeed string 1 RecordMediumWriteStatus string NOT_IMPLEMENTED CurrentRecordQualityMode string NOT_IMPLEMENTED PossibleRecordQualityModes string NumberOfTracks ui4 0 1 CurrentTrack ui4 0 1 1 CurrentTrackDuration string CurrentMediaDuration string CurrentTrackMetaData string CurrentTrackURI string AVTransportURI string AVTransportURIMetaData string NextAVTransportURI string NextAVTransportURIMetaData string RelativeTimePosition string AbsoluteTimePosition string RelativeCounterPosition i4 AbsoluteCounterPosition i4 CurrentTransportActions string A_ARG_TYPE_SeekMode string TRACK_NR REL_TIME A_ARG_TYPE_SeekTarget string A_ARG_TYPE_InstanceID ui4

Current device RootDevice description:

<?xml version="1.0"?> 1 0 DMR-1.50 MS_DigitalMediaDeviceClass_DMR_V001 MediaDevices BridgecoCE2DM870_0xBD VEN_14E7&DEV_0001&REV_01 Multimedia.DMR QPlay:1 SeekOnPaused,WHA urn:schemas-upnp-org:device:MediaRenderer:1 CP-800 B&W Group Ltd CP-800 Stereo Preamp Processor CP-800 CP-800 D81EDE20B93C uuid:5f9ec1b3-ed59-1900-4530-d81ede20b93c 123810928305 image/jpeg 48 48 24 /BCO_device_sm_icon.jpg image/jpeg 120 120 24 /BCO_device_lrg_icon.jpg image/png 48 48 24 /BCO_device_sm_icon.png image/png 120 120 24 /BCO_device_lrg_icon.png urn:schemas-upnp-org:service:RenderingControl:1 urn:upnp-org:serviceId:RenderingControl /RenderingControl/desc.xml /RenderingControl/ctrl /RenderingControl/evt urn:schemas-upnp-org:service:ConnectionManager:1 urn:upnp-org:serviceId:ConnectionManager /ConnectionManager/desc.xml /ConnectionManager/ctrl /ConnectionManager/evt urn:schemas-upnp-org:service:AVTransport:1 urn:upnp-org:serviceId:AVTransport /AVTransport/desc.xml /AVTransport/ctrl /AVTransport/evt urn:schemas-smsc-com:service:X_WholeHomeAudio:1 urn:schemas-smsc-com:serviceId:X_WholeHomeAudio:1 /WholeHomeAudio/desc.xml /WholeHomeAudio/ctrl urn:tencent-com:service:QPlay:1 urn:tencent-com:serviceId:QPlay /QPlay/desc.xml /QPlay/ctrl http://192.168.1.16

UPnP devices found : 6
Device #0: ID 0x0 Marantz SR7011 UID: uuid:1cfe6f03-2860-12cd-0080-0005cd716938 Location: http://192.168.1.13:60006/upnp/desc/aios_device/aios_device.xml
Device #1: ID 0x0 CP-800 UID: uuid:5f9ec1b3-ed59-1900-4530-d81ede20b93c Location: http://192.168.1.16:8080/description.xml
Device #2: ID 0x0 Marantz SR7011 UID: uuid:d7530943-817e-1d6f-0080-0005cd716938 Location: http://192.168.1.13:60006/upnp/desc/aios_device/aios_device.xml
Device #3: ID 0x0 Marantz SR7011 UID: uuid:efdb241a-9da9-101d-0080-0005cd716938 Location: http://192.168.1.13:60006/upnp/desc/aios_device/aios_device.xml
Device #4: ID 0x0 Marantz SR7011 UID: uuid:8453496f-86d0-5bed-7a55-1027014b62c2 Location: http://192.168.1.13:60006/upnp/desc/aios_device/aios_device.xml
Device #5: ID 0x0 Marantz SR7011 UID: uuid:5d8b6568-7163-171f-cdaf-67a744f11c89 Location: http://192.168.1.13:60006/upnp/desc/aios_device/aios_device.xml

CoreAudio audio path, buffer I/O frame size: 0

Max. memory for audio buffers: 3726MB

Local Audio Engine:
Exclusive access: Enabled
Integer mode: Enabled

Local devices found : 3
Device #0: ID 0x38 Built-in Output Manufacturer: Apple Inc. Model UID: AppleHDA:108 UID: AppleHDAEngineOutput:1B,0,1,2:0
Device #1: ID 0x3f CP-800 Manufacturer: B&W Group Ltd Model UID: CP-800:19B5:0009 UID: AppleUSBAudioEngine:B&W Group Ltd:CP-800:2144572:1
Device #2: ID 0x2d WiDisplay Loopback Sound Virtual Device Manufacturer: BUGUN Software Co., Ltd Model UID: WiDisplayLoopbackSoundVirtualDevice:WiDisplay Loopback Sound Virtual Device UID: WiDisplayLoopbackSoundVirtualEngine:0

Yup. Exactly.  

Hello @GrantBu, @music4me and @EMW,

On my side I have not made the update to 11.3 for the moment but as soon as I will do, I will try to reproduce your issue.

1 Like

Any updates on this issue?
I have upgraded to Big Sur 11.3.1 this afternoon, but unfortunately that did not have any impact. I see that someone spoke of Audirvana 3.5.45 - is that avaiable as my system says I am up to date on 3.5.44

Well, I guess with Studio and subscription this issue will never get fixed for those of us on 3.5 :frowning: