Audirvana Remote Disconnect from Audirvana on Windows 10

About three updates of Audirvana ago on Windows 10 I’ve been fighting my iPad’s Audirvana Remote not connecting or connecting poorly and slowly. I found a definite fix. Fix is:

In Audirvana Settings, Miscellaneous
Turn OFF “Prevent Screen From Going to Sleep”

I am running Audirvana 3.5.10 on Windows 10.

PLEASE NOTE: Every time Audirvana Windows 10 app updates it defaults back to this Prevent Screen setting being turned ON, very annoying!

I am running Audirvana 3.5 on a Windows 10 PC, and Audirvana Remote on an iPad. I have no problems connecting the two , and when they are connected they work just fine.

The problem, of course, is that the remote app loses connection with the main program. A lot. And when the connection is lost I have to reboot the program on my computer and the remote on my iPad. Or else I just have to continue operating the program from my computer. Either way, this of course negates the whole benefit of the Remote app, and without the remote app Audirvana is worthless to me.

A few bits of information:

  1. This is not a problem with my network or wi-fi. Like I say, the programs connect initially just fine. When the disconnections occur, music continues streaming on Audirvana without a glitch, and my iPad continues on without a glitch. My wi-fi is very fast, and I stream things all the time without a problem.
  2. The problem is clearly in the connection between the Audirvana software and Audirvana Remote. I don’t think it’s a hardware problem. For example, I’ve used JRiver with its remote app for years without ever encountering this problem.
  3. The connection is not lost because one of the devices is going to sleep. I have set both devices not to sleep, and their screens remain on through the loss of connection. I have turned OFF “Prevent Screen From Going to Sleep” as per the advice above.
  4. I have set my computer to “private network” and have turned off the private network firewall. All the Audirvana apps are set on “allow” for both the private and public network firewalls in any event.
  5. The loss of connection is somewhat unpredictable. If I’m actively using the remote it may go a while before losing connection. More often, though, it loses the connection every few minutes. If I cue up an album on the remote and then leave it alone, it will always lose connection before the album is done. The loss of connection occurs even though I am running no other programs/apps on either device.
  6. When the connection is lost and I get the screen that tells me so, my computer is sometimes shown as an available computer. But clicking on it does nothing.
  7. I have reported the problem to Audirvana support, but they are unresponsive.

I’m pretty bummed that I paid money for Audirvana and the Remote and now they’re pretty worthless to me. I’d be very grateful for any suggestions anyone may have. Thanks!

2 Likes

I too am disappointed with the implementation of the remote. I have just upgraded to the cross-platform version.

Today, I have installed Roon trial just so I can compare the Roon controller (remote) and it works flawlessly with the Roon core.

It breaks my heart that the author of Audirvana can’t make this thing to work PROPERLY.

1 Like

My Windows 10 laptop running Audirvana just did some Windows self-updates and my situation has gotten markedly worse. After say twenty minutes of inaction, my Audirvana Remote (running on iPad) won’t reconnect unless I turn Windows Defender Firewall (running on Windows 10 Lenovo laptop) completely off, even though I have it set (just like before) to allow Audirvana through the firewall. Nothing is going to sleep. I think it’s Windows Defender Firewall blocking certain requests from Audirvana Remote that we users have no idea how to set Firewall to allow.

Currently I can always connect if I turn off Windows Defender firewall completely, and I can even then turn Firewall back on and keep functionality for a while, But eventually I will experience the infuriating refusal to reconnect requiring me to turn off Firewall again to reconnect.

Audirvana developers, please investigate and fix this!

1 Like

Ok here’s an update to my last post that might help. I found multiple instances of Inbound and Outbound Rules in my Windows Defender Firewall Advanced Settings, one set apparently from a much older version of Audirvana. My Audirvana Remote connection problems started when Audirvana first updated, and were exacerbated by Windows 10 updates, so this seemed suspect.

I then deleted all the mess of Audirvana Inbound and Outbound Rules and started over by launching Audirvana again and letting Windows Defender decide what fresh Rules to create (need to make sure “Notify me when Windows Defender Firewall blocks a new app” box is checked in Firewall > Customize Settings, then tell it to “Allow” for Private Networks).

Windows Firewall then created two Inbound Rules, one for Audirvana Private UDP and one for Audirvana Private TCP, and it created zero Outbound Rules, and so far the connection is working. Before I did this rules refresh I could not connect at all without disabling Windows Defender Firewall. Now I can connect with Firewall turned on so I think I’m on to something.

We’ll see if connection holds with just these two Inbound Rules. If not I will try going in to “Allow an app or feature through Windows Defender Firewall” and telling it to allow Audirvana through which I believe will create a set of Outbound Rules in addition to the Inbound Rules and test again. By the way, if you don’t see Audirvana in your “Allow an app…” list you need to go into Add or Delete Programs Control Panel and Repair Audirvana.

I will report on if this is a fix. Isn’t this fun?

Addendum to above:

I had to create one Outbound Rule by repairing Audirvana, I assume because Outbounds create themselves upon app installation and I deleted them when I did my rules clean out. I also deleted a 2019 installation of Audirvana Plus that I didn’t realize was still there in case it was causing problems.

Control Panel > Add or Remove Programs
Select Audirvana > Advanced Options > Repair

Now I have two Inbound Rules (created by Firewall when I said “Allow”) and one Outbound Rule (created by “Repair” of Audirvana) where before I had six and three respectively.

Still testing… so far so good.

I am very sad to report that rebuilding firewall rules was a fail. I still have to completely shut off Windows Defender Firewall to have reliable connectivity between Audirvana Remote and Audirvana that does not drop over time and stay dropped.

I am out of ideas.

I had to double check that I didn’t write your post! I have done the exact same troubleshooting with the same results. When connected, it works great. Within a few minutes, it drops connection. I close the application on my Windows 10 PC, reopen, and the android remote, which has been giving the “No computer was recognized” message, instantly connects again.

Has anyone tried just keeping Windows Defender firewall off permanently and using a free firewall software application like Avast, AVG, etc.? I haven’t used those in years as they seem to slow the computer down, and ultimately I felt safe enough with Windows Defender, so why bother with a separate firewall… but now, maybe?

@iceninejim Stick to Windows Defender…

@Damien3 it worked for a while, however yesterday I only have one client open which is my Samsung A51 and sadly it doesn’t connect. I have no idea why suddenly it didn’t want to. I’m a member of the Hegel Facebook group and have recommended Audirvana (before I use the remote) and most of them have a problem. Have a look.

Veganeyes’ experience is the exact same one I’m having. I’ve sent an email to Audirvana support but I doubt I’ll see a response seeing as how others have said they aren’t getting anything back.

This is ridiculous and infuriating. You cannot make a product that does not work and charge money for it.