Bought Qobuz Hi Res Files, Audirvana plays just 16 bit

Hi there,

I bought, for test purposes a 24 bit Hi Res album from Qobuz. Trying to play this with Audirvana 3.5.38 results in a 16 bit playback! The funny thing is, using the Qobuz App, everything is fine. Issuing the playback of the same file via the file browser, the MacOS Finder, Audirvana is also playing the file with 24 bit.
Who or what is doing what wrong? Any substantial feedback is appreciated.

What does it say in the lower left corner? Did you add the files to the library?

Hello bitracer,

the lower left corner says “FLAC 16/44,1kHz Stereo” when the playback is issued via Audirvana.
In case the playback is issued via the “Finder” Audirvana says in the lower left corner “FLAC 24/96kHz Stereo” and yes, there’s a difference in the sound quality.

Yes the files are part of the library.

Kind regards

Hello @mahmue,

When you downloaded your album in Qobuz, are you sure you selected the proper sample rate?

Also check the file paths. These are probably different files.

Hello Damien3,

yes I’m very confident that I downloaded the wanted sample rate. Just to clarify, in my opinion the file must be the same. I tried different locations on my Mac, a) the NAS and b) the local SSD the result is the same. Issuing the playback via the Audirvana GUI, section bought music, the playback is 16bit/44.1kHz, accessing the same file via the Finder, right click - open with Audirvana, it’s 24bit/96kHz.
Maybe my thinking is not correct, but the only way this can happen is that regardless the fact that I try to play a bought file from my local storage, the software is issuing the playback online at Qobuz and my streaming plan is the HiFi one (16bit,44.1kHz)
Do you need any debug info?
Kind regards

Hello bitracer,

as I wrote in my replay to Damien, as I firstly noticed this issue I tried different file locations, NAS vs local disk, without any difference in the result.

I would be more than happy to check the file path for playback of bought music through the GUI but I’m unable to do this as I don’t know how.

The file in question is located on my NAS and this path is part of my defined library path in Audirvana.

Kind regards

Can you send me one of those file at If it’s above 20Mb let me know so i can give you a link to upload it.

Hello Damien,
each file of the album is bigger than 20Mb, therefore I think I need the mentioned link.


I took a look at your file and it is identified as 24/96 file in Audirvana when it is added from a folder, the fact that it is not detected as the right frequency and depth in the purchase section might be related to the API of Qobuz but we will need to take a look at it.

Hi Damien,

you made my day. Meanwhile I started thinking that I’m a fool :wink:

Thanks for your investigation so far and good luck with the API of Qobuz. Hopefully you’re more successful than I was in the past with tickets at Qobuz to adress simple sort issues in their iOS App.

Thanks and kind regards

Try to play file via app ,instead of via the file browser.

I did some intensive testing of playback of Qobuz files when I first purchased Audirvana, Perhaps 2 years ago. I downloaded the same track from Qobuz and from HDtracks, and also streamed it from Tidal and from Qobuz. The downloaded versions were bit-perfect identical. In playback, however, the streamed version from Qobuz didn’t even sound as good as the streamed version from Tidal, even though the Qobuz version was 24/96 vs. Tidal’s 16/44.1. The stereo soundstage with Qobuz streaming is significantly degraded. Audirvana left and right showed 24/96 playback, yet it didn’t sound nearly as good as the downloaded file.

It took me the better part of a year to get Sebastien (the newsletter guy) at Qobuz to admit that they limit the bandwidth of streamed content. He didn’t specify how but my guess is that they combine the two stereo channels into sum and difference streams and compress the difference stream. That would allow them to cut the bandwidth of streamed content, nearly by half. The result in critical listening is a compressed soundstage.

Sorry, I know that this has little to do with your problem, but the point is that even when reported otherwise, streamed content from Qobuz had deliberately reduced bandwidth. Also, you may need to be persistent when it comes to tech support from Qobuz.

Regarding your particular problem, are you sure you aren’t selecting your test file from under the Qobuz heading, below your library? Once you download the file, the original source becomes irrelevant. You should be able to disconnect your computer from the internet and still listen to your file. In fact, why don’t you try turning off Qobuz playback in Audirvana to test this. Go into your settings and uncheck Qobuz. That shouldn’t affect playback of the track if you’re playing it from your Audirvana library on your NAS, but if you’re playing the track by streaming it from the Qobuz server, you’ll be blocked.

1 Like

Hi Steve,

thank you for sharing your experience with Qobuz, indeed very interesting. In regards to my problem, I believe Damien has figured out why the system behaves as it does. In addition I figured out that playing the bought files from the local library is fixing the problem. Initially I issued the playback from the Qobuz section, the point “Bought Music”.
However, I believe there’s a bug, or at least a totally different understanding/approach, in the API

Hi Damien,

today, while hearing some music from my local library, I scrolled through the files and “found” my bought Hi-Res file from Qobuz, selected it, clicked play and voilá the playback was 24bit/96kHz using Audirvana. In other playing the bought files from the local library is fixing the problem. Same storage location, other behavior. I believe this finding emphasized your investigation towards a bug in the API, doesn’t it?
Best regards

Hello @mahmue, I would like to try something with you to determine if it works or not. This is a bit technical and I understand if you don’t want to do it. This will be a setting to change in your database:

If you don’t have a database visualization tool you can use this tool:

To get your database with the Finder:

  1.  Open its Go menu
  2.  Pressing the option (or alt) key, and maintain it pressed. This reveals the Library command in this Go menu.
  3.  Click on this Library command
  4.  In the Finder window that opens, navigate into Application Support, then Audirvana
  5.  You’ll find there the file AudirvanaPlusDatabaseV2.sqlite (This is the one for Audirvana 3.5, the other is for the older version 3).

You need to close Audirvana to be able to open the database.

When you open it, go to the tab “Browse Data” (“Parcourir les données” in french):

You then need to go in the Table “PREFERENCES”

and change the the data next to StreamingQualityqobuz to 3

After doing this, save the change, close the visualization tool and open Audirvana again and try to play a song form the Purchased section. Does it is still in 16/44?

Hello Damien,

I’m fine doing this, the only problem, neither me nor my OS knows with which program should the database be opened?
I have no clue

You need this

Hello @mahmue, you need to be able to open the database and see what’s inside.

Hello Damien,
I was on the road the last few days, today I followed your recommendation, no change in the behavior, still 16/44 when using the Qobuz section in Audirvana.

These are the streaming entries int he DB with regards to Qobuz

StreamingQualityqobuz 3
StreamingQobuzActiveTag1 6
StreamingQobuzActiveTag2 0
StreamingQobuzActiveTag0 0

As the bought files are part of my local music library as well, the interesting thing is when I’m issuing the playback from there, in other words from the local library section of Audirvana, the playback quality is 24/96