Duplicate tracks - is it back again in Studio?

The dreaded duplicate tracks item has reared its head for me again, I thought this was finally behind me in V3.5 but AS seems to be suffering the same problem.

I am not certain, but I think the action that triggered this was adding a few album cover jpegs into my music library folders while AS was running, now I have a number of albums showing duplicate tracks in exactly the same way it used to happen before. The affected albums seem to be ones that have been played recently and not those I actually added new covers to.

Anyone else encountered this with AS?

Yeah, I have this problem with duplicate tracks in my local library. I’m not sure what triggered it, because I haven’t been adding anything. Some albums are fine, some have some duplicate tracks, some have all the tracks duplicated.
I posted about this before, but it remains unsolved and my local library therefore unplayable.

Hello,
I had also the same problem. It seems that when importing the 3.5 DB to Studio , the imported mounted volume pathname does not resist to a reboot of my Mac : all tracks are duplicated with another second (stable this time) pathname .
To avoid this problem I forced Studio to not updatethe DB ( copying and saving the 3.5 DB with another name). I asked then to sync all my mounted directories in Studio from scratch : no more duplicates (even if I reboot).

Hi, thanks for the tip.
If I understand you correctly, what I have to do is prevent AS to import the database of 3.5 but instead create it’s own.

Sounds promising. I’ll try that tomorrow and post the results.
Thanks.

Forcing AS to create its own database from scratch is worth a try, it’s odd though as this issue didn’t raise it’s head again until last week - I had been testing AS since the release without any duplicates. I must have done something to start this off.

So far I have deleted the AS database so that it re-imports (a known to be good) V3.5 database which seems to work but it doesnt prevent the duplicates from happening again. Déjà vu.

Yeah, I tried that, but it didn’t work. Unfortunately.

Sorry that it didn’t work for you , it works for me .
By the way, I reported this problem in this forum in this post: " Tracks are doubled when local music is imported" on june 1st , so more than one week ago.

Hm, my first post about it was 22 days ago. Damien replied, i answered but never received an answer back. But I’ll try the other solution. Hope that’ll work.
Cheers

In case you don’t have a backup… you can redo your database…

If you have Playlists that are important export them first to desktop and save them in a folder…
when Audirvana is reset, you can re-import them back in one shot. sadly to this day, the folders
they were in if so, are not back, you have to do them again…

Apple hide the Home Folder in User Library at some time depending on OS System…
When you have clicked your Home Folder, and cannot see the Library Folder in there,
just do a ‘‘cmd J’’ to show the folder settings preferences and see at the bottom…
click Show Library Folder and then you’ll have access to the rest forever.

If you continue and trash the database, you will lose also the play count number
of how many times you played those songs… if important to you or not.

Go to Audirvana preferences panel and delete with - sign your music folder(s) there.

Close Audirvana.

Go to User… Home Folder… Library… Applications Support… Audirvana Folder…
Trash All the files in that folder (that is your database of music, back it up! or not).

Restart Mac. Restart Audirvana.

Add a music folder when asked or go to prefs again and add one with + sign.
LET IT SYNC, even better don’t try to adjust windows or edit files, even playing music
while it is not finished… you’ll see the progress bar going… Could be long the first time
depending on how large your library is, and Mac is fast or not…
go to sleep if it is too long. :slight_smile:

Then when finished, close Audirvana, yes close it before playing a song…
That way you will have your database from scratch saved without crashing or bugs.
Then copy the .sqlite file to somewhere else in a folder as a backup for today.
Do this as often you can, if you do many edits in your library or add many CDs, that way
if a bug comes back or doubles, you’ll have a not so far library to put back in the same place without bugs.

When copied, reopen Audirvana, and play a song. :slight_smile:

3 Likes

Not only do I have a problem with duplicates, but AS is also adding its own (Musicbrainz?) metadata to the Artist field. Below is a copy of a message I just posted to another forum:

I’ve just installed AS for the first time (v1.4) a couple of days ago, and suddenly it is showing duplicate tracks for most of my albums. Furthermore, most of these duplicates (but not all) have different entries in the “artist” field, usually in addition to what I’ve meticulously entered previously. Take the following as an example:

In this instance, the “Artist” was previously entered as “Reiner/CS”. AS not only duplicated the tracks, but it also added “Sidney Harth (Violin), Fritz Reinter (sic), Chicago Symphony Orchestra, Chicago Symphony, Fritz Reiner," to what I had previously entered. This extra info is obviously coming from an outside music database (Musicbrainz?) and I DON’T WANT IT!!!

Other albums show differing combos of artist metadata, alternating with my own and/or from the outside. Some even show the WRONG artists!

FWIW, the “Save recovered track ID in your local files metadata” in Preferences is set to OFF.

This was not a problem at all with v3.5 and earlier.

Also, these issues did not show up until the second day or so of me using AS. When I first installed the program, everything seemed OK (though I noticed a few—just a few—duplicated tracks while spot-checking). On the second day, AFTER AS had seemingly finished “analyzing” my files, it started analyzing all over again, which I think has led to the duplicate tracks and extra metadata.

Any way to fix this???

Thanks RunHomeSlow. This is an excellent and probably foolproof manual.

Good advice :+1:

It can be very frustrating sometimes, just go bang your head against the nearest wall, it’s much easier.

In my case duplicates occur only on favorited tidal tracks. Local library and tidal manual playlists are fine

Audirvana does not put this info in your music files, but in it’s own database. What you are seeing is maybe frustrating (and I don’t think you can turn that info off), but rest assured, this is only internal in Audirvana… your music files are not affected.
You also can choose to not look at this info in Audirvana, maybe that helps with the frustration :wink:. It is there, but it does not hurt anything in your music collection or library.

As Andy said, if you did not check the option allowing AS to write the tug to your files, they remain save.

This mess is actually supposed to be beneficial for you, because it is supposed to help you to discover new artists and more music that you should enjoy on the streaming services.

Well, this gets more confusing by the day. I had cleared the duplicates problem by deleting the database and starting again, letting AS import a good (duplicate free) V3.5 database, all seemed OK, other than AS was doing its ‘analysing’ thing again, but we all understand what’s is going on there now.

This morning I start up AS to see it spending a while ‘synchronising’ - the upshot is that I now have many albums with duplicates again. I have just checked through a random selection of albums and quite a lot have duplicates.

Strangely, nothing has changed in my local music library, I haven’t fiddled at all, no new album covers, no new albums, nothing.

When you just want to play some music the question has to be asked - do I really need to waste time with this?

My AS trial ends today (I have requested an extension) but I think it is time to just give up and go back to V3.5, perhaps revisit AS sometime in the future.

Having tried what you did try, you may want to try this:

  1. Create a backup of your A3.5 database. by copying it somewhere else.

  2. in A 3.5, preferences, erase all the music files folder(s) you had setup.
    You have now in A3.5 a database with all your playlists, all your connections to streaming, and no music at all. You can leave A3.5

  3. Launch AS, and import the A3.5 database when prompted.

  4. Once the A3.5 database has been imported, go to AS preferences and indicate the location(s) of your music files, as they were in A3.5.
    AS should now proceed with the synchronisation and analysis of the music files.

  5. You can now go back to A3.5 to restore its database from the backup you made in 1.
    All should be back as it should be in A3.5.

  6. When AS has finished synchronising, you should hopefully have all your music in the same state as in A3.5, without duplicate. :crossed_fingers:

Thats an interesting method, not one I have tried before.

I will give it go soon when I get some spare time, thank you for the suggestion.

Well, I decided to trash my AS .sqlite database files (as well as the same files for v3.5) and essentially start all over, per RunHomeSlow’s directions earlier in this thread. So far, so good: everything synced perfectly, with no duplicates (yet!), but while doing its “analyzing”, it’s still appending stuff to the “Artist” field as I mentioned before–not sure if I can live with that, but at least it’s not actually writing this stuff to my music files. Only several more hours to go–fingers crossed for no more duplicates!