Hoping to experience MQA

It seems that setting up a system to successfully play MQA-encoded files appears to be a lot harder that I imagined it would be.

I having been corresponding with iFi Audio about MQA for some weeks now - I have three of its DACs, two of which support MQA rendering - trying to solve the problem but have had little success so far. At that time I was using different software to play files and it was through the company that I got to know about Audirvana, and I’m certainly glad of that for I have been really delighted with it when playing both standard PCM and DSD material. The degree of transparency experienced from most recordings I’ve been listening to has been startling, to say the least.

The DAC I have connected to my main system (I have a smaller one which I use when I’m computing) is an iDSD Micro Black Label and it has something of a history. It is my understanding that, when it was initially released, the LED colour on its upper surface - to indicate the audio format being played - was yellow for MQA-related material, but that was changed to magenta at some later stage, presumably to avoid confusion with other formats that display yellow. I have it on good authority from the iFi Audio Help Desk that my particular DAC should display magenta from the serial number I supplied. The firmware installed is version 5.3c (it supports MQA) and that also supports PCM sampling from 44.1KHz to 384kHz and DSD64 to DSD256. In Audirvana with ASIO selected, I have set auto-detect of MQA to off (circle to the right) and for ‘DAC not detected as MQA, use as’, MQA Rendering is selected. I hope these settings are correct.

I only have a single MQA-encoded file album so far. It is from 2L and I purchased it because I also have the same album as an SACD so I felt that a comparison between the two would be interesting. When the file album cover is displayed in Audirvana, there is a small circle with what appears to be an M inside it below the cover at its right-hand end, while when playing the files, I am informed that they are ‘FLAC MQA’ with native resolution of 24bit/88.2kHz (which agrees with the information in the SACD booklet) so it would seem that they are genuine MQA- encoded files. With the output set to ASIO mode, at the right hand side of Audirvana the readings are 32bit/88.2KHz when the files are playing and, amazingly, 32bit/384kHz when I stop playing them (by clicking on the small filled square to the left of the Pause)

If I change the output to WASAPI, the readimgs on the right-hand side become 24/88.2 when playing and 32/192 when stopped.

In all instances, the LED colour on the top of the Micro BL DAC remains yellow at all times.

Any suggestions as to what might be happening would be gratefully appreciated.

Finally, I realise that MQA is a very controversial subject - certainly one of the most controversial audio topics in recent times. My personal advice would be to listen to it via recordings that you know well and if you like what you hear you will probably support it. If, on the other hand, you don’t like what you hear, then forget about it. Remember, it’s you listening to the music, not someone else, so only you can decide whether it has merit or not. I have yet to experience it and it’s quite possible that I might end up deciding it’s not for me. On the other hand, I might love it. Time will tell.

My iFi DACS render MQA without issue. I use ASIO.

Ensure that your are NOT using software volume control and are NOT up-sampling. What is the file name of the MQA source file? Do the DACS have the correct firmware for MQA installed?

1 Like

Firstly, Pieronip, thank you for your response to my query.

I’ll need to check up on the questions you’ve asked so all I can say at this stage is that I haven’t ticked any boxes or knowingly selected software volume control or upsampling options

The 2L MQA album I mentioned contains works by a Norwegian composer named Arne Nordheim (b. 1931) and contains works for electronics and percussion and features a soprano in a couple of the pieces. I suppose you could say that the music is an acquired taste, but its beautifully recorded - at least, as heard from the SACD. The PCM files - which I keep assuming are just normal PCM 24-bit/88.2kHz FLAC files as I am currently playing them - sound pretty darned good too.

As mentioned in my letter, the firmware installed is version 5.3c and the AMR iFi website states that that version supports MQA. Furthermore, Audirvana also suggests that as well when I looked at the iFi firmware’s specifications under ASIO.

I don’t know how thoroughly you read my letter but I’ll be interested in what you made of the resolution figures I mentioned when I played and then stopped playing those 2L files with the output set to ASIO. When playing the files, Audirvana’s output (bottom right-hand side) resolution was 32-bit/88.2 kHz and when I clicked on the Stop square, that resolution changed to 32-but/384 kHz. I don’t understand that at all and would appreciate an explanation.as to what is happening.

Finally, I’m pleased you’ve had success in getting MQA to work with your DACs. What models are you using and what colour do your LEDs glow when playing MQA material? As regards the sound, are you impressed by what you’ve heard so far?

The LED is magenta when playing MQA on both the iDSD Nano BL and the Zen DAC.

Can you post your debug info here? Go to ‘Settings’, click the ‘Debug’ button. This will put the info on the clipboard and you can paste it here.

I don’t bother much what appears at the bottom of Audirvana but rely on the DAC light to confirm MQA. Here is what appears when playing an MQA file

I believe the left is info from the file itself and the right is what your DAC is seeing as the incoming stream. In this case the DAC is receiving a 32-bit 88.2KHz stream and unfolding to a 352.8KHz output.

I was asking about the file name rather than the type of music. An MQA file must be named correctly. Here is the format for a FLAC-encoded MQA file.


When you press the ‘Stop’ button what you see at bottom right changes from the actual track resolution to the maximum capability of the DAC.

Here are the correct settings from the Audio Device section. This is the PC version of Audirvana. The MAC version will have equivalent settings.

Hello Pieronip,

Thank you again for your assistance…

I will answer your questions first then paste the debug information.

The Audio Device section settings are EXACTLY as per your screen dumps, so everything would seem to be OK there.

Sorry, I didn’t realise you were after the file extensions for that 2L album. All the audio files are *.mqa.flac

Here is the debug report.

Audirvana 3.5.44


Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

SoX not in use
SoX filter parameters
Bandwidth at 0dB = 99.5
Filter max length = 30000
Anti-aliasing = 100
Phase = 66

Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

Sync list: 8 folders
AUTO: D:\23Fish\Future (DL 16-44.1)
AUTO: D:\Colombier, Michel\Wings (DR)
AUTO: D:\Glorified Magnified
AUTO: D:\Nelson, Oliver\The Blues and the Abstract Truth (DL 24-96 FLAC)
AUTO: D:\Nordheim, Arne
AUTO: D:\Rachmaninov, Sergei\Symphony 1 & Symphonic Dances (DL 24=96 FLAC)
AUTO: D:\Weinekamp, Gerd (Der Laborant)\Kontakt (DL)
AUTO: D:\Yes\Fly From Here (H)
Library database path: D:\AudirvanaPlusDatabaseV2.sqlite


=================== AUDIO DEVICE ========================

Max. memory for audio buffers: 2770MB

Local Audio Engine:ASIO 2 driver version 794

Preferred device:
iFi (by AMR) HD USB Audio
Model UID:iFi (by AMR) HD USB Audio
UID:iFi (by AMR) HD USB Audio

Active Sample Rate: 48kHz

Bridge settings:
Sample rate limitation: none
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:
Local audio device
iFi (by AMR) HD USB Audio Manufacturer:
Model UID:iFi (by AMR) HD USB Audio UID:iFi (by AMR) HD USB Audio

11 available sample rates up to 11289600Hz
Volume Control
Physical: No
Virtual: No
MQA capability
Auto-detect MQA devices: Yes
Not a MQA device, user set to MQA Renderer
DSD capability: Raw DSD (MSB)
Device audio channels
Preferred stereo channels L:0 R:1
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: Yes

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1
2 ch Integer PCM 32bit little endian 44.1kHz
2 ch Integer PCM 32bit little endian 48kHz
2 ch Integer PCM 32bit little endian 88.2kHz
2 ch Integer PCM 32bit little endian 96kHz
2 ch Integer PCM 32bit little endian 176.4kHz
2 ch Integer PCM 32bit little endian 192kHz
2 ch Integer PCM 32bit little endian 352.8kHz
2 ch Integer PCM 32bit little endian 384kHz
2 ch DSD 8bit big endian in 8bit chunk 2822.4kHz
2 ch DSD 8bit big endian in 8bit chunk 5644.8kHz
2 ch DSD 8bit big endian in 8bit chunk 11289.6kHz

Local devices found : 1
Device #0: iFi (by AMR) HD USB Audio Manufacturer: Model UID: iFi (by AMR) HD USB Audio UID: iFi (by AMR) HD USB Audio

UPnP not started…

Hopefully, you can see something here that should be different. I look forward to your reply.


Hi Johnno

The bad news is that your settings are exactly the same as mine! You have the correct driver and the correct setup. The numbers you are seeing on the status line of Audirvana are saying that Audirvana is performing the MQA first unfold and the DAC should recognise the stream as MQA since it is not being interfered with by up-sampling or a software volume control.

If you feel confident in so doing I reckon you might try to reload the firmware on your DAC. You can choose between 5.30 and 5.30c depending on your own view on the relative compromises. I am wondering if perhaps, somehow, your DAC still has firmware 5.2 on it.

Other than that, perhaps @Damien has an idea.

EDIT: To check the firmware version easily, find the iFi icon in your system tray (bottom right near the clock. Press up-arrow to show hidden icons). Click on the iFi icon and then on the ‘Info’ tab of the resulting window. The ‘Revision’ field shows the firmware version which should be 5.3 or 5.3C.

Hello Pieronip,

Once again, thanks for your comments.

I actually reloaded the firmware very recently, as I wondered whether that might have been the cause of the issue, so I’m pretty sure it’s OK. I also checked the version again a couple of nights ago but in a somewhat different way from the one you suggested. As you know, ifiHDUSBAudio_dfuapp.exe is used to update the firmware and it also displays the current firmware version being used so I always use that to check it out.

There is one other factor that I’ve never mentioned because I didn’t think it would affect anything. I am using three AudioQuest Jitterbugs in the system around the laptop: one between the USB 3.0 port and the DAC, and another between one of the two USB 2.0 ports and a USB multi-port hub, with two ports being used: one for a Seagate fast SSD (drive D:, with all my audio files on it) and another for a small Microsoft mouse. I use a third Jitterbug plugged into the second USB 2.0 port with nothing connected to it (that port is fine, as is the USB 3.0 port). I suppose the Jitterbugs could be messing up the digital data but I’d be really disappointed if that were the case. I guess I should have mentioned this earlier and apologise now for not doing so.

Now for the bad news of my own, and I’m not sure what caused it or how to fix it - assuming it can be fixed. All was obviously fine when I carried out the various checks and created the debug report for you last night. After sending my reply I went back to the laptop and immediately noticed that there was no light under the mouse. The light at the end of the SSD was still there so I wondered it the mouse might have failed. Replacing that temporarily with another mouse that I know works made no difference, so next I wondered it was the hub. I also have another identical hub and that produced the same result so I considered both to be OK. I swapped Jitterbugs and that made no difference, so I was beginning to run out of options. I then noticed that drive D: wasn’t showing up in ‘This PC’, even though the light at the end of the drive was still glowing. Could it be the port, I wondered. I decided to check that out with Device Manager next - and the truth was revealed. In the USB area there was 'Unknown USB Device (Device Descriptor Request Failed) and when its properties were checked, there was ‘Windows has stopped this device because it has reported problems (Code 43). A request for the USB device descriptor failed.’ I have never encountered that before so I decided to do a Google search and found a considerable number of people were suffering from the same problem. Furthermore, one report seemed to think it was a recent phenomenon. (I had previously been using a very early version of Windows 10 Home Edition - 1511 - that came loaded on the laptop when I bought it. To use Audirvana, however, I had to update it because the required install program from the Microsoft Store was incompatible with that early Win10. It now has 20H2 on it and I further did a check for new updates this morning and downloaded and installed some more, so it is now completely up to date.) What gave me some hope was that some people have apparently solved their problems because - perhaps not surprisingly - my immediate thought was that it had to be a hardware failure of some kind associated with that port. I’m firmly convinced that the SSD and the mouse are both fine and I can’t see the hub being the cause of any disruption. I later connected everything up to the other USB 2.0 port and it was all working again I have tried a couple of suggestions put forward via Google to fix the issue but they have made no difference. Uninstalling the USB port and rebooting so that the port reinstalls itself has made no difference, and there was another so-called fix that also didn’t change the status quo. I did read that there is possibly a utility that one can download from Microsoft, so I’ll go there and check that out. Other than that, I have no idea what to do. What a pain!!


Hi Johnno

It is tempting to assume that a hardware problem is at the root of the matter. I certainly would not want the USB connection to the DAC going through an external hub however. As for Jitterbugs, I use one (just one) myself without issue but have no experience with using a multiplicity.

Once you get the hardware issue resolved try with a ‘no jitterbug’ direct connection from PC to DAC. Also in your PC Sound Control Panel, ensure that output level is fixed at 100% and that ‘Exclusive Mode’ is enabled in the Advanced tab.

I hope you get this resolved and please let us know how this turns out.

Hello PIeronip,

I’ve been reading more on the USB issue via Google and two articles I read made it clear that if one moves devices from one USB where there isn’t any response to one which works, the first USB port has a definite fault, and that is clearly a logical conclusion to reach. I’m afraid it looks as if there is a hardware failure around the port somewhere. If I had a circuit diagram of the laptop, I’d be tempted to try and fix it myself. There is a good electronics store near me and it stocks resistors, capacitors, ICs, transistors etc and I worked in electronics for almost 40 years so I’d be able to work around the circuit. I’m not keen on working on surface mounted devices, however, and that would probably be a deciding factor in a modern laptop. Some of those SMtd resistors and capacitors are so small that I can hardly see them, while removing an SMtd IC with numerous pins around all four sides would be a nightmare !! Soldering a new one in would be equally difficult without the right equipment. (I have a temperature-controlled soldering iron but nothing else). There is a computer repair outlet fairly close to where I live so on Tuesday (nobody will be there over Easter) I’ll take the laptop down and explain the situation to someone there and hopefully it will be repaired fairly quickly.

I hope I didn’t give the impression that the hub was inserted between the laptop and the DAC. No, the DAC goes directly to the USB 3.0 port (admittedly through a Jitterbug). The hub has the SSD and the mouse connected to it and it was connected to the (faulty) USB 2.0 port…I’ll connect them all to the good port over the weekend for music

I will try removing the Jitterbug between the laptop and DAC and see if that makes any difference…If it does fix the MQA issue, what does that say about the Jitterbugs? With standard PCM and DSD files they seem to be fine.


My Jitterbug is between the PC and the DAC and it is fine, so don’t worry about that.

Hope you get sorted out and it all springs to life.

You’re overthinking it. Remove the Jitterbug just to make sure it’s not that what’s interfering with the ability to play MQA files. Also disable the MQA auto-detect feature.

If it turns out that it’s the Jitterbug related issue, it would mean that it messes with the bits during playback.

Jitterbug has no adverse effect in my setup. Disabling MQA auto-detect is fine but it is superseded by the ‘Use as MQA Renderer’ setting anyway. The output data stream from Audirvana would seem to indicate a correct unfolding so I’m suspicious that PC sound settings may be at the root of matters.

Will be interested to find out in due course.

Hello Pieronip,

I see you have sent me another, later message so I’ll address that one with comments.


Hello Alex,

Thank you for your comments.

I initially removed the jitterbug between the USB port and the DAC, and got a new ‘Integer’ error message when I attempted to play anything in Audirvana. I then realised I probably needed to reboot the laptop and that fixed that issue. Unfortunately, the Micro BL’s LED was still yellow when I played the first Erne Nordheim 2L file. I have now removed the one remaining Jitterbug from between the hub and the only functioning USB 2.0 port (I had to remove the third Jitterbug earlier because there was nowhere to fit it when the other port failed), played that same 2L file again - and obtained the same result as before, yellow light only.

Pieronip has wondered if it might be a Windows audio setting at the heart of the problem. When I set up Foobar2000 I went into that area and set them up so that they wouldn’t interfere with playback, but I’ll check them out again.

There is, however, one thing that suggests that the Windows audio settings have been successfully bypassed. If I click on the speaker icon at the right hand end of the Windows taskbar, I can move the slider from one end to the other and the sound level doesn’t change at all. To check for that I plugged headphones into the MicroBL phone socket as I didn’t want to turn my pre-amp and class A monoblock amplifiers etc on and I have to say the sound quality was absolutely wonderful, even from an early 60s jazz album I downloaded (24/96). It sounded gloriously clean and spacious with marvellous sounding percussion. That was without any of the Jitterbugs in place. Audirvana is undoubtedly superb but I’m beginning to think I might have to dispense with the thought of ever hearing MQA through it. However, as mentioned above, I will check the Windows sound settings and make sure they are being either bypassed or not selected,


Hello Pieronip.

You have probably read my letter to bitracer by now and have picked up on my comments there. I have just carried out a check on the Sound settings (Settings/System/Sound) and have found that one or two of them had changed - presumably after the major Windows update from 1511 to 20H2 and I admit I never thought to check those after the update. As expected, the ‘Sound Output’ option is set to ‘Speakers (iFi (byAMR) HD+ USB Audio)’, with the alternative being ‘Speakers (High Definition Audio Device)’ (the Windows internal RealTek sound card), although that option may no longer exist. (See comment later). Master Volume is set to 100% on the ‘Sound’ page (probably not important)… I then went straight to ‘Related Settings/Sound Control Panel’ further down and that opened a new window and I noted that both the above Speakers options were present there, with the iFi one showing a green tick. I have now uninstalled the Realtek alternative (the comment made earlier)…
Everything that follows relates to selections within this window. Firstly, I clicked on the .‘Enhancements’ tab and noted that the ‘Disable All Enhancements’ was NOT ticked. However. none of the individual enhancements (Bass Boost, Virtual Surround, Room Correction, Loudness Equalization) were ticked anyway so I guess it didn’t matter. I have now disabled them all just to be sure. (I wonder how the ‘Room Correction’ works?) Next, I clicked on the ‘Advanced’ tab and saw that the ‘Default format’ was set to 32 bit, 48000Hz (Studio Quality). I don’t know how important that is or why that particular resolution was chosen. Checking through the options, I noted that there are eighteen items in the list, ranging all the way from CD-quality 16 bit, 44100Hz right through to 32 bit, 192000Hz (Studio Quality). Further down on that page there is ‘Exclusive Mode’. The options are ‘Allow applications to take exclusive control of this device’ and ‘Give exclusive mode applications priority’. Both were ticked. Finally, the ‘Spacial Sound’ tab. The option ‘Select the Spacial sound format you want to apply’ is set to ‘Off’.

That’s it - I think.

If you can think of anything I’ve missed, I’m sure you’ll let me know. Thanks.


Hi Johnno

I think that just about wraps up all the possibilities. I am out of ideas and very puzzled! I remember you said you had two mqa-capable DACs and I presume you have tried both to eliminate a possible fault (although it would be a strange one indeed!). You don’t have another PC you could do a temporary set up on? Try swapping the USB cable?

I’ll post again if I think of anything.

Hello again, Pieronip.

You are correct. I do have another iFI DAC that supports MQA. It’s the original ZEN and is my next step. However, I have tried it out before, and did not have success then. That said, it wasn’t with Audirvana, so that may well make a difference.

I’ll obviously let you know what happens.


…and do try another USB cable.

Hi Pieronip,

IT’S WORKING WITH THE ZEN DAC !!!. I’m seeing magenta for the first time when I played the first track from the 2L Nordheim album.!!! As far as the Micro BL is concerned that can surely only mean one of two things :-
(1) The Micro BL is using the same firmware as the ZEN, but it still might not be correct for the former to decode MQA, or
(2) The help desk at iFi Audio made a mistake when he told me that my DAC is from a period of manufacture after the colour switch was implemented. The serial number is pretty low - a zero at the start followed by four other non-zero digits, so it’s difficult to judge as I have no idea how many Micro BL have been made or when the company decided to change the LED from yellow to magenta for MQA. Having said that, I still feel that the second possibility seems the more likely of the two.

I wonder if there is any way to know for sure what the MQA colour actually is with my particular DAC? I’m just not happy if it’s yellow.

After all this correspondence, it all seems to have fallen rather flat. It’s also clear that I didn’t have the other software I was using correctly set up as I’ve never seem Magenta before with either of the DACs.

I wonder if the store I bought the Micro BL from would let me take another one home to check and do a swap if I find it shows magentta. I can only ask and the store can only say no.if it objects.

Any further comments always welcome.