How To Use Kernal Streaming

First of all , a big thank you to support for solving the signup problems for activating a free trial.
Having used both Tidal and Qobuz for years along with Roon , I can tell right off the bat that the sound is better in studio so I will be a paying customer!
My problem is this:
the program defaulted to WASAPI which sounds real good but I want to try Kernal , but I can’t figure out how to activate it?
My DAC is a Schiit Bifrost which studio found and works great . Is the Dac an issue knowing hoe Schiit unfolds?
Tnx so much and I look forward to using Audirvana daily!

Is it not clear how to select different modes? or specifically fail to select Kernel streaming.

When I google, other players also have problems with Kernel Streaming and the Schiit Bifrost.

Tnx so much , Jason. I can’t figure out how to select different modes either whether kernal or whatever. I would not think the Bifrost would be a factor, but could be wrong?
But, I am impressed with the sound which is why I am here .Always chasing sound !
Have a great day , Jason, and enjoy your music!

Does this help?

I have a Schiit Bifrost 2 connected via (Unison) USB and I always use it in KS mode (Intel(R) Core™ i5-6200U CPU @ 2.30GHz 2.40 GHz/8.00 GB (7.88 GB usable)/ Windows 10 Education-21H1-19043.1237-Windows Feature Experience Pack 120.2212.3530.0). I never had any problem in that mode. And i agree Audirvana in that mode sounds (@ least to me) significantly better than Roon in WASAPI exclusive.
More details, silences darker (sorry dunnow the words).

Tnx so much, I now have kernel streaming selected. Problem before was the player was playing music and I didn’t know it as my headphones were not on!
But now with kernel streaming selected , it will only play 16/44 files.
Could you please tell me your output device settings when you have time ?
Tnx so much!!

Tnx so very much for taking the time to do this , Frank, but after using your configuration I am still having the same problem. On Qobuz it will play 16/44 files but when trying to play a 24/192 files it says: error starting device playback.
Plays 24/192 fine in waspi.

Bifrost 1 or 2? Gen5 usb or unison?
Try another usb port on pc.
Possibly another cable. Less than 2 m long, new if possible.
Reboot computer can help too.

Some users have reported that uninstalling the ASIO drivers helped. You might wanna try that.

Hi @bitracer, the bifrost2 doesnt have an Asio driver i believe.

Tnx so mch , Frank , and I will try your suggestions today.
It a Bifrost 2.
Where do I find bitracer?

Tried another usb port. Restarted computer several times. Usb cable is a high end Audioquest-2 ft.
Computer is an ssd , 8 meg and very fast processor that will run Roon ( not on it now, but has been )and any other music program.The computer has basically nothing on it from the time I purchased it for a specific application and only accesses the internet to play music.

Could you share the debug info, with the DAC connected en KS selected?

@usbkx3px3 , please update windows 10 to most recent version and deactivate any third-party antivirus. I only use window defender on my Asus Vivo mini.
Sorry i cannot help more. I can only say that KS mode works perfectly with my Bifrost 2.
Fyi, I have Roon server and Audirvana happily coexisting on the same machine, in case you do as well. I never checked however if Roon core and Audirvana can be idling together and play nice when using exclusivity in turn.
Lastly, in my case Audirvana doesn’t work with the Bifrost 2 if software volume is not turned on (referring to second screen capture I posted).

You should contact support and send your debug log.

Hi Frank,
Just wanted to let you know I received a Loki Mini + yesterday and it’s awesome!

1 Like

It’s WORKING on kernel!! It was the software volume. I kept thinking it was turned on and it was not. I have some mobility issues and it’s hard for me to get real close to the computer where I could see the symbol. Plus , old age/reading glasses.
Tnx so very much for all your help!


My pleasure Alan. Happy listening! I recently bought a Ragnarok 2. ‘Looks like we both like Schiit!

1 Like

How to uninstall ASIO? I’m a layman on pc. I tried to find the ASIO driver in the settings but failed. Pc I have an Intel NUC