Library still exist (File is there) but appears empty

Hi bitracer,
Thanks for your message.
There are indeed problems related to my NAS setup with files containing accented characters that are not properly encoded and not accepted by the MAC.
But, there are things that are related to Audirvana itself:

  • Why is it that the library appeared suddenly empty when the DB was still at 3.2GB?
  • What the hell Audirvana is doing when eating 70% of the CPU and showing no progress in the sync activities (Mine is running for 24h now and still no progress)?
  • Is it possible to activate any debug mode able to produce some kind of log from Audirvana?

Here are my questions, but I’m not sure I will get an answer.
On my side I will dig in the issue of accented characters but knowing SMB is a MS piece of crap, I doubt I will find a clear reply.

I wouldn’t read too much into this. Resolve first your issue. The other issues might go away.

My setup is very similar and I have no issues. Your experience should not be different from mine.

Hello @patifr, Can you send me a copy of the “Debug Info”? You can get it in Audirvana Settings>General>Debug Info

Note: By clicking on the Debug Info Audirvana button automatically copies all its content, all you have to do is paste it in response to this message.

Also, if you are interested by looking into logs of Audirvana, there is some of them, i can send you the path to find them in a private message.

I am wondering, where your database is located? Did you changed his location to put it in your Synology NAS?

Hi Damien,
Thanks for helping.
Today I managed to clean-up a bit my directory on the NAS (5140 Albums… I need to stop accumulating).
What I discovered:

  • Some files were duplicated, and one of them was empty: I removed the copy.
  • Trash bin was activated on my NAS and a directory called #Recycle had been created and contained audio files that were most probably used by Audirvana when syncing.
  • Several file names contained character encoded in ways that cannot be used by SMB properly: I corrected some of them (Still 100 to process)

Finally, and this is good news, I managed to restart Audirvana and it seems to be able to recreate the DB from scratch. So far so good.

Anyway, here is the “Debug info” and I’m indeed interested to get access to the Audirvana log to better understand what is happening when strange file names (with accented characters using encoding not fully supported by SMB) are encountered. I think they are ignored as they cannot be retrieved through the SMB protocol.

Audirvana Mac Version 3.5.33 (3563)
macOS 10.15.3 with 16384MB RAM

Licence enregistrée pour Conquet Eric


Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

SoX not in use
SoX filter parameters
Bandwidth at 0dB = 99.5
Filter max length = 30000
Anti-aliasing = 100
Phase = 66

Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

Sync list: 1 folders
AUTO: /Volumes/Audio/
iTunes/Music library synchronization: not synchronized
Library database path: /Users/eric/Library/Application Support/Audirvana/AudirvanaPlusDatabaseV2.sqlite


=================== AUDIO DEVICE ========================

Preferred device: UpMpd_TotalDac Model UID:JF Light Industries UpMpd_TotalDac UID:uuid:f88bf027-d2c5-e810-3750-d063b40157c5

Selected device:
UPnP device at
ID 0x0 UpMpd_TotalDac Manufacturer:JF Light Industries
Model UID:JF Light Industries UpMpd_TotalDac UID:uuid:f88bf027-d2c5-e810-3750-d063b40157c5

6 available sample rates up to 192000Hz
Volume control: No
MQA capability
Auto-detect MQA devices: No
Not a MQA device, user set to not MQA
DSD capability: Raw DSD (MSB)
Device audio channels
Preferred stereo channels L:0 R:1
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1
UPnP/DLNA supported protocols:
DLNA 1.5: No
Gapless playback: Yes
Missing events workaround: No
Can play native DSD: Yes
Number of channels: 2
Use as stereo device only: No

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1

Stream ID 0x0 0 channels starting at 0
14 virtual formats:
2 ch Non-mixable linear PCM Interleaved 16 little endian Signed Integer 44.1kHz
2 ch Non-mixable linear PCM Interleaved 24 little endian Signed Integer 44.1kHz
2 ch Non-mixable linear PCM Interleaved 16 little endian Signed Integer 88.2kHz
2 ch Non-mixable linear PCM Interleaved 24 little endian Signed Integer 88.2kHz
2 ch Non-mixable linear PCM Interleaved 16 little endian Signed Integer 176.4kHz
2 ch Non-mixable linear PCM Interleaved 24 little endian Signed Integer 176.4kHz
2 ch Non-mixable linear PCM Interleaved 16 little endian Signed Integer 48kHz
2 ch Non-mixable linear PCM Interleaved 24 little endian Signed Integer 48kHz
2 ch Non-mixable linear PCM Interleaved 16 little endian Signed Integer 96kHz
2 ch Non-mixable linear PCM Interleaved 24 little endian Signed Integer 96kHz
2 ch Non-mixable linear PCM Interleaved 16 little endian Signed Integer 192kHz
2 ch Non-mixable linear PCM Interleaved 24 little endian Signed Integer 192kHz
2 ch Non-mixable linear PCM Interleaved 8 little endian Signed Integer 2822.4kHz
2 ch Non-mixable linear PCM Interleaved 8 little endian Signed Integer 5644.8kHz

0 physical formats

Current device transportInfo:
CurrentTransportState: STOPPED
CurrentTransportStatus: OK
CurrentSpeed: 1
Current device MediaInfo:
NrTracks: 1
MediaDuration: 00:00:00
PlayMedium: NONE

Current device AVT service description:

<?xml version="1.0"?> 1 0 TransportState no string STOPPED PLAYING TransportStatus no string OK ERROR_OCCURRED PlaybackStorageMedium no string PossiblePlaybackStorageMedia no string RecordStorageMedium no string PossibleRecordStorageMedia no string CurrentPlayMode no string NORMAL SHUFFLE REPEAT_ONE REPEAT_ALL RANDOM DIRECT_1 NORMAL TransportPlaySpeed no string 1 no RecordMediumWriteStatus string CurrentRecordQualityMode no string PossibleRecordQualityModes no string NumberOfTracks no ui4 0 2000 1 CurrentTrack no ui4 0 2000 1 CurrentTrackDuration no string CurrentMediaDuration no string CurrentTrackMetaData no string CurrentTrackURI no string AVTransportURI no string AVTransportURIMetaData no string NextAVTransportURI no string NextAVTransportURIMetaData no string RelativeTimePosition no string AbsoluteTimePosition no string RelativeCounterPosition no i4 AbsoluteCounterPosition no i4 CurrentTransportActions no string LastChange yes string A_ARG_TYPE_SeekMode no string ABS_TIME REL_TIME A_ARG_TYPE_SeekTarget no string A_ARG_TYPE_InstanceID no ui4 SetAVTransportURI InstanceID in A_ARG_TYPE_InstanceID CurrentURI in AVTransportURI CurrentURIMetaData in AVTransportURIMetaData SetNextAVTransportURI InstanceID in A_ARG_TYPE_InstanceID NextURI in NextAVTransportURI NextURIMetaData in NextAVTransportURIMetaData GetMediaInfo InstanceID in A_ARG_TYPE_InstanceID NrTracks out NumberOfTracks MediaDuration out CurrentMediaDuration CurrentURI out AVTransportURI CurrentURIMetaData out AVTransportURIMetaData NextURI out NextAVTransportURI NextURIMetaData out NextAVTransportURIMetaData PlayMedium out PlaybackStorageMedium RecordMedium out RecordStorageMedium WriteStatus out RecordMediumWriteStatus GetTransportInfo InstanceID in A_ARG_TYPE_InstanceID CurrentTransportState out TransportState CurrentTransportStatus out TransportStatus CurrentSpeed out TransportPlaySpeed GetPositionInfo InstanceID in A_ARG_TYPE_InstanceID Track out CurrentTrack TrackDuration out CurrentTrackDuration TrackMetaData out CurrentTrackMetaData TrackURI out CurrentTrackURI RelTime out RelativeTimePosition AbsTime out AbsoluteTimePosition RelCount out RelativeCounterPosition AbsCount out AbsoluteCounterPosition GetDeviceCapabilities InstanceID in A_ARG_TYPE_InstanceID PlayMedia out PossiblePlaybackStorageMedia RecMedia out PossibleRecordStorageMedia RecQualityModes out PossibleRecordQualityModes GetTransportSettings InstanceID in A_ARG_TYPE_InstanceID PlayMode out CurrentPlayMode RecQualityMode out CurrentRecordQualityMode Stop InstanceID in A_ARG_TYPE_InstanceID Play InstanceID in A_ARG_TYPE_InstanceID Speed in TransportPlaySpeed Pause InstanceID in A_ARG_TYPE_InstanceID Seek InstanceID in A_ARG_TYPE_InstanceID Unit in A_ARG_TYPE_SeekMode Target in A_ARG_TYPE_SeekTarget Next InstanceID in A_ARG_TYPE_InstanceID Previous InstanceID in A_ARG_TYPE_InstanceID SetPlayMode InstanceID in A_ARG_TYPE_InstanceID NewPlayMode in CurrentPlayMode GetCurrentTransportActions InstanceID in A_ARG_TYPE_InstanceID Actions out CurrentTransportActions

Current device RootDevice description:

<?xml version="1.0"?> 1 0 urn:schemas-upnp-org:device:MediaRenderer:1 UpMpd_TotalDac JF Light Industries UPnP front-end to MPD UpMPD 1.0 42 uuid:f88bf027-d2c5-e810-3750-d063b40157c5 urn:schemas-upnp-org:service:RenderingControl:1 urn:upnp-org:serviceId:RenderingControl /upmpd/RenderingControl.xml /ctl/RenderingControl /evt/RenderingControl urn:schemas-upnp-org:service:AVTransport:1 urn:upnp-org:serviceId:AVTransport /upmpd/AVTransport.xml /ctl/AVTransport /evt/AVTransport urn:schemas-upnp-org:service:ConnectionManager:1 urn:upnp-org:serviceId:ConnectionManager /upmpd/ConnectionManager.xml /ctl/ConnectionManager /evt/ConnectionManager urn:av-openhome-org:service:Product:2 urn:av-openhome-org:serviceId:Product /upmpd/OHProduct.xml /ctl/OHProduct /evt/OHProduct urn:av-openhome-org:service:Info:1 urn:av-openhome-org:serviceId:Info /upmpd/OHInfo.xml /ctl/OHInfo /evt/OHInfo urn:av-openhome-org:service:Time:1 urn:av-openhome-org:serviceId:Time /upmpd/OHTime.xml /ctl/OHTime /evt/OHTime urn:av-openhome-org:service:Volume:1 urn:av-openhome-org:serviceId:Volume /upmpd/OHVolume.xml /ctl/OHVolume /evt/OHVolume urn:av-openhome-org:service:Playlist:1 urn:av-openhome-org:serviceId:Playlist /upmpd/OHPlaylist.xml /ctl/OHPlaylist /evt/OHPlaylist urn:av-openhome-org:service:Radio:1 urn:av-openhome-org:serviceId:Radio /upmpd/OHRadio.xml /ctl/OHRadio /evt/OHRadio urn:av-openhome-org:service:Credentials:1 urn:av-openhome-org:serviceId:Credentials /upmpd/OHCredentials.xml /ctl/OHCredentials /evt/OHCredentials /upmpd/presentation.html

UPnP devices found : 3
Device #0: ID 0x0 CRX-N560 84BA0 UID: uuid:5f9ec1b3-ed59-1900-4530-00a0dea84ba0 Location:
Device #1: ID 0x0 UpMpd_TotalDac UID: uuid:f88bf027-d2c5-e810-3750-d063b40157c5 Location:
Device #2: ID 0x0 Marantz NA-11S1 UID: uuid:5f9ec1b3-ff59-19bb-8530-0006781a09a1 Location:

CoreAudio audio path, buffer I/O frame size: 0

Max. memory for audio buffers: 13312MB

Local Audio Engine:
Exclusive access: Enabled
Integer mode: Enabled

Local devices found : 1
Device #0: ID 0x47 Haut-parleurs Mac mini Manufacturer: Apple Inc. Model UID: Speaker UID: BuiltInSpeakerDevice

Oops, sorry I forgot to mention that I emptied the trash and disabled it on the Syno.

And, by the way, I still have this strange display showing: 3189 Albums, 47520 pistes and 4995j and 15h.
I’m sure there is an error in the way those things are computed. Usually one album is around 1 hour of listening time.

And, by the way, the problem I have with Samba is due to the use of different encoding schemes for the same character, “é” in French, or “ü” with Umlaut in German.
If somebody knows a trick, or better a tool, to automatically detect and correct those file names, I will be his or her first fan forever :wink:

Good news! Syncing is now completed and I have access to 5054 albums!
Still some file names to be changed to get rid of those bloody accents and everything is fine.
In the near future, before adding files to my NAS I will pay attention to the way the file names are encoded. I will maybe give a try with Audirvana and if the files can be played then I will give them the authorisation to enter the DB. Nowadays we are used to have authorisations to go outside :wink:

When done, don’t forget to close Audirvana and copy the .sqlite file and put it somewhere for a backup as todays date :grinning:

At least you’ll have enough time to sort out your music library. :slight_smile:

Yes, thanks for the advice. I have regular backups using Time Machine, so the DB is preserved and can be restored when needed.

That’s true… Or almost true as I am teleworking and sometimes you work more (and even better) than at the office.

Bonjour Damien,
Je ne sais pas si vous l’avez vu mais j’ai répondu à votre message. Je n’ai pas utilisé le bouton Reply, désolé…

Bonjour @patifr, j’ai bien lu tout vos messages. Si je comprend bien c’est à cause du dossier corbeille créé par votre NAS que vous aviez des doublons?

Bonjour Damien,
En fait je ne sais pas car j’ai modifié deux choses:

  • Vidé la corbeille du dossier “/Volumes/Audio” sur le NAS, et je l’ai désactivée.
  • Modifié les noms de certains fichiers qui contenaient des caractères accentués apparemment non autorisés par Samba. Mais je n’ai pas terminé cette opération.
    Comme Audirvana s’est remis à fonctionner suite à ces deux opérations, on pourrait en déduire que la suppression de la corbeille est la raison principale, le nettoyage des noms de fichiers n’ayant pas été complété.

En tous cas, quand les problèmes existaient, et qu’Audirvana n’arrivait pas à reconstruire la base de données SQL, il tournait à 70% de CPU pendant 24h avant que je ne l’arrête.

J’aimerais bien jeter un oeil sur les logs d’Audirvana pour essayer de comprendre les raisons, non seulement de la difficulté à effectuer une synchronisation mais aussi celle liée à la disparition complète de tous les albums alors que la base pesait toujours 3.2 GB.

Après le succès de l’opération de hier (5054 albums), je l’ai relancé hier soir. Ce matin il affichait 5105 albums alors que je n’ai pas touché au volume sur le NAS.

Merci du support.

Dear all,
I finally solved my issues with Audirvana and the Samba thing:

  • By removing the trash on the Syno Volume (I emptied the trash and disabled it)
  • By modifying file names that contained wrongly encoded accented chars (More than 300 files!! Quite painful).
    Now I got rid of SMB errors and Audirvana is able to complete the synchro with the NAS volume.
    Thanks to all for the support.

OH NOOOOOOO!!! The very same problem is back!!!
I tried to include some new albums in the DB. I properly checked that they do not contain any wrongly encoded chararacters that this piece of crap of SMB could not read.
And BING! Again, after some long processing, Aurdivana reported an empty library…
If you are reading this Damien, I would be delighted to have a look at the Audirvana logs to understand what is going around.

This piece of crap did not report any file with wrong file names and Audirvana was working well.
Until this morning where, suddenly, new files with encoding of accented chars are not SMB compatible were found!! Yesterday, nothing! Today, plenty fo files with problems! Without me having changed anything!
MS, the Masters of Shit!

On your Synology NAS, go to File Services > SMB > Advanced Settings and enable “Enable VFS module to convert Mac special characters”.

Screenshot 2020-03-30 at 14.10.25|677x499

Thanks Bitracer. I already saw this option on the NAS but I was a bit scared of using it due to the message I got when I checked that option: Activating this option may lead to file name not being recognised when they contain special characters…
I’m wondering if that could be worse than the problem I currently have. The NAS is used by other computers on my network…
At this stage, what is strange is to see Audirvana up and running for a while, only eating 16% of the CPU and not doing much on the disk. What the hell the app is doing? I hope it is something useful.

This is interesting. I took the opportunity to upgrade to 10.15.4 because anyway Audirvana did not make any progress.
And, now it works, without any SMB error message.
I suspect that something was wrong in the SMB support of Catalina and was corrected with that version without telling the users. Come on Apple, don’t tell me you hired the same bad programmers as the one working for MS? That will be the end of the world!!

1 Like