Library still exist (File is there) but appears empty

Bonjour @patifr, j’ai bien lu tout vos messages. Si je comprend bien c’est à cause du dossier corbeille créé par votre NAS que vous aviez des doublons?

Bonjour Damien,
En fait je ne sais pas car j’ai modifié deux choses:

  • Vidé la corbeille du dossier “/Volumes/Audio” sur le NAS, et je l’ai désactivée.
  • Modifié les noms de certains fichiers qui contenaient des caractères accentués apparemment non autorisés par Samba. Mais je n’ai pas terminé cette opération.
    Comme Audirvana s’est remis à fonctionner suite à ces deux opérations, on pourrait en déduire que la suppression de la corbeille est la raison principale, le nettoyage des noms de fichiers n’ayant pas été complété.

En tous cas, quand les problèmes existaient, et qu’Audirvana n’arrivait pas à reconstruire la base de données SQL, il tournait à 70% de CPU pendant 24h avant que je ne l’arrête.

J’aimerais bien jeter un oeil sur les logs d’Audirvana pour essayer de comprendre les raisons, non seulement de la difficulté à effectuer une synchronisation mais aussi celle liée à la disparition complète de tous les albums alors que la base pesait toujours 3.2 GB.

Après le succès de l’opération de hier (5054 albums), je l’ai relancé hier soir. Ce matin il affichait 5105 albums alors que je n’ai pas touché au volume sur le NAS.

Merci du support.

Dear all,
I finally solved my issues with Audirvana and the Samba thing:

  • By removing the trash on the Syno Volume (I emptied the trash and disabled it)
  • By modifying file names that contained wrongly encoded accented chars (More than 300 files!! Quite painful).
    Now I got rid of SMB errors and Audirvana is able to complete the synchro with the NAS volume.
    Thanks to all for the support.

OH NOOOOOOO!!! The very same problem is back!!!
I tried to include some new albums in the DB. I properly checked that they do not contain any wrongly encoded chararacters that this piece of crap of SMB could not read.
And BING! Again, after some long processing, Aurdivana reported an empty library…
If you are reading this Damien, I would be delighted to have a look at the Audirvana logs to understand what is going around.

This piece of crap did not report any file with wrong file names and Audirvana was working well.
Until this morning where, suddenly, new files with encoding of accented chars are not SMB compatible were found!! Yesterday, nothing! Today, plenty fo files with problems! Without me having changed anything!
MS, the Masters of Shit!

On your Synology NAS, go to File Services > SMB > Advanced Settings and enable “Enable VFS module to convert Mac special characters”.

Screenshot 2020-03-30 at 14.10.25|677x499

Thanks Bitracer. I already saw this option on the NAS but I was a bit scared of using it due to the message I got when I checked that option: Activating this option may lead to file name not being recognised when they contain special characters…
I’m wondering if that could be worse than the problem I currently have. The NAS is used by other computers on my network…
At this stage, what is strange is to see Audirvana up and running for a while, only eating 16% of the CPU and not doing much on the disk. What the hell the app is doing? I hope it is something useful.

This is interesting. I took the opportunity to upgrade to 10.15.4 because anyway Audirvana did not make any progress.
And, now it works, without any SMB error message.
I suspect that something was wrong in the SMB support of Catalina and was corrected with that version without telling the users. Come on Apple, don’t tell me you hired the same bad programmers as the one working for MS? That will be the end of the world!!

1 Like