Mac OS Sonoma et Sysoptimizer

Bonjour @Antoine,

Je suis revenu avec joie vers Audirvāna. Je possède un Macbook Air M1 avec 16go. Mon ordinateur est connecté via un câble Audioquest USB coffee vers un Denafrips Iris ddc. Qui lui, est connecté à un câble Audioquest HDMI vers une entrée numérique I2s à mon dac Denafrips Terminator Il. Avec cette installation, je rencontre un problème récurrent. À chaque fois que je démarre l’application Audirvāna et la lecture d’un fichier, Audirvāna me demande systématiquement d’installer sysoptimizer. Pourtant, dans les réglages d’Audirvana il est bien indiqué que sysoptimizer est bel et bien installé. Ai-je oublié d’installer ou de d’autoriser quelque chose dans mes préférences système dans mon MacBook Air qui m’éviterait cette situation un peu irritante? Je vous remercie pour votre assistance!

Bonjour @beajuju

Cela m’est arrivé il y a quelques années.

Pouvez-vous supprimer sysoptimizer et vous devez ensuite l’installer.

Je ne me souviens pas si c’est ce que j’ai fait, mais c’est ce que je pourrais essayer. Quoi que je fasse, cela a résolu le problème.

D’autres auront peut-être une meilleure solution.

{Google translated.)



Tu peux essayer de jeter tes prefs du sysopt…

1 Like

THIS happens to me too, since the last macOS Sonoma.

It happens only after every boot. (I mean, if I only close Audirvana and re-open it, there is no SysOptimizer pop-up anymore).

You’re right.The problem only appears after each restart of Mac OS despite having thrown PrivilegeHelperTools folder in the trash. @Antoine it sounds to be a bug? Isn’t it?

Check those preferences in Sonoma if they are on or off.
on this computer i don’t have screen saver and don’t do automatic backups
so, those prefs are off…

Thank you so much for your help and kindness. Unfortunately, the problem is ongoing. Audirvana has full access disk mode on my MacBook Air.

try to remove the full disk access minus sign…
put time machine prefs OFF in sysopt in Audirvana
restart Audirvana, play a song… no message?

Wait, today the SysOpt. message didn’t happen to me, even after a cold boot.

However I noticed that I have not plugged the jack output yet (I do remember yesterday I got the message when launching Audirvana and having my headphones plugged-in already).

→ Will do some tests later and let you know! (might be a clue)

Well, I got this message again, with no earphones plugged-in… So it appears quite randomly it seems.

I think I found the culprit. In my applications on my Macbook Air, I also have an Audirvana Legacy version. In my Mac OS Sonoma system preferences, I removed Audirvana Legacy from full access to my disk. However, I have maintained this permission for Audirvana Origin. Since then, I no longer have to install Sysoptimizer after each startup of my computer. the problem seems to be resolved with this trick. Hope I can help others!

1 Like

Glad it works for you. Thanks for your input.

On my side, I made a clean install when I got my M2 MBA, and I never installed the old Audirvana. I installed the new Origin from scratch, so I have nothing related to Legacy in the pref. pane.

And this pop-up window for SysOpt still appears, but it seems quite random.

I ran the Console while starting Audirvana Origin (and having the same issue).


Disallowing com.audirvana.SysOptimizerTool because no eligible provisioning profiles found


Couldn’t build index for com.audirvana.SysOptimizerTool: Not eligible for acceleration

Then I assume this is why Audirvana asked again about installing SysOpt.

Reminder: this issue only appeared after macOS Sonoma update.

@Antoine Hope this helps.

So this is still not fixed, and no news from devs as well on the matter?

FYI, the new update didn’t solve that issue.

Based on your pics, I might have found something…

In the Pref. Pane of macOS Sonoma, Files and Folders, I see Audirvana Origin, but it is somehow greyed out and I don’t see any slider/button.

I open Automator one to let you see the difference.

@RunHomeSlow Are you running Sonoma too? (cause on your side I see the slider/button.

@Antoine That would be nice to know if you are working on a fix, thanks.

Yes Sonoma… but when you give Complete access, there is no slider.
Only like me when you chosse some places on your Mac :slight_smile:

Ok, thanks!

Still buggy for you Pierre?

Yep, indeed. Every time I boot the Mac, I need to install SysOpt.