Manually type in numerical values

I use Audirvana Origin on a Windows machine. I noticed that it is not possible (correct me if I am wrong) to manually type values for numerical settings which use a slider. The screenshots below are just a few, but this is the case with all these ‘slider’ settings. In the example below I want to set the number to 8000, but it is impossible to do so with the mouse+slider (because it is to crude). It would be nice to have the possibility (as in most Windows programs) to (double) click on the number and type it in/adjust it manually to fine tune it to the exact value I want. Normally (in Windows) focused sliders can be fine-adjusted with the arrow keys as well. This also does not seem possible in Audirvana because the slider controls do not get focus when clicked with a mouse.

Another example:

I did not try all the slider settings in Audirvana, but I assume they all don’t allow manual typing.

As said: this is on a Windows machine. I did not try this on a Mac.

Hi @AndyLubke Just tried on my MacBook Air M2 and can confirm that numerical changes can be completed.

Thanks @ChiliHot . Than it seems an issue in Windows only :wink:
Dear @Antoine. Now I am in doubt if this should be a feature request or a bug report :wink:

Euh, i can’t type what i want,
mac mini late 2018, sonoma 14.3

1 Like

The plot thickens :crazy_face:

1 Like

i settle to see the number i want on the close window… had to put 17.434gb of memory to see 17 :slight_smile:


That is funny. I did not notice that:

The setting is 8192 MB, but on the ‘main’ screen Is 8.0 GB. Well probably rounding/truncating (and dividing by 1024) explains that.

Settings with fractions (in the SoX/R8Brain sliders) don’t behave so nicely. Try to slide a value to 188.5 for instance with the mouse.

The plot thickens even more :rofl:

Hi Guys. Sorry only half right. The RAM usage can only be changed by slider (didn’t check your first screen shot), however the settings under Upsampling can be changed manually.

Yep. mine is 6750 to show 6.6GB Hadn’t really noticed that before…

1 Like

Thanks for trying! If I double click (in Windows) the numerical values under Upsampling I can see the background color changing (like it is selected for editing), but I can not type anything in it. So in Windows it still does not seem to work.

1 Like

Might be just a small bug. Hopefully can get it sorted.

1 Like

Yes. It is not the end of the world, but it would be nice indeed.

1 Like

For upsampling:

Use TAB to change focus, left/right arrows to adjust/fine tune values.

Wow! Thanks @DGrigorescu. That works! I had to remove my glasses and use a magnifying glass to actually see the focus frame around the fields. At first it seemed that the sliders where not getting focus, but after closer inspection I could see that it worked. Thanks again. Now I know it I can’t unsee it anymore :champagne:. Until now I tried clicking with the mouse on it, but that does not give focus.

I will mark your answer as solution, because this is good enough for me :wink:

1 Like

The slider for ram size doesn’t let you fine tune MB. For example, can’t set to 48000 MB.

Can you fix the slider?

Maybe you find the solution in this thread:

Manually type in numerical values - User Voice - Audirvana

1 Like

Beat me to it! :+1:

1 Like

It doesn’t work on MAC.

Yup, so frustrating on a Mac when you have 128 GB, slider moves +/- a 1000 mb with just a slight roll of the finger on the touchpad. In the grand scheme of things really not an issue, but for those for whom precise is a life long ambition…so frustrating.

1 Like

The volume slider is what annoys me the most. My vintage preamplifier has no remote and my DAC has no digital volume control. Sometimes I rely on Audirvana to adjust volume instead of walking up to the rig to adjust. Can be quite annoying clicking through .1dB decrements or clicking and suddenly jumping 10dB. Wish I could just type in the exact dB i want.