Music Integrated Mode (Legacy) Stoped working on 2.2.7

  • macOS Ventura 13.3
  • Audirvana Origin 2.2.7 (upgraded just now), running with “Music Integrated Mode (Legacy)”

Music Integrated Mode still worked (with some minor issues though) with 2.2.6, but after I upgraded Audirvana to 2.2.7, it completely stopped working.


After toying with enabling/disabling “Music Integrated Mode”, it solved somehow, mysteriously.

After I disabled “Music Integrated Mode” and tried to play a track, it warned me “Maximum Volume Alert” dialog. From the Origin’s native mode, it plays fine. But after I switched again to “Music Integrated Mode” on, it won’t play any music. Furthermore, even if I’m in the “Music Integrated Mode”, it automatically went back to a native window - still no music.

Then I got a point. Again, I disabled the “Music Integrated Mode”, tried to play a track, and “Maximum Volume Alert” dialog appeared. This time, I checked “do not show next time” checkbox. Then I went back to “Music Integrated Mode” - it started working again as it should.

So my guess is that, users who use Audirvana Origin only with “Music Integrated Mode” will encounter this issue. Even in the “Music Integrated Mode”, Audirvana Origin would try to show up the “Maximum Volume Alert” dialog, which is invisible. After I disabled “Music Integrated Mode” and played a track, and clicking “do not show next time” checkbox, “Music Integrated Mode” would operate normally (although it still having another issue that has annoyed me for months).

It may be a trivial bug in Audirvana that even in the Music Integrated Mode it would show up the Maximum Volume Alert. Or this showing dialog routine should be implemented also to the Music Integrated Mode.

The rason I always set the volume to maximum is, my mac is connected to a dedicated DAC, which is connected to a dedicated preamplifier, then to a pair of dedicated power amplifiers, to drive a pair of loudspeakers. I always adjust the volume with the preamplifier.

Hi @Kohji_Matsubayashi ,

Thank you for your message. We have been able to reproduce your issue on our side thanks to your report and it will be fixed in the next update of Audirvāna Studio/Audirvāna Origin.

1 Like


I am a long time Audirvana user and when I bought Audirvana Origin it was with the intention to use it in Music Integrated Mode and using Apple Music for keeping order of my music. I should also add that I have an Apogee Duet sound card updated with latest drivers and causing zero problem in other music apps (e.g. Spotify). Initially, on macOS Monterey everything worked as always have been the case during all years with Audirvana. However, my problem in Music Integrated Mode (not in main application) started after installing macOS Ventura (13.1) - after this it has been a long struggle. The main observation is that everything works fine in main application, but when trying to play the first song in Music Integrated Mode, I have to try up to 30 times (with 2.2.7) and it goes in the wrong direction. Once I succeed to get the first song playing (counter starts, and no “Releasing Audio Playback”…), it plays forever until I close and open Audirvana Origin again. Then I am back to square one. I would highly appreciate a solution to this…

Best regards


1 Like

Hi @LLindfors61 , let me know if you still have your issue after the next update we will do.