No direct mode with Audirvana 3.5.30 and MacOS high Sierra 10.3.6

Hi, I upgrade audirvana to 3.5.30 under high Sierra 10.13.6 and the direct mode doesn’t work although I do the patch.
I keep the 3.2.18 and the direct mode work with this version :face_with_monocle:

What’s wrong?!


You can try trashing your preferences and see, because it should work with whatever version of Audirvana and still works now on Catalina 10.15.3 on Audirvana 3.5.30.

Close Audirvana.

Apple hide the Home Folder in User Library at some time depending on OS System…
When you have clicked your Home Folder, and cannot see the Library Folder in there,
just do a ‘‘cmd J’’ to show the folder settings preferences and see at the bottom…
click Show Library Folder and then you’ll have access to the rest forever.

Go to User… Home Folder… Library… Preferences…
trash com.audirvana.Audirvana-Plus.plist and com.audirvana.Audirvana.plist in that folder (those are A+ software preferences, back them up somewhere else if you want to put them back)

Restart MAC. Restart Audirvana, and see.

Thank you for your help but it doesn’t work :confused:
I forgot one thing : in the option of A 3.5, I can put ON the direct mode. But when I play music, the INT icon doesn’t go green…

If it works, the direct mode appears in the preferences of Audirvana, and you can choose mode 1 or 2. Forget the color, there is no green in 3.5 :grinning:

People with any OS now over 10.11.6, don’t see the option in 3.5 by default, it is not there anymore in the preferences menu except if you do the ´hack’ it reappear when it’s working, but no green color :grinning:

So, it works :blush:. Thank you :slight_smile:

Hello there, using mac min (2011) as my music server. I have tried to run the patch to allow direct mode to work. I have followed all the steps as explained by @RunHomeSlow. The step that I am stuck at is when I try to Drop the file IOAudioFamily.Kext from El Capitan in: /system/library/extension . I drop to file and try to Authenticiate with my admi password to replace and I get the following message “IOAudio Family.kext” can’t be modified or deleted because its required by Mac OS.

Not sure what I am doing wrong, I have follow the steps to turn off SIP in macOS high Sierra to allow for this change, any suggestions?

I running High Sierra 10.3.6 and Audirvana 3.5.35

you are sure you disable correctly SIP ?
can you see here it is disable?
click Apple in left corner…About this Mac… System Report

Yea, it’s showing that’s it enabled. I will go through the steps again (for the 9th time - LOL) @RunHomeSlow you note that one needs to have 2 spaces before reboot. I am I to understand that I type “csrutil disable;**reboot” (the ** are representing spaces) or is it “csrutil disable;*reboot”? Thanks


csrutil disable;**reboot

two spaces instead of stars…

Don’t mess your system… not starting good :slight_smile:

Ok, this did not work again, I must not be typing this in-correct.
I am re-booting OS in Recovery Mode as instructed by holding Command R keys. My system re-boots and I go to “Terminal” in the menu bar. The screen open up with “-bash-3.2#” I type right behind this with no spaces after the #csrutil*disable;*reboot ( are the number of spaces - I do not put the star in)

My system report is still showning SIP enabled.

Any suggestion on what I have been doing wrong, I must be on my end.

I just re-read my reply… correction I type #csrutil*disavle;**reboot.

man! there is no # in front of the line…
don’t type it yourself, select the text, then copy and paste it in Terminal

same thing with the others lines below… don’t type them
copy then paste… like that, no errors
no horrors like you might answer while typing :slight_smile:

when you do it right in Terminal window…
it says SIP as been disabled… just restart…

Going to start over again with a fresh OS, and try again later.
Thank you for your help, I do appreciate your assistance.

1 Like

I want to thank @RunHomeSlow for all your help, I reinstalled High Sierra 10.3.6 and followed your instructions and everything is working great. Not sure what happened with my last install of High Sierra, but I was missing SIP codes and was not able to disable or enable from the terminal window. SO will a new OS installed all is working with direct mode with Audirvana. Cheers

1 Like