No DSD option with V3.5 with PS Audio DirectStream DAC

it is staight DSD without loss, just another form of sending it… my dac show DSD64 or 128 as Audirvana shows Sent DSD64 or 128 :slight_smile:

Thanks @RunHomeSlow. That’s what I would expect from the DAC also and what I got with a previous version of Audirvana. However, now the DAC indicates PCM when receiving DoP. And it’s a DSD-based DAC!

I’m baffled but I keep hearing it doesn’t matter. I only have one choice so I can’t compare anymore.

Too much for my knowledge, mine show dsd, but direct usb connect, try a right click on damien for private message maybe

Hey guys!

I took the playback chain apart tonight and reinstalled Audirvana and re-flashed the DirectStream. I got things working using DoP with the DAC recognizing it as such. Small victory!

Still no native DSD though. Will ask again over at PS Audio. Found a video from about 6 months ago with Paul McGowan talking about Audirvana and BitPerfect being his players of choice. So I’m guessing they should know.

Thanks for all your help.

If I learn anything I’ll post it here.


1 Like

Pardon me for jumping in! I have the same issue with my Topping D10 DSD capable DAC.

Like you, the settings in Audirvana say that the D10 does not support DSD. But it does.

While I can still use it (with PCM) I would surely like to see Audirvana recognize that it is DSD capable and show me the option for that.

What is the mechanism by which the capabilities of a DAC (is or isn’t DSD capable, for example) are determined? Is this an active inquiry to the device? Or is it some sort of lookup in a database of devices?


DoP is DSD. Just use that.

Thanks! But… I’d still like to see Audirvana recognize the capabilities of my DAC.

For one thing, though it may seem minor, the D10 has a clever display panel that shows what is flowing through it, and I’d really like to see “DSP” on there when playing DSP material, rather than showing “PCM” as it does otherwise.

If you select DoP and play DSD material you should see DSD playing. If that’s not the case something else is wrong.

Very interesting! Thanks for your help. Indeed there must be something else going on. I’d still wish that Audirvana could be configured to send DSD without the DoP. \

BUT - when I do choose DoP and play a DSD128 file, sadly indeed my D10 shows 352PCM and not 5.6DSP, which I really would prefer to see. I’ll upload a couple of images to show what I’m doing and seeing. One shows the selection I have made in Audirvana. The other shows the Audirvana screen along with the D10, while playing a DSD128 file.

one more…

your settings look like mine…
you sure there is not a setting on your DAC itself that is not turn on?

is it usb connect to mac? you don’t have a thing between the 2 ?

Thanks for your input!

Indeed I have connected the DAC using USB directly to the Mac - nothing in between. I even used the USB cable that came in the box with the DAC!

I don’t know of any way to change settings on the Topping D10.

I did test with Colibri (from the App Store) and when doing that was able to play a DSD128 file that registered as such on the Topping D10… see the annotated photo below to see what I mean (this is playing the same DSD128 file as in the previous example):

you are not upsampling in Audirvana?

I don’t think so… I just checked the “Upsampling” section on the settings screen for the DAC in Audirvana. It says “Forced upsampling type: Deactivated”.

Also, have you tried turning off Exclusive access or Integer Mode in Audirvana preferences to see?

Ah, not until now! But I just tested with Exclusive Mode off, as well as with Exclusive mode On but Integer Mode Off, and got the same results…

thanks for all the help!

try clicking Damien’s name and private message him…

you can try posting here your question maybe more people see it:

good luck :slight_smile:

New data point!

I just tried playing a DSD64 file and… guess what. D10 shows “2.82 DSD”. Interesting!

Works with DSD64.

Doesn’t work with DSD128.

Bearing in mind that DSD128 did work with Colibri. What the heck?

Try dsd over pcm 1.1

you can also try deleting your Audirvana prefereces, maybe something got corrupted somewhere…

Close Audirvana

Apple hide the Home Folder in User Library at some time depending on OS System… When you have clicked your Home Folder, and cannot see the Library Folder in there,
just do a ‘‘cmd J’’ to show the folder settings preferences and see at the bottom… click Show Library Folder and then you’ll have access to the rest forever.

Go to User… Home Folder… Library… Preferences…
trash com.audirvana.Audirvana-Plus.plist and com.audirvana.Audirvana.plist in that folder (those are A+ software preferences, back them up or not)

Restart MAC. Restart Audirvana, You’ll need your serial number i think.
Choose your preferences again in Audirvana menu and audio settings, then try to play a DSD file.