Not able to play more than 1 song in DSD256

I have Audirvana 3.5.43 on a PC with Win10. The DAC is a M2Tech Young MkIII, which accepts DSD up to 256 via USB. The driver in use is MUSBAudio ASIO driver.
I try to play a DSD256 album, and the first song plays normally. Then the second doesn’t start, and if I try to start it manually I get a message that I can’t play it. On a couple of occasions the program froze (once continuing to put out the same sound, once just shutting down). If I switch to Wasapi driver, it can play but converts to PCM.
Should I maybe use a different ASIO driver?
Thanks

Can you dump here the debug info?

Audirvana 3.5.43

SIGNAL PROCESSING:

Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

UPSAMPLING:
SoX not in use
SoX filter parameters
Bandwidth at 0dB = 99.5
Filter max length = 30000
Anti-aliasing = 100
Phase = 66

AUDIO VOLUME:
Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

LIBRARY SETTINGS:
Sync list: 1 folders
AUTO: D:
Library database path: C:\Users\Alessandro\AppData\Local\Audirvana\AudirvanaPlus\AudirvanaPlusDatabaseV2.sqlite

ACTIVE STREAMING SERVICES
Qobuz: Connected as Qobuz Studio
TIDAL: Connected as HIFI

=================== AUDIO DEVICE ========================

Max. memory for audio buffers: 1344MB

Local Audio Engine:ASIO 2 driver version 1083

Preferred device:
MUSBAudio ASIO Driver
Model UID:MUSBAudio ASIO Driver
UID:MUSBAudio ASIO Driver

Currently playing in Integer Mode:
Device: 2ch 8bits Integer, 2 bytes per frame 11289.6kHz

Active Sample Rate: 11289.6kHz

Bridge settings:
Sample rate limitation: none
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:
Local audio device
MUSBAudio ASIO Driver Manufacturer:
Model UID:MUSBAudio ASIO Driver UID:MUSBAudio ASIO Driver

11 available sample rates up to 11289600Hz
44100
48000
88200
96000
176400
192000
352800
384000
2822400
5644800
11289600
Volume Control
Physical: No
Virtual: No
MQA capability
Auto-detect MQA devices: Yes
Not a MQA device, user set to not MQA
DSD capability: Raw DSD (MSB)
Device audio channels
Preferred stereo channels L:0 R:1
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: Yes

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1
2 ch Integer PCM 32bit little endian 44.1kHz
2 ch Integer PCM 32bit little endian 48kHz
2 ch Integer PCM 32bit little endian 88.2kHz
2 ch Integer PCM 32bit little endian 96kHz
2 ch Integer PCM 32bit little endian 176.4kHz
2 ch Integer PCM 32bit little endian 192kHz
2 ch Integer PCM 32bit little endian 352.8kHz
2 ch Integer PCM 32bit little endian 384kHz
2 ch DSD 8bit big endian in 8bit chunk 2822.4kHz
2 ch DSD 8bit big endian in 8bit chunk 5644.8kHz
2 ch DSD 8bit big endian in 8bit chunk 11289.6kHz

Local devices found : 4
Device #0: Generic Low Latency ASIO Driver Manufacturer: Model UID: Generic Low Latency ASIO Driver UID: Generic Low Latency ASIO Driver
Device #1: JRiver Media Center 26 Manufacturer: Model UID: JRiver Media Center 26 UID: JRiver Media Center 26
Device #2: MUSBAudio ASIO Driver Manufacturer: Model UID: MUSBAudio ASIO Driver UID: MUSBAudio ASIO Driver
Device #3: Yamaha Steinberg USB ASIO Manufacturer: Model UID: Yamaha Steinberg USB ASIO UID: Yamaha Steinberg USB ASIO

UPnP devices found : 1
Device #0Denon AVR-X2200W UID: uuid:5f9ec1b3-ff59-19bb-8530-0005cd5aef0d Location: http://192.168.1.3:8080/description.xml

Try to reduce the pre-load cache to 4096MB.


You mean this setting? I can’t pinpoint exactly 4096 though, as it’s a continuous setting…

It doesn’t have to be exactly that. Somewhere around 5000MB is also good.

If you make the pre-load cache too large you’re starving the operating system of resources. This could lead to issues. Also if the pre-load cache is too small, Audirvana might have problem to fetch the data fast enough and might lead to stuttering or interruptions.

Optimally, the pre-cache should be large enough to contain about one song worth of data in a typical resolution you listen.

1 Like

It doesn’t work: the song has started, and frozen on the same sound about 40 seconds in.

That’s weird. Have you tried to download some sampler and try with that?

Try some from 2L test bench:

I have one sample of 2L both at 128 and 256, and that seems to work, but it’s only one song. I will try to download some more.

I downloaded three sample tracks in DSD256 from 2L: they play normally, although there’s a relatively loud “bump” from the speakers at the beginning of the track. Then tried again to play the original record (which by the way is Blues Band, by Vivino Brothers, downloaded from Native DSD), and Audirvana still freezes (playing one note on and on until it shuts down) about a minute into the first track.

Contact NativeDSD, maybe there is domething wrong with the file.

I did. They suggested to try playback with JRiver to make sure it’s not an issue with the files themselves. With JRiver they do work normally, and also play ininterruptly from one song to the next.

I got a further feedback from NativeDSD, saying they found Audirvana sometimes having issues with very large files, depending on which kind of disc they are stored on (which kind of formatting, I mean). In my case, the music resides on a second SSD on the same computer on which Audirvana is installed (i.e., not the disc onto which the OS resides, but a second one).

That could very well be the case if you’re on Windows and the file size is larger that 2GB.

Thanks. I will check the file sizes when I get back home and let you know.

I checked the files’ size: the first file, which now I cannot play (and the first time I did play, but didn’t move forward to the second once it was finished), is 866 Mb. Only two songs are above 1 Gb, and none above 1,2 Gb. And anyway, I didn’t get to those, as they’re not at the beginning of the record.
So the problem doesn’t seem to be file size.

Maybe @Damien3 can help you. I’m out of ideas.

Can you give us more information about it? Who at NativeDSD told you about it? Can you send us a mail at [email protected] with the conversation you had with them?

Sorry, I don’t think it’s quite correct to divulge that. I am only trying to see whether I can solve the problem. Bitracer suggested I contact NativeDSD to check whether the file may be defective, which it isn’t, since the whole record plays normally on JRiver. Therefore, as far as I am concerned, NativeDSD is not involved anymore.
I don’t want to overblow this issue, it’s just a minor nuisance. If you can suggest a solution, I’d appreciate, otherwise, no problem. Thanks.

Hello,
I have almost the same issue and i solved it.
My probleme was with oversampling from pcm to dsd 256.
This ask a lot of work for the cpu and memory.
What are your cpu and memory speed ?
You only have 4Go ram in your computer, can you go to 8Go ?
Can you try another computer in your system (with a trying licence of audirvana)
And to finish my experience / my dac accept up to dsd 512, but when i oversample this there is pop a hum1 second/2 in background so it’s not usable in the life.
Maybe dsd 256 is too much for your dac ?