Please help me. The pitch of the playing song becomes high

Hello. I’m Kana. I am Japanese, so I am not good at English, but please forgive me.
Read the title of this question about what’s happening in my app this time.
Because my mac was a new model, data was migrated from an old mac.
And I wanted to listen to the music using Audirvana, but the music that flows is very strange.
All sounds, such as instrumental and vocal voices, have been high.
Symptoms do not go away after reinstallation. I listened to music on iTunes etc., but there was no problem. I am using a trial version. I am very troubled because I intend to purchase the product version. Help me.

Hello @11123,

Can you send me a copy of the “Debug Info”? You can get it in Audirvana Settings>General>Debug Info

Note: By clicking on the Debug Info Audirvana button automatically copies all its content, all you have to do is paste it in response to this message

EDIT: Regarding the SysOpt errors: Apparently this is because of MacOS’s newest update (see other posts).

Update: I do not have any issues with playback via DAC. However, any AV sound via speaker is still high-pitched and a little faster.

Hello again, I’m now having the same issues as user @11123 with external speakers (I have not tested any Headphones or DACs yet). Any music becomes high pitched (and maybe a little faster?) when playing anything from Audirvana (3.5). Other sources do not have this issue.
I tried to install this GitHub - TrungNguyen1909/AudirvanaDiscordRPC: Audirvana Discord Rich Presence support. but it didn’t work, so I reverted everything that’s changed to default. Idk if this caused the high pitch music “bug” but I wanted to mention it anyway.
In addition, after running “Complete defragmentation of the library database”, I now have the following error:
"There was an error while running SysOptimizer. Not all optimizations can be performed.
Error = The process could not be completed. (OSStatus error 22.)"

Debug Info:

Audirvana Mac Version 3.5.50 (3580)
macOS 13.1.0 with 32768MB RAM


Polarity Inversion:
	Globally: OFF
	Per track: OFF
Effects plugins NOT ACTIVE

SoX not in use
SoX filter parameters
Bandwidth at 0dB = 99.5
Filter max length = 30000
Anti-aliasing = 100
Phase = 66

Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

Sync list: 1 folders
AUTO: /Users/Name/Music/Audirvana Music Lib
iTunes/Music library synchronization: not synchronized
Library database path: /Users/Name/Library/Application Support/Audirvana/AudirvanaPlusDatabaseV2.sqlite

Qobuz: Connected as Qobuz Studio

=================== AUDIO DEVICE ========================

CoreAudio audio path, buffer I/O frame size: 512

Max. memory for audio buffers: 16068MB

Local Audio Engine:
Exclusive access: Disabled
Integer mode: Enabled

Preferred device:
Model UID:1E6DC8C0-0000-0000-011E-010380A05A78

Active Sample Rate: 48kHz
Hog Mode is off

Bridge settings:
Sample rate limitation: 48kHz
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:
Local audio device
ID 0x33 LG TV SSCR2 Manufacturer:GSM
Model UID:1E6DC8C0-0000-0000-011E-010380A05A78 UID:1E6DC8C0-0000-0000-011E-010380A05A78

7 available sample rates up to 768000Hz
Audio buffer frame size : 15 to 4096 frames
Current I/O buffer frame size : 512
Volume Control
Physical: No
Virtual: No
MQA capability
Auto-detect MQA devices: No
Not a MQA device, user set to not MQA
DSD capability: DSD via PCM 1.1
Device audio channels
Preferred stereo channels L:1 R:2
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: Yes

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1

Stream ID 0x34 2 channels starting at 1
1 virtual formats:
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 48kHz

3 physical formats
2 ch Mixable linear PCM Interleaved 24 little endian Signed Integer aligned low in 32bit 48kHz
2 ch Mixable linear PCM Interleaved 20 little endian Signed Integer aligned low in 32bit 48kHz
2 ch Mixable linear PCM Interleaved 16 little endian Signed Integer 48kHz

Local devices found : 4
Device #0: ID 0x33 LG TV SSCR2 Manufacturer: GSM Model UID: 1E6DC8C0-0000-0000-011E-010380A05A78 UID: 1E6DC8C0-0000-0000-011E-010380A05A78
Device #1: ID 0x46 BlackHole 2ch Manufacturer: Existential Audio Inc. Model UID: BlackHole2ch_ModelUID UID: BlackHole2ch_UID
Device #2: ID 0x69 Built-In Speakers Manufacturer: Apple Inc. Model UID: Speaker UID: BuiltInSpeakerDevice
Device #3: ID 0x42 Multi-Device Output Manufacturer: Apple Inc. Model UID: ~:AMS2_StackedOutput:0 UID: ~:AMS2_StackedOutput:0

UPnP devices found : 0

I think you posted in the wrong thread.

Nah, this one is mainly about high pitched music.

Sorry, I misread.

1 Like

From the title of your thread I still get the impression that you still have a problem, but from your post I get that you fixed it already yourself.
So did you solve it, or do you still need help?

If it was a matter of applying wrong settings, it is not a bug, but simply ‘user error’. I know settings for DACS and connection types can get complicated.

It isn’t fixed yet. Most songs are still high pitched but there are exceptions, for some reason.
To avoid confusion I deleted my previous post.
Edit: Also, I didn’t start this topic, its more like I have the same issues as @11123. I can’t mark a solution.

@max2bw … Sample-rate clock mismatches are the reason you are getting playback at the wrong pitch/tempo… The ‘master’ clock frequency (Fs) of a digital playback system must be synchronized for all playback devices, when the playback devices are using synchronized connections like S/PDIF or AES/EBU, where the DAC of the device is not running asynchronously and is dependent on a ‘master’ clock Fs…

My bet is BlackHole is causing your problem… It competes for the Core Audio API’s with Audirvana which wants complete control of the digital-audio-pathway and it’s clocking…

:notes: :eye: :headphones: :eye: :notes:

@Agoldnear Thank you, that’s probably it.
I’m also using Sound Source that, together with Blackhole, might intervene with Audirvana in some way. What do you think I should do? It’s not like I can uninstall Blackhole…I do still need it.

With all things considered, I don’t think there’s a solution without uninstalling Blackhole. Since Audirvana is way too loud for speakers anyway (at least for me) EDIT: foobar is almost as loud as AV, guess I’ll die, I might switch to foobar for use with external speakers only :man_shrugging:t2:
Of course, I’ll keep using AV3.5 with headphones.

I have exactly the same problem with @max2bw !!
Through the external speaker, all the music tracks including classical or traditional ethnic music tracks are becoming higher. It’s a huge problem for me because I need to do some pitch analysis for my research…

And it seems can’t be solved until now, right?

But if I change to using my Macbook speaker, the pitch became normal.

@Soma hello, do you have Blackhole installed on your Mac?

Do these ‘plugins’ soundsource, blackhole, soundflower, etc, have an effect on the audio when not selected? If Audirvana has exclusive rights, does that not negate any influence?

Well, they shouldn’t. That’s the weird thing. Like I said, the issue is limited to external speakers. As for sound source, I think Audirvana has full control over the system audio API while sound source is running, however, Blackhole and soundflower are (probably) different.

Possible solution without uninstalling:

I have configured Blackhole as part of a multi-audio device output, mainly to record desktop audio (btw BH cannot record any Audirvana Audio). I actually tested this earlier but If you have configured such multi audio devices (Audio-MIDI app), deselect the specific audio “plug-in(s)” and the high pitch / faster sound issue should be gone. This means I have to reselect blackhole every single time I’d like to use it but well, this certainly is better than uninstalling.

Screenshot 30

If they are installed, their tentacles (API’s) are generally always connected… They usurp the Core Audio signal architecture so to make the signal routes between applications and manage the clock-rates between them, so to synchronize the devices and applications that are connected to the signal router of the application… These applications could also conflict with the Apple Multi-ouput device Core Audio signal pathways… We would need somebody more savvy about the Core Audio API architecture to corroborate this…
:notes: :eye: :headphones: :eye: :notes:

1 Like

@max2bw No, I don’t have Blackhole installed. I only have EV 3285( the route for external speakers) and Macbook itself.

截圖 2023-01-06 下午12.28.24

One of the issues I had when setting up my system was similar high pitched noise, had something to do with integer mode.

@Soma really? Well, since you’re using AV Studio / Origin you might have installed some plug-in that’s causing issues. I think they have a plug-in feature built-in. Or maybe it’s upsampling or integer mode,
In any case, please post your debug info here.

hi, @max2bw , the problem is solved! But I still want to thank you for replying my question!

Nice, good to know. Still weird, why these can happen in the first place.