"Pop" between songs in kernel streaming mode

Apologies if this has been mentioned but I don’t see an existing thread. I get a loud “pop” between songs that appears to only happen in kernel mode; I tried ASIO and haven’t heard it; and it happens both during Qobuz streaming or music streamed from local library. Is this a known issue being worked or unique to me? Windows 10 with all the latest updates and USB to a Cary DAC100. Thank you.

Hello @kdistefa ,

Does the issue appear when you have upsampling activated or when you play tracks with different sample rates?

I do have upsampling enabled at “Power of 2”; with the r8brain algorithm currently enabled. I want to say it happened with the default settings too but let me go back and reset everything to default and try it. I’ll let you know if it still happens. Thanks.

I think you nailed it. I turned off upsampling and have not heard the pop after four song changes. I do think I detect the slightest “tic” when the next song to play has a different sample rate; say going from 44.1 to 96Khz; but it’s very slight and I can live with it. Greatly appreciated. I’ll run it with no upsampling for now and watch release notes for a fix in a subsequent software release. Thanks again.

Spoke too soon. Not totally fixed but better. Just got a nasty “snap” going down from a 24/96 file to a 16/44.1Khz file. Once every six or seven songs is better than after every song but thinking I’ll go back to ASIO until this is fixed. Too bad; kernel mode was one of the main selling points for me to upgrade to Studio.

Does your device works well if you try to use WASAPI?

Sorry Antoine, just logging back on to the forum for the first time in awhile. Yes, WASAPI works fine. However I have had two upgrades of Studio since my last note and no longer hear the “pops” between songs with upsampling enabled in kernel mode. I didn’t see anything specific in the release notes that this was a fix but maybe it fell under “minor fixes”? Either way since the last upgrade it seems to be fixed; unless it was something unique to my setup that worked itself out. Thanks for the help.

If I can say something about that, then I don’t use resampling. Plop between songs is still in kernel streaming mode. In ASIO it’s ok but ASIO is worse for my ears so I would like to figure out what it does. I also tried to lower the buffer and it didn’t help. It just doesn’t do it after the right song, but only after about the fourth, then still …

HI!

Mine is a curious experience. When i have the ZEN DAC V2 official drivers installed on my Windows 10 PC, i get those noises in KS mode also. If using ASIO mode, the noises go away. Like you, to my ears KS mode sounds better, so my solution was to uninstall the ZEN DAC V2 drivers from my Windows 10 PC. I am using the Windows 10 generic USB 2.0 HD audio drivers and this way i solve 2 issues:

  • No more noises in KS mode;
  • MQA birate/sampling rate is correctly displayed with the blue or green dot next to it.
1 Like

Im still getting loud pops and harsh noises between songs in Kernel mode. I have done all the latest updates as soon as they come out. I dont use upsampling as I let my Chord Qutest do that bit. Windows 10 laptop. Im now listening to a few albums in Wasapi to see if it still does it. I will check Asio as well. The pop is very loud and not great when listening at any loud volume. Do you think skipping to the end of each track will be ok to test or do I have to let the whole song play?

Ive been testing it again today. Its stopped doing it using WASAPI. Previously I was using Kernel Streaming mode on Windows 10, No Upsampling and a Chord Qutest Dac and I was still getting the loud pops/hiss.

I have the same problem, but for my ears, KS + r8brain upsampling to DSD makes a remarkable difference I now don’t want to live without.

In WASAPI and ASIO, no pop between tracks but the tracks randomly stop in the middle.

In KS there’s incidentally this pop and the tracks ALSO randomly stop in the middle, but it is a bit more rare.

@Antoine, Is there any sort of behind-the-scenes work in progress to address these instabilities?

Thanks, Ed

Im also concerned what possible damage these loud noises may do to my equipment. Infact that’s my main concern to be honest. I think Studio is great and have paid for the year and dont mind persevering for updates etc but would like some updates on this please. Ive spent over £10,000 on Amps/Speakers/Subwoofers/DAC’s etc and I am more concerned I damage it. Thanks

Hi.
When you have installed those ZEN DAC V2 drivers, which driver do you play through? Does the DAC not need a driver? I want to try it but when I delete the driver from me Gustard I don’t know how Audirvana will see my DAC …

Without a driver (Windows) the DAC may work because Windows has also a “generic” driver wich works in most cases but has not the same quality.

Doesn’t it have the same quality? So will it be worse?

Hi all!

As i stated in my message, to my ears, KS mode sounds better than ASIO, with ZEN DAC V2 drivers. With the generic Windows USB 2.0 HD audio drivers, i can use WASAPI and KS modes, not ASIO. ASIO usually requires specific drivers.
@THXKO The best is always to try for yourself what sounds better in your system. I don’t know if your DAC is compatible with the USB 2.0 HD Audio standard for Windows 10. If your DAC is USB connected, try uninstalling those drivers and rebooting your PC. If the Windows 10 USB 2.0 HD Audio driver recognize your DAC, you will be able to check the Sound settings in Windows 10 for it, making sure it is the default audio source. Then launch Audirvana and see if it detects it. If it does, try playing sound tracks that you are very familiar with so you can have a way to compare with the previous setup. And judge for yourself if it is better or not. If not, you can always re-install your DAC specific drivers.
As i stated in my previous message, not only does Windows 10 generic USB 2.0 HD Audio driver detect my DAC capabilities (bitrates/sampling rates), but Audirvana also detects correctly all of my DAC capabilities including Full MQA capability (with ZEN DAC V2 drivers installed, i have to force MQA Decode mode!!!), so i guess ZEN does a worse job with their own drivers than Windows programmers…

1 Like

That’s extremely useful, thanks a lot! Will try it out and see what happens. I also have to force MQA decode at my DAC (SMSL SU-9), which otherwise runs fine.

Please please please, we must find a way to stop the pop/crackling sound between tracks and solve the stability problem of tracks randomly skipping to the next one.

I am willing to betatest as much as practical (and pay!) to get this working. It’s too bad I can’t un-listen to r8brain upsampling to DSD512. There’s no going back.

I’ve also experience the “pop”, or more accurately a quick burst of white noise between tracks in KS mode. I’m not up-sampling and the tracks in question are of the same bit-depth / sample rate, usually on the same album. I don’t have this issue with either AISO or WASAPI modes.

I have the iFi Zen DAC v2, using the latest drivers, and the issue seems to be random as it doesn’t happen all of the time.

@Antoine has to say if it’s useful, but I can imagine that user data here can be helpful to make a root cause analysis.

Does it mainly happen on:

  • Win10
  • in KS
  • with brand, type and version (an IFI DAC V2)
  • with the drivers from IFI itself?
  • local
  • streaming
  • upsampling
  • HiRes files
  • not after restart PC
  • not after restart Audirvana
  • after 7 songs
  • no pattern when it happens
  • ……

Perhaps a common factor can be found that will allow Damien to solve a specific (driver.buffer?) problem.