Possible Studio/Windows issue using usb/digital interface

I purchased the following digital interface with the femtosecond clock option. I wanted to see if the reclocking of the device would improve resolution and it does. Am very pleased with the change in sound. However, about 80% of the time I get noise between tracks. Sometimes its a short burst of pink noise but most of the time its a few notes of music that I think is from the buffer either emptying or taking in data. No noise occurrs with other windows playback software: foobar 2000 or windows media player. Also no noise with Audirvana/IOS with the buffer set the same as with my windows machine. Any chance a mute button between tracks could be offered, like the current one for changing sample rates? Any other ideas on how to address the issue? The device really improves the sound of my Yggdrasil Less is More DAC.

Did you play with the settings below in Audirvana? In the screenshot below these are settings for a Topping Dac I have connected, but they should be there for your output settings too:

Also what might help is changing (in Audirvana) to WASAPI, Kernel Streaming or ASIO.

Are there also (I2s) settings on your usb/digital interface or your DAC itself to mute between tracks? (I am asking because I have a Topping DX9 DAC which has this option built in).
Note: My output device is also connected directly via USB.

Thanks Andy. Yes my settings are as you show. No switch on dac or interface for muting between tracks. If I switch from Kernel Streaming to ASIO the noise does disappear but I much prefer the sound of Kernel Streaming.

Also in the “DAC Input” field in settings I use Kernel Streaming Extreme.

If you add latency like 0,5 or 1 sec, do you still have your behavior?

I don’t know if adding latency helps. How does one change the latency in Studio? Thanks for your reply.

That is the first indicated setting in the previous screenshot. I still suggest (as in the previous post) that you try to experiment with various values for both settings.

Also it would not hurt to change the KS Extreme setting to something lower. Never hurts to try. I have seen posts in the past about some problems with KS Extreme. Some hardware seems to have problems with it.

1 Like

Some additional (and background) info:
As far as I know Foobar2000 and Windows media player don’t use Kernel streaming.
Foobar2000 uses WASAPI (in exclusive mode) or ASIO (with a ASIO plugin installed). Windows media player always uses the default output settings in Windows (and can not do WASAPI (exclusive), ASIO or Kernel Streaming at all).

Your issue seems to narrow down to Kernel Streaming since you don’t have the problem with ASIO and WASAPI in Audirvana as well. As said, some hardware does not play nice with Kernel Streaming. Kernel Streaming is an ancient technology in Windows and Microsoft replaced it with the more modern WASAPI (Windows Audio System Application Programming Interface).

Both (KS and WASAPI) offer a complete bypass of the Windows audio processing system (volume mixer and dsp/resampling etc.), so (in theory) should give the same results. Kernel Streaming is ‘closest to the hardware’, closely followed by WASAPI which has a more modern and friendly interface for developers than the ‘ancient’ Kernel Streaming.

All This additional info sadly does not change anything to the tips already given by @Antoine and in previous posts:

  • Experiment with the settings in the previous screenshot.
  • Experiment with other settings than ‘extreme’ in Kernel Streaming.

Here some links with additional info about KS vs WASAPI vs ASIO:

Kernel Streaming, ASIO, WASAPI… and music players (Foobar, JRiver…) | Audio Science Review (ASR) Forum

Kernel-streaming vs. ASIO vs. WASAPI - Studio - Audirvana

Kernel Streaming better than WASAPI? (devialetchat.com)

Really appreciate all the thoughtful replies. Unfortunately I’ve spent the last couple days testing various combinations of settings none of which solved the problem. Reducing latency to zero helped a bit but did not eliminate the problem. All other latency values were equally bad at eliminating noise between tracks. I agree that it’s likely a Kernel Streaming problem as I get no noise withASIO and WASAPI. Reducing buffer size to the smallest value reduces the noise to a brief click but degrades overall sound quality. Don’t know if it’s feasible but an automatic mute button between tracks would eliminate the noise. Because sound quality is my muse in this hobby I’ll likely stick with Kernel Streaming……

Maybe have a look at this thread as well. Audirvana seems aware of the KS problem (and it seems they are going to address it). In the last posts someone seems to have found a workaround. Maybe it helps also in your case:

Bursts of short distorted noise shots between songs :frowning: - Studio - Audirvana

1 Like


As 0G78 said in the link referenced above, turning on software volume control seems to fix the problem. Though I prefer the sound with software volume control off. The XMOS device Im using came with a driver package that included an ASIO driver. Not sure how to uninstall just that driver…

Hi @boleary if you have the volume control ‘enabled’ in Audirvana and put the volume slider (in Audirvana) on ‘max’ (0 db) there is no technical difference with the volume control ‘disabled’ (‘disabled’ simply sets the volume slider on ‘max’ internally and prevents you from using the volume slider). Both settings (volume disabled, or enabled with slider on max) are ‘bit perfect’. There is no sound quality difference between the two. If you perceive a difference this certainly can’t be the reason. Maybe check the position of your volume slider in Audirvana?

Uninstalling an ASIO driver in Windows is exactly the same as uninstalling any other program:

Uninstall or remove apps and programs in Windows - Microsoft Support

In Windows go to ‘Settings\Apps’ and uninstall from there.
I have a Topping DAC and In my case the program/driver is listed as ‘Topping USB audio device driver’ in the Windows apps and can be removed/uninstalled just like any other program. The screenshot below is from Windows 11:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.