Problems with Audirvana Origin

I was very pleased when Audirvana Origin was announced, as that’s what I was waiting for. Albeit quite expensive, finally a stable release that addressed the bugs afflicting Audirvana+ - at least that’s what I assumed. Sadly, after testing it on the trial version for a few days, that doesn’t seem to be the case. As in A+, very often the playback interrupts, sometimes after playing just the first or second song from a selected album. In some cases, an error message appears, saying “unable to open audio device”; some other times, no error is displayed. When that happens, the software just stop working and no audio file can be selected for playback any more, the software just becomes unresponsive. The bug has already be reported by others, so it’s not just me experiencing this issue.

I have Audirvana Origin installed on a Macbook (2015), with Catalina 10.15.7, and 16 GB of RAM. Apparently that’s compatible with the system requirements.

Bugs aside, the new UI looks definitely cleaner, but lots of usability issues still affect the overall experience:

  • Album selected, no list of tracks available, just the album cover. None of the buttons or text visible allow to load the whole list of tracks in the album.
  • Clicking on an album cover has inconsistent effects, based on where it happens. Sometimes it selects the album, sometimes it starts to play it.
  • Bugs in the way the pause/play button responds to user input.
  • List of recently added in autosuggest overlay do not disappear, as the user starts typing.
  • There is no stop button anymore, but the message “Please stop playback to change audio settings” still appears, as in A+.
  • The settings cog is mysteriously disabled, for reasons that are hard to comprehend.
  • Visual feedback on Audio dynamic analysis is not provided, it seems to be broken, when in fact it does work (it just won’t give you any cue that it’s working).
  • Still no way to jump fwd/backward with keyboard shortcuts.

Considering the many usability issues and the fact that the software is totally unreliable in what is supposed to be a no-brainer, play an album from start to end without forcing me to restart the machine, I have decided that I am not going to extend the trial. At this point, I think I am done with Audirvana. I’ve been submitting bugs for years, helping the team improve the product, but problems still occur. The license is quite expensive and while the usability issues would not be a deal breaker, the playback bug definitely is.

I am afraid I can’t send the logs, as the trial has expired - unless there is a workaround.

1 Like

I’m using Audirvana Studio, so basically Origin but with all bells and whistles.

Regarding the stop button. I fully agree with you there. It’s annoying that you have to click on the little padlock to get it to stop and unlock the sound output. 3.5’s stop button made far more sense.

I’ve never run into your described Album selected bug. Single click on an album and it opens up as it should. All tracks are there and by scrolling down the rest will show up.

The media keys (play/pause, next track, previous track) on both my Macs work as they should. They also work when AS plays music in the background while I’m using Chrome.

I’m currently running AS on my 2 MacBooks. A 2020 M1 MacBook Pro and a 2017 MacBook Air. Both have 8 gb of RAM and are running on macOS 12.4 Monterey.

Lastly I don’t run into playing bugs here either. Both my Mac’s happily play music all day. Only thing I can think of about this might be your connected sound devices. I’m using USB sound cards to connect my Macs to my hifi and monitor speakers. But I’ve read a lot of people here having problems with UPnP connections going bonkers in similar ways that you are describing.

I hope you’ll find something that does work for you :smiley:

Thank you for your kind reply. Audirvana Studio and Audirvana Origin are two different products, not sure to which extent do they look alike. I did consider it could be an issue with the DAC, but that doesn’t explain the fact that 1) it works just fine with Google Play music or other local media software, and 2) if it was an issue with the DAC, I guess Audirvana would still keep running, rather than saying “Unable to open audio device”. Good for you if everything works fine on your machine. Unfortunately I have been trying to make this work for a long time, and when it seems to be stable, it suddenly reveals that some issues are still there.

Well Audirvana Origin has the same interface as Studio does. Only difference is that Studio has added options like Qobuz & Tidal streaming, Internet radio and podcasts. Origin was created solely to play local files.

This is what Studio looks like here.

When it comes to DAC’s. I’m only using USB sound cards for both my MacBooks. And they work fine. But as I’ve mentioned before, other people who use UPnP to connect their devices have issues with Audirvana while other programs work.

@LucaBen,

I would like to reply to your post not to refute it, but just to offer a counter example. I am running on a 2018 Mac Mini on the latest and greatest version of Monterey. I use a Schiit Modi 3 DAC.

Audirvana Origin 1.0.5 (10005)
macOS Version 12.4 (Build 21F79) with 16GB physical RAM
Connected account of : Michael Sacks

=================== AUDIO DEVICE ========================
CoreAudio audio path, buffer I/O frame size: 512
Max. memory for audio buffers: 13312MB
Exclusive access: Enabled
Integer mode: Enabled

Preferred device:
SCHIIT AUDIO SCHIIT MODI 3
Model UID:Schiit Modi 3:0D8C:0066
UID:AppleUSBAudioEngine:Schiit Audio:Schiit Modi 3:14600000:1

Active Sample Rate: 192kHz
Hog Mode is off

  • Album selected, no list of tracks available, just the album cover. None of the buttons or text visible allow to load the whole list of tracks in the album.
  • Clicking on an album cover has inconsistent effects, based on where it happens. Sometimes it selects the album, sometimes it starts to play it.

I don’t experience this issue. Here is a screenshot of my album view.

Here is what happens when I l hover over an album:

Here is what happens when I left click on an album cover (single click not double click).

This behavior is reliable and consistent for me.

  • Bugs in the way the pause/play button responds to user input.

I don’t experience this.

  • There is no stop button anymore, but the message “Please stop playback to change audio settings” still appears, as in A+.

The stop button is now a lock. I get that it’s idiosyncratic but now that I’m used to it, I don’t give it a second thought.

I have no issue playing an album from start to finish.

I hope you find solutions to the issues that are preventing you from enjoying this software. My point of view may differ from the majority of users on this forum. The nuances of the UI are not the main event for me; it’s only ever been about the sound quality. For me the UI is usable and more than good enough. The sound is spectacular.

When it comes to the UI, all the usability issues that I’ve reported are real, so that means that we are looking at different versions of the software. I appreciate you are trying to be helpful but those issues do exist in Audirvana Origin.

Hello @LucaBen,

Do you remember if the first time you opened Audirvāna Origin you had a window telling you that a migration was done by the software?

@Antoine Unfortunately I don’t remember if that happened. Could that be at the root of the problem I am describing?

Yes it can. Some users reported issue when switching from an old version of Audirvāna to Audirvāna Origin or Audirvāna Studio.

To get rid of this, you will first need to move the old AudirvanaPlusDatabaseV2.sqlite file to your Desktop for example. After doping this you will to remove the AudirvanaDatabase.sqlite file.

To go to it with the Finder:

  1. Open its Go menu
  2. Pressing the option (or alt) key, and maintain it pressed. This reveals the Library command in this Go menu.
  3. Click on this Library command
  4. In the Finder window that opens, navigate into Application Support, then Audirvana
  5. You’ll find there the file AudirvanaDatabase.sqlite

Special Warning : When you delete the file AudirvanaDatabase.sqlite, you will lose all the Playlists you created in Audirvāna Studio.

However, you can back-up all those Playlists by going in the Local section of Audirvāna Studio.

When it has been done, please reopen Audirvāna Origin, a new AudirvanaDatabase.sqlite file will be made and you will have to sync your files again.

@Antoine Happy to try this route. Would it be possible to get a 2 weeks extension, since the trial has now expired?

I gave you the extension.

Thank you, much appreciated. Will let you know at the end of the trial if the problem is resolved.
I also wanted to give more details about one of the issues reported above. If I search a song by title, and then select it, there is no way from there to go to the album, and see a list of the tracks in the album. The fact that I only searched for one song in the first place doesn’t mean that I intend to stay in that mode forever. Let me explore what’s in the album, by clicking on the album name, or on the icon that sits next to the playback controls toolbar. Thanks

@LucaBen,

I suspect when you get your installation sorted this issue will go away as well.

I search for a song title:

If I click on See All I get this:

Clicking on any Album in the Album column gives me the song listing for that album.

@TribecaMikey Thanks, unfortunately it doesn’t work that way on Audirvana Origin. I tried, and I only get the album cover, no list of tracks. I would also be some sort of workaround, and there’s no reason to make it so difficult. People should always find a way to the content they need, rather than being forced into a specific workflow that they have to discover and remember. I see no reason why I can’t find that list of tracks from the places where it would be intuitive to have that content available.

It should work as @TribecaMikey describes. It also works that way on my Audirvana Origin and it also worked that way on my version of Audirvana Studio. They both have exactly the same user interface. As said by others already they are basically the same product, they only differ in streaming capabillities.

Why it does not work for you I have no idea, but it clearly is not supposed to do that. It seems you have a problem with your installation and/or your system. But, as far as I can see this is not an omission in Audirvana because (as I already said) it should work as described above. Needless to say that you should wait until Audirvana has completely finished the library sync, because data could be incomplete if it is not finished syning yet.

I wish I could help you further with your glitch, but I think @Antoine is better equiped to do that.

@AndyLubke I am on Mac OS, I am not on Windows. So the glitch may be limited to the Mac OS version only.

1 Like

hello, is this the same issue that you are having?

@cosmicpoems Yes, it is. Thanks for bringing up this thread. I hope this gets fixed in the next release.

Hello @LucaBen,

Can you try to reproduce this issue with this test version?

https://audirvana-my.sharepoint.com/:f:/p/antoine/Epl5qCoq7QxBpw35tEss4A0B11Gdti2HczsJi4kuY0gL3w?e=Uukr45

@Antoine Thanks that was a good suggestion, it works fine on this new release, I am glad it’s been addressed.
I am still having issues with playback, though. Today the speakers suddenly became silent around the middle of the second song in the album. Since the UI in Audirvana looked normal (no “file missing” error message, and it kept playing), this time I am not sure if it’s a software or a hardware issue. I am doing some more testing. Would it help to send debug info?
After quitting Audirvana, the speakers were still on mute, despite the fact that the DAC they are connected to (a Pro-Ject Pre Box S2 Digital) was selected in the audio options. Do you think it’s more likely that Audirvana is causing this, or could it be a problem caused by the DAC? I know that Audirvana takes control of the audio settings in quite a significant manner, so I am not sure what could have happened.