Really need to come back to older A+Remote

My situation is as follows:

  • My DAC does not work with any OS higher than Yosemite (manufacturer stopped to update drivers)

  • So I cannot use Audirvana 3.5

  • Audirvana Remote has automatically been updated to the new version in my iPad and in my iPhone

I have tried to reinstall the older Audirvana Remote by restoring my iPad from a back-up in my Mac and does not work: it only downloads the new Audirvana Remote

I hardly can use the new A Remote and I have lost most of the features

What can I do? Somebody with the same problem? Any solution?

I have tried almost every idea and suggestion offered by Apple forums and do not work

1 Like

Not a good position to be in, Yosemite dropped out of support over two years ago.

Sorry, no solution to offer, but just out of interest and to avoid that DAC (or perhaps the whole manufacturer), which one is it?

I assume you’ve tested without drivers on current releases of OS X (umm, let’s say Mojave, maybe not quite Catalina just yet)?

Hello, I have a similar problem - my DAC M2Tech HiFace does not work with Mac OS higher than Yosemite. Why does everyone go off with the new updates?? My 2009 iMac works fine with the HiFace DAC - with Audirvana, it sounds great! Why should I change the Hardware? I mean, we are not talking about changing from SDTV to HDTV or from DVD to Bluray - it’s not a system-problem, it’s a simple software problem of compatibility - and by the way: what about sustainability? And by the way: my HiFace works with windows 7 AND Windows 10 both - Finally, my next computer is NOT an apple, my next playout software is NOT audirvana…

1 Like

I am in a similar position. I am using an older version of Audirvana 2.2.6 (Mac), and it appears the new Remote won’t work on any versions other than 3.5.

For now, I am using another app “Screen” to access and manage remotely the MacBook that runs Audivarna. It works but you might find it is sluggish compared to the previous Remote. You can try other similar software.

I also tried the Apple Remote device. It can play and stop the current selection but won’t move the cursor to navigate. It seems I need to connect my Apple TV box to the computer to make it work - haven’t tested it yet.

In the connected world, unfortunately updates are necessary for security. Blame Apple all you want, they support old hardware for a reasonable time - I still use one 2010 mbp. Yes, they could support hardware just a bit longer, but supporting ancient OS releases is another thing and no, it’s not a simple software issue, it all gets extremely complicated and dirty very quickly.

The same goes for third party software; Supporting the ancient library versions of dead operating systems is not feasible - practically, it’s near impossible. When an OS reaches its End-Of-Life, it’s only reasonable that software developers drop support for it as well - sometimes it happens sooner, sometimes later, depending on when building on the old platform becomes too involving or just plain impossible.

Unfortunately, the original M2Tech HiFace predates the USB Audio Class 2 standard. Not providing drivers for proprietary third party hardware can not be blamed on operating system vendors. On the other hand, take Microsoft, they didn’t even support standard UAC2 devices before Windows 10 release 1703…


If you need a modern, good UAC2 DDC, I’d recommend checking out the Topping D10.

PPS… I use more operating systems daily than most do in their lifetime. They all suck, so just pick your favourite poison and hope for the best.

1 Like

We are talking about the new Audirvana Remote thats just been released. If it was designed to be compatible and run only with Audirvana 3.5, then I think they should not have dropped the old version of the Remote in the AppStore and instead released the new version for 3.5 only.

Since it was released as a “free update to the previous version” of A+ Remote, then it gets downloaded automatically or unknowing users may download the update replacing the old running versions of Remote for their old version of Audirvana. Once it happens, you are done. There is no published processed to recover/reinstall old version of the Remote.

Thank you Jannek. My DAC is M2Tech Young (first release, not the Young DSD). It does not work with Mojave, I will try with Catalina but as far as I understand the problem comes from DAC manufacturer, not from Apple
As I have a Mac mini just for music, I have no problem in maintaining it in Yosemite … but my problem is still not solved.
To clarify: I am quite happy with Audirvana - Audirvana remote combo and with the sound of my M2Tech Young but I am not happy with the postsales policy of M2tech: no other to blame (I can tell much more things here but I want to keep focus in my real problem)
Still, the only solution that I see is to “downgrade” the Audirvana Remote app in my iPad, some good soul?

The situation is worse than I thought, at least your cases now have more meat on the bones.

The damage is done, what was intended as a free upgrade “bricked” some setups. One solution would be a final new build of the older iOS remote, released as a separate application (with a different name), either with merged licensing or available for free.

I can see why you aren’t that interested in a new DAC, that Young has been quite an investment and still seems like a nice piece of kit - apart from being Italian, that is. :wink:

Yosemite, though… I’d wouldn’t even use a web browser on it anymore, keep them well hidden.

1 Like

Thank you Janek
Your proposal that I quote:
“One solution would be a final new build of the older iOS remote, released as a separate application (with a different name), either with merged licensing or available for free”,
Is for me an excellent idea and would make my life much easier as well as the life of other M2Tech customers, I think.
Hopefully somebody in Audirvana will listen to this

Fully agree on the suggestion for a separate release of the old version of Remote.

1 Like

+1 for a seperate release of the old version

Please a seperate release of the old remote version for Audirvana under 3.5


no limitations for the new remote !!!

My new Iphone has the update. I went to my Ipad and forgot I had turned off wifi. I have the original remote on Ipad, so I’m charging my old Iphone right now to see if it is still there. I’ll use it soley as a remote.

Same here. While offering a few nice features, the new remote app is less stable than the prior one. I would love to have the option to retain the older remote app.

With all the issues reported with the new Remote, it seems Audirvana chose to be quiet and not offer solutions at all. Can’t use their Remote, Time to consider other software options.

Je ne comprends pas le manque de réaction, le silence de Damien !?

A total disaster. I used to rave about the simplicity of the A+Remote. Now that I unwittingly upgraded to the new remote the functionality of using the remote is gone.
It is unfortunate that we cannot have the choice to go back to the older remote. Worse still the deafening silence from Audirvana to address our concerns.

I updated to the new Remote app and have lots of problems.

  1. Artist view only shows artists starting with A or B and the rest of my library artists are nowhere to be seen. There is also no alphabetical sidebar in Artist view for quick navigation. Strangely there is a sidebar on Album view but not Artist.

  2. While playing a track Audirvana randomly skips to the next song midway through a song.

  3. As others have noted, it’s frustrating that when navigating back after a search, you are returned to the top of the pages.

I’ve repeatedly tried reinstalling the remote app, but this doesn’t help

If I access Audirvana directly on my Mac mini it works fine.

I’m using the Mac mini as a dedicated music server and have the remote running on a 2017 iPad. Audirvana and O/S are all latest versions.

Any ideas to resolve this?


I am in similar difficulty. I need to communicate with the Mini with my computer and I cannot upgrade the systems from Yosemite or I will lose essential software. Eventually, yes I will have to, or buy a new computer in order to keep the old data. However, it all works fine so I am reluctant to do this in order to run a new version of a remote app that worked perfectly. I want the option of downloading the former app for the older Audirvana. It sounds fine. Also is the new remote app working as well as the old one? Yes there were glitches with the old one but I was familiar with them. I am grateful for your letting me know that I can’t get the old one back from the back up since that is what I was going to try next.

Hello everyone,

Regarding the automatic update of A+ Remote to the new app, this is an iOS settings that you can enable or not in your iOS device settings. This can’t be controlled by Audirvana at all.

For the A+ Remote we can’t bring this version back anymore. Due to Apple App Store limitations, having both old A+ Remote and Audirvana Remote available together would have prevented to offer to all A+ Remote the free upgrade to Audirvana Remote.

That’s why we have chosen the free upgrade for all A+ Remote users.

As this non maintained audio device is preventing you from upgrading past Yosemite, this strongly limits your choice of recent applications. For Audirvana, this means you can’t get past the 3.2.18.

Now, what are the issues you’re having with Audirvana Remote?

Sure, the new features (e.g. playlist editing, advanced filters, all favorite types, …) require Audirvana 3.5.

But you can still get the feature set of the old A+ Remote in Audirvana Remote.

Please note there is an issue preventing to access some albums contents in the current 2.0. This is fixed in the 2.1 that has now been submitted to Apple for App Review. It should then arrive shortly.