Results and MQA Playback

Hi all

I am using the beta with an iFi iDSD Nano BL and everything seems to work very well with the possible exception of MQA. All the PCM and DSD sample rates play perfectly with neither hissing nor clicking and the DAC happily switches the LED colour to indicate the rate.

MQA, however, does not act as expected. I have a number of MQA sample files which should turn the DAC light Magenta if unfolding is being done properly by Audirvana, leaving the iDSD to render. The LED remains stubbornly green indicating a PCM 44.11/48/88.2/96kHz rate BUT Audirvana shows the correct details for the file being played, identifying MQA and the ultimate rate.

Either Audirvana is correctly identifying the file but not processing it or my iDSD is not operating correctly (latest F/W is loaded) or I am misunderstanding what I am seeing.

Can anyone advise?



Perhaps this will shed some light. I looked in ‘Debug’ info and found the following two lines

Auto-detect MQA devices: Yes
Not a MQA device, user set to not MQA

It would seem that I need to change a setting but I can’t find where to do so?

Today I have been experimenting with upsampling.

Pleased to report that all the upsampling settings work well and I am not experiencing any spurious noise of any kind.

Your DAC should be recognized as MQA, as the automatic detection is enabled.
Anyway, you can force it by setting “MQA Renderer” in the audio settings.

Thank you for that. I am new to Audirvana so can you explain exactly where the ‘Renderer’ setting can be found.


Open the detailed audio settings by clicking on the small Arrow right of the device name in the device selection popup
Then open the top section (“Device”) if it is not already open.
The MQA setting is in the “Active Audio Device” paragraph

Hereis the Settings paragraph with Auto-detect enabled

and here Auto-detect is disabled

There is no option to select MQA manually.

Inline images now fixed.


I have put links in my previous posts. The layout I see is quite different from yours. Could it be the use of ASIO??

Should not be.
What if you select another audio device in WASAPI first?
I’ll check this with my micro iDSD later today.

Thank you. I appreciate the help!

I will try WASAPI and let you know.



MQA is correctly detected using the iDSD as a WASAPI device. Unfortunately, the iDSD is not recognised as DSD capable using WASAPI. So at the moment I can have MQA or DSD but not both.

The basic ‘bug’ report is therefore that the iFi Nano iDSD is not recognised as MQA Render-capable in ASIO mode.



Some further information.

When Audirvana is in WASAPI mode, I am getting some of the effects noted by other posters - noise and loud, intermittent crackling - on playing DSD recordings. Some issue with DSD over PCM perhaps?

In ASIO mode, everything is a smooth as silk and the only issues is the recognition of my iFi Nano iDSD BL as a MQA renderer.

This software is a definite purchase for me as soon as it is available.

I can confirm I have this issue as well using the iFi Nano iDSD BL on W10. Great beta so far!

You may want to try to unselect the option “Use large WASAPI I/O buffer” in the detailed audio settings as the nano may have compatibility issues with it.

Yes! That has cured the bursts of noise! Many thanks Damien.

I also have the ifi Nano BL running on Windows 10 update 1803. I have noticed that the WASAPI audio mode will correctly recognize both DSD and MQA playback if you do not install the ifi ASIO drivers. However, if you install the ASIO drivers it causes the issues you have mentioned. I noticed it also limits playback to a maximum of 32/192 instead of the 32/384 it is capable of.

Also for me personally I was limited to a maximum 96kHz for MQA when playing back in ASIO mode even when manually setting the MQA Render option.

Just received an update. ASIO now works correctly with MQA+DSD for the ifi Nano BL.

Yes - v1018 now allows MQA to be used correctly in ASIO mode. It is not auto-detected and requires one to select MQA Renderer manually but this is minor.

Thank you Damien.

I am reporting this as a possible bug but I don’t know enough about WASAPI to be sure.

The following picture shows the WASAPI set up with an iFi Nano iDSD BL in WASAPI mode. The DAC capabilities seem to be somewhat reduced. PCM should go up to 384, DSD to DSD512 and the MQA Renderer is not auto-detected with nowhere to select it manually.

I am an ASIO user and am happy that this now works correctly. This report may just be my misunderstanding of what WASAPI can do.

  1. This is a WASAPI limitation
  2. For the MQA detected capability, I’ve added its display in the settings, when auto detected (for build 1019).
    When you have changed the “auto-detect MQA devices” option, you need to unplug then replug your DAC to have it taken into account, or restart Audirvana Plus