SysOptiimizer Error: Audirvana Origin 1.0.3 (10003)


Just installed Audirvana Origin and tried to play one track, It prompted to install SysOptimizer, then ended up getting this error.

My environment is as follows:

  • macOS 12.3.1 (21E258)
  • MacBook Air (Retina, 13-inch, 2020)
  • 1.2 GHz Quad-Core Intel Core i7
  • 16 GB 3733 MHz LPDDR4X

I have followed some of the previous topic suggestions of deleting LaunchDaemons and PrivilegedHelperTools items, reboot and retry. But was not successful.

Hope there is a fix. Thanks.

You mean those commands?

sudo chgrp wheel /Library/PrivilegedHelperTools

sudo chmod 1755 /Library/PrivilegedHelperTools

If its still not working an you close Audirvana and do the three commands below in Terminal ?

sudo launchctl load -w /Library/LaunchDaemons/com.audirvana.SysOptimizerTool.plist

sudo rm /Library/PrivilegedHelperTools/com.audirvana.SysOptimizerTool

sudo rm /Library/LaunchDaemons/com.audirvana.SysOptimizerTool.plist

After doing this, can you open Audirvana and play a track?

The privileges and rights for the /Library/PrivilegedHelperTools has been set as follows, so I do not have to run the first two commands you mentioned;

drwxr-xr-t  14 root  wheel             448 Apr 15 23:09 PrivilegedHelperTools

The commands I meant were the three commands you mentioned later. I did three times so far and still getting the same error each time I try to play any music.


You can read that thread, might help you


Well, I have not had one problem while I was using original Audirvana.

When I upgraded to this latest Audirvana Origin 1.0.3, this became a very annoying issue. Every time I try to play a track it pops up telling I need to install SysOptimizer then gets this error. When I click on “OK” button, then it plays the track.

I wonder if this is a SysOptimizer issue or Audirvana Origin 1.0.3 issue, to be honest.

Can you go in /Library/PrivilegedHelperTools/ and check if you have com.audirvana.SysOptimizerTool in it?


Here is the result from;

shigeru@**************** ~ % ls -la /Library/PrivilegedHelperTools/
total 48952
drwxr-xr-t  14 root  wheel      448 Apr 18 18:42 .
drwxr-xr-x  73 root  wheel     2336 Mar 31 19:57 ..
-r-xr--r--   1 root  wheel   221808 Nov 11 05:23 com.************************
-r-xr--r--   1 root  wheel   222160 Nov 11 05:23 com.****************************
-r-xr--r--   1 root  wheel   154672 Apr 15 23:09 com.audirvana.SysOptimizerTool
-r-xr--r--   1 root  wheel   184048 Nov 13  2020 com.**********************************
-r-xr--r--@  1 root  wheel  7334704 Dec 20 07:54 com.********************
-r-xr--r--   1 root  wheel   163584 Sep 27  2018 com.***********************************
-rwxr-xr-x   1 root  wheel   326064 Apr 12 14:17 com.**************************
-rwxr-xr-x   1 root  wheel  1772352 Apr 10 08:55 com.**********************************
-r-xr--r--   1 root  wheel  1875760 Mar 16 18:44 com.**************************
-r-xr--r--@  1 root  wheel  6616368 Jun 25  2019 it.*************
-r-xr--r--   1 root  wheel  7128912 Feb 26  2020 it.****************
-r-xr--r--   1 root  wheel   198432 Mar 27 13:42 us.***************

Yes, I do see it exists.

Can you close Audirvāna Origin, remove the com.audirvana.SysOptimizerTool and then reopen Audirvāna Origin and check if you have the popup asking you for installing sysoptimizer tool. does the installation work and do you still have an error message when you try to play a track?


No change in behaviour. Every time I try to play a new track, I will be prompted with these three panels.

Then, it will starts to play.

Hope this is giving some idea.

Can you try again this command in Terminal?

sudo launchctl load -w /Library/LaunchDaemons/com.audirvana.SysOptimizerTool.plist

After you used this command, try again to play a track to see if you still get this error.


How odd! Running of the launchctl load with -w option this time seems to have resolved the issue.


1 Like