SysOptimizer Error?!

Every time I try to install SysOptimizer, I get this same error!

How can I successfully install SysOptimizer?

Hello @karipu,

Can you make a screenshot of the error you get?


Can you close Audirvana and do the three commands below in Terminal?
sudo launchctl load -w /Library/LaunchDaemons/com.audirvana.SysOptimizerTool.plist
sudo rm /Library/PrivilegedHelperTools/com.audirvana.SysOptimizerTool
sudo rm /Library/LaunchDaemons/com.audirvana.SysOptimizerTool.plist
After doing this, can you open Audirvana and play a track?

Terminal commands didn’t work:

karipu@Kari-iMac ~ % sudo launchctl load -w /Library/LaunchDaemons/com.audirvana.SysOptimizerTool.plist

/Library/LaunchDaemons/com.audirvana.SysOptimizerTool.plist: No such file or directory

karipu@Kari-iMac ~ % sudo rm /Library/PrivilegedHelperTools/com.audirvana.SysOptimizerTool

rm: /Library/PrivilegedHelperTools/com.audirvana.SysOptimizerTool: No such file or directory

karipu@Kari-iMac ~ % sudo rm /Library/LaunchDaemons/com.audirvana.SysOptimizerTool.plist

rm: /Library/LaunchDaemons/com.audirvana.SysOptimizerTool.plist: No such file or directory

I can open Audirvana and play track, but the app wants again install SysOptimizer and I get the same error.

1 Like

Can you check if you have any file in /Library/PrivilegedHelperTools/ ?

Can you also run this command line and past the result here?
sudo ls -al /Library/PrivilegedHelperTools

I have five files in in /Library/PrivilegedHelperTools.

karipu@Kari-iMac ~ % sudo ls -al /Library/PrivilegedHelperTools
total 10872
drwxr-xr-t 7 root wheel 224 17 Syy 08:04 .
drwxr-xr-x 71 root wheel 2272 25 Syy 12:59 …
-r-xr–r-- 1 root wheel 79200 28 Tou 18:19 com.linotype.FontExplorerX.securityhelper
-rwxr-xr-x 1 root wheel 2271440 17 Syy 08:04
-rwxr-xr-x 1 root wheel 104220 25 Elo 2010
-rwxr-xr-x 1 root wheel 2068416 10 Elo 17:18
-r-xr–r-- 1 root wheel 160800 3 Kes 09:45 org.cindori.SenseiHelper

1 Like

Strange, you don’t have the file that should be here, have you tried to reinstall Audirvana?

I uninstalled Audirvana with the App Cleaner & Uninstaller, reinstalled Audirvana and now I was able to install SysOptimazer.

1 Like

Good to know this :slight_smile:

I had this issue until I used BatChmod, a free utility app for Mac.
BatChmod fixes any ownership and privileges issues, and the SysOptimizer error 4 is a such.
In the main Library/LaunchDaemons and PrivilegedHelperTools folders + folder content should have the following privileges:


There’s something going on here, it was working fine before. Since this version, when It prompts me to install Sysoptimizer it will ALWAYS say the password is wrong the first time no matter if I put the same thing in over and over. I don’t know whether to be annoyed at Apple or seriously have some security concerns right now.

I have the same issue.
Exept the other error message
“Error = Couldn’t communicate with a helper application.”

But all the behavior is the same.
I have checked all the repositories
But there is no audirvana’s files. At all!
reinstall doesn’t help.
May be I can get this files somewhere and put in repostories manually?

I have Audirvāna Origin 1.0.3 and MacOS Monterey 12.3.1

Please assist

You can try my files from older thread…

1 Like

Hello @Smyck,

Do you mean that if you have SysOptimizer activated and you try to play a track, you do not have a window asking you to install it?