UPNP workaround once and for all

UPNP playlists playback stability issues seem to be a recurring problem giving a lot of grief to many Audirvana Studio(AS) users. I understand it’s more a UPNP loose standard issue than an AS problem. One workaround could be to use a USB cable from computer to USB-DAC, however budget-good-quality USB DACs (I mean DAC that can connect to a PC via USB, not just to a USB dongle) are not very common. Am I correct when I suggest instead to use the “optical in” on the DAC via a USB/SPDIF converter? e,g, an Audiophilleo, or a Concero or a uLink?
I would suggest AS to optimize connection to such converters instead of trying to win the UPNP “battle”, which will always be frustrating to everyone, by making sure that such converters are easily recognized by Audirvana?
It seems to be the solution adopted by the people of “Volumio” for instance who modified an Asus Vivo Mini by adding such USB/SPDIF converter: I believe that a “home-made” solution with AS as the software and such converter would be superior. Let me know what you think. I plan to get an Audiophilleo 2 to connect my DAC (Yamaha WXA-50) directly to my Asus Vivo Mini…

My Cambridge Audio CXN would not play track via uPNP until I followed a “tip” to up-sample then it worked but I see that as a workaround and not a viable option for me.

I also have a Raspberry Pi 4 , 4Gb , with an Allo Digione HAT running Roipeee XL to a separate Audiolab M-DAC for my Roon installation and that worked without up-sampling . So maybe you thoughts are correct. (I need the Allo HAT to get 24/192 as the RPi → USB is not perfect on the M-DAC, its a known M-DAC issue)

What confuses me is that the CXN runs fine with 3.5 , so it would suggest the uPNP portion of AS has been modified between the 2 products.

The prime reason for even considering AS was to utilize my CXN (a V1 which is not Roon Ready) but that would seem not to be possible until AS changes in some way.

I accept the thoughts of the loose DLNA spec but so far I have used quite a range of uPNP/DLNA servers with the CXN without an issue (eg JRiver, VLC, Minim Server) so AS must be missing something quite critical.

I can jut convince myself of a SQ advantage with AS which I would like to pursue but currently this is not to be. To add insult to injury I ran audio analysis on my main library overnight , it crashed , took out a Roon BU, and now AS refuses to start. It doesn’t make me feel too inclined to keep trying.

I admit I am a 5 year Roon user so I really wonder what I will gain …

Have you tried to enable the “Do not use RAW PCM” option?
And in general - let’s not marginalize UPnP, it is a good and needed technology.

1 Like

Spot on that seems to work ,

Its nice to see a fellow user with the answer how come its taken 6 weeks to find that out ?

The option ‘Do not use RAW PCM’ just came available in the last AS update (a couple of days ago).
Six weeks ago it was not there yet :wink:

This option was introduced quite recently - in 10505 release

Ah that may explain :sunglasses:

I am not sure what it means , maybe a bit of explanation may help. It seems to work , so be it …

Here is the only explanation:

https://community.audirvana.com/t/release-note-audirvana-studio-1-5-5/27591

Mike, It was myself who found the upsampling trick and I have now tried the new workaround in 1.5.5 but sadly, not only does the new method not work but neither does the upsampling fix work any more… I am actually worse off. I have the CXN V2. With USB connection there is no problem but not ideal.

Agreed
I, unfortunately, found the same issues still as well. AS1.55 did not fix my issue either (running into a Classé CP800 MK2 pre). Tried multiple settings with the new option, but still nothing helped.
Works with Windows 10 via UPNP without issue, but not with macOS 11.3 and higher.
Hopefully this will be fixed before the end the trial extension. @Damien3 ?

Also mConnect is working fine but with Audirvana and Audirvana Studio I have always some Upnp/dlna troubles. I agree that there is something critically wrong with the implementation. The answer that the receivers are not fully upnp compliant is not helping. Especially when there are other products which are working fine with my receiver

@peckem , @GB46

I agree the implementation must be at fault somewhere workarounds should not be needed for a “so called” uPNP based player playing to one of the arguably most popular streamers in the last 5 -10 years.

I use a mix of JRiver and Roon , I was just keeping abreast of changes trying AS . My CXN is V1 so not Roon Ready but it has played problem free from JRiver for several years ,It played 3.5 no problem

So it is clear (at least to me) that the AS DLNA/uPNP process is flawed, there are enough people on very different systems making similar comments to guide that thought.

To be honest I don’t think I will be following the AS route as currently the look and feel is a mess so I will leave @Damien3 to sort it out . I may come back for another go later but for now my audio and video needs are sorted .

I do understand the DLNA spec is a bit “wide” and variably applied , this is one of the primary reasons Roon went with RAAT their on built protocol, but to set out your stall as an uPNP server surely you must deal with the vagaries to match the maximum number of devices out there, that’s what uPNP was about “Universal”.

Good luck if uPNP is your only source, I have an active alterative, Roon, if you have a CXN V2 it is already Roon Ready maybe give it go …

I have MConnect but it doesn’t seem to see AS also it has Gapless Issues with my CXN , not good for a classical and Pink Floyd listener

1 Like

My issue is on Windows 10 laptop. It worked on 3.5 so Audirvana is capable of using UPnP with these devices.

Are you saying you can use mConnect to control AS ?

I don’t see it as an available server ?

No, no. My reaction was about still having upnp problems with A+/AS and my Marantz receiver while mConnect works perfectly with my receiver.

What is still odd in my setup, is that the radio stations play using AS, macOS11.4 via UPnP
As the radio stations are generally of lower quaity (lower bit rates), does this not point to the issue being something to do with the file resolution being transmitted via UPnP causing the issue?
Just sharing my experiences, so that we can hopefully get a solution soon.

Update since version 1.5.6. I have been able to play over UPnP to the CA CXN V2 but with problems.
1, Once again it will only play if higher res files eg 24/96 or upsampled. Won’t play 16/44.1.
2, Half way through a track it jumps to the beginning of the next track.
3, The controls at the bottom (eg pause) do not work. The only way to stop playing is via the ‘padlock’.
4. The sound quality is quite bad.
I don’t know for sure if the new version is responsible for the difference as it has behaved like this once before and also the release notes do not mention any changes to UPnP playback.
EDIT: Selecting the RAW PCM mode has allowed playback of 16/44.1 and in good quality sound and no skipping. Controls still non-functional.

In one forum thread about UPnP playlists issues, I remember Damien asking aggrieved customer about sampling rate changes between songs and advising to use over sampling (X2 or max frequency), so that rate would be constant across playlist, so yes. I did try and saw some improvement. Also, when it really gets bad, rebooting computer and audio device has helped. I wonder if computer going to sleep can also play up with UPnP. Weirdly this morning, it was soo bad that I toggled back from UPnP to my little USB dragonfly dongle. This is not UPnP right, well guess what? Songs were still skipping. :rofl: WTF?!