UPNP workaround once and for all

Spot on that seems to work ,

Its nice to see a fellow user with the answer how come its taken 6 weeks to find that out ?

The option ‘Do not use RAW PCM’ just came available in the last AS update (a couple of days ago).
Six weeks ago it was not there yet :wink:

This option was introduced quite recently - in 10505 release

Ah that may explain :sunglasses:

I am not sure what it means , maybe a bit of explanation may help. It seems to work , so be it …

Here is the only explanation:


Mike, It was myself who found the upsampling trick and I have now tried the new workaround in 1.5.5 but sadly, not only does the new method not work but neither does the upsampling fix work any more… I am actually worse off. I have the CXN V2. With USB connection there is no problem but not ideal.

I, unfortunately, found the same issues still as well. AS1.55 did not fix my issue either (running into a Classé CP800 MK2 pre). Tried multiple settings with the new option, but still nothing helped.
Works with Windows 10 via UPNP without issue, but not with macOS 11.3 and higher.
Hopefully this will be fixed before the end the trial extension. @Antoine ?

Also mConnect is working fine but with Audirvana and Audirvana Studio I have always some Upnp/dlna troubles. I agree that there is something critically wrong with the implementation. The answer that the receivers are not fully upnp compliant is not helping. Especially when there are other products which are working fine with my receiver

@peckem , @GB46

I agree the implementation must be at fault somewhere workarounds should not be needed for a “so called” uPNP based player playing to one of the arguably most popular streamers in the last 5 -10 years.

I use a mix of JRiver and Roon , I was just keeping abreast of changes trying AS . My CXN is V1 so not Roon Ready but it has played problem free from JRiver for several years ,It played 3.5 no problem

So it is clear (at least to me) that the AS DLNA/uPNP process is flawed, there are enough people on very different systems making similar comments to guide that thought.

To be honest I don’t think I will be following the AS route as currently the look and feel is a mess so I will leave @Antoine to sort it out . I may come back for another go later but for now my audio and video needs are sorted .

I do understand the DLNA spec is a bit “wide” and variably applied , this is one of the primary reasons Roon went with RAAT their on built protocol, but to set out your stall as an uPNP server surely you must deal with the vagaries to match the maximum number of devices out there, that’s what uPNP was about “Universal”.

Good luck if uPNP is your only source, I have an active alterative, Roon, if you have a CXN V2 it is already Roon Ready maybe give it go …

I have MConnect but it doesn’t seem to see AS also it has Gapless Issues with my CXN , not good for a classical and Pink Floyd listener

1 Like

My issue is on Windows 10 laptop. It worked on 3.5 so Audirvana is capable of using UPnP with these devices.

Are you saying you can use mConnect to control AS ?

I don’t see it as an available server ?

No, no. My reaction was about still having upnp problems with A+/AS and my Marantz receiver while mConnect works perfectly with my receiver.

What is still odd in my setup, is that the radio stations play using AS, macOS11.4 via UPnP
As the radio stations are generally of lower quaity (lower bit rates), does this not point to the issue being something to do with the file resolution being transmitted via UPnP causing the issue?
Just sharing my experiences, so that we can hopefully get a solution soon.

Update since version 1.5.6. I have been able to play over UPnP to the CA CXN V2 but with problems.
1, Once again it will only play if higher res files eg 24/96 or upsampled. Won’t play 16/44.1.
2, Half way through a track it jumps to the beginning of the next track.
3, The controls at the bottom (eg pause) do not work. The only way to stop playing is via the ‘padlock’.
4. The sound quality is quite bad.
I don’t know for sure if the new version is responsible for the difference as it has behaved like this once before and also the release notes do not mention any changes to UPnP playback.
EDIT: Selecting the RAW PCM mode has allowed playback of 16/44.1 and in good quality sound and no skipping. Controls still non-functional.

In one forum thread about UPnP playlists issues, I remember Damien asking aggrieved customer about sampling rate changes between songs and advising to use over sampling (X2 or max frequency), so that rate would be constant across playlist, so yes. I did try and saw some improvement. Also, when it really gets bad, rebooting computer and audio device has helped. I wonder if computer going to sleep can also play up with UPnP. Weirdly this morning, it was soo bad that I toggled back from UPnP to my little USB dragonfly dongle. This is not UPnP right, well guess what? Songs were still skipping. :rofl: WTF?!

Good to see KEF have updated the firmware for LS50 Wireless II’s to version 2.0. Can now use UPnP with these speakers in AS which previously would not play tracks despite being recognised by AS as a UPnP device. No longer have to use airplay with its limitations on bit depth and sampling rate. Happy!

1 Like

Follow up on tracks skipping even with a cabled connection to DAC: I am using a multibit Schiit bifrost2 DAC and every now and then, AS moves randomly to next track before it’s end. If it starts it then does it systematically until I restart manually a track. I don’t use oversampling due to multibit DAC. I will endure this for the year of my subscription but if this is not fixed by then, I will bid my farewell and move to Roon.

Are you playing local content or streaming?

Hi bitracer, I am mostly streaming from both Tidal and Qobuz. Only rarely do I play local tracks as I don’t have many albums. It seems like it is triggered the first time when bitrate changes between tracks. Once triggered, it happens very frequently. It doesn’t seem specific to particular tracks either…