2.4 vs 5 Ghz WiFi

This has likely been asked and hopefully solved before, but I’m having trouble with the remote app trying to connect to Origin (on a month free trial) when my router is using 5 Ghz. If the router is set to transmit either both 2.4 & 5 (same network name, and either with band steering on or off), or just 5 Ghz, the remote app has a lot of trouble finding the computer, whether on iPhone or iPad. If I set the router to 2.4 Ghz only, it’s instantly fine.
Might this be a router issue (with some settings I could potentially change on there) an OS Ventura issue, or laptop issue (2021 16" MBP, M1 Pro); does anyone have experience of this?
Many thanks in advance,
(an admirer of the Origin layout, and of the decision to release a non-subscription version.)

Hi @DAT,

When you select your Wi-Fi network on your Mac, which frequency band is used? Same question on your iPhone or iPad :wink:

Hi Antoine - thanks for the reply. Both the 2.4 & 5 Ghz bands have the same name, and I leave it to the router to choose the cleverest with ‘band steering’ set to on. If I switch one band off then the only luck I seem to have is via the 2.4, which allows the remote app to see the computer running Origin straight away. It’s worth saying maybe that if I leave on the 5 Ghz only, all devices operate otherwise without issues (as in, I don’t think it’s a 5 Ghz fault with the laptop running Origin, but I’m just guessing).

If you have the possibility to choose just the 5 Ghz band on the router, can you try to do this and then check if you can connect the Remote?

Hi - I have tried that (i.e. switched the 2.4 band off) a number of times but no, that won’t connect the remote. It’s only when I’m choosing the 2.4 (i.e. when I switch off the 5 Ghz) that everything works fine.

biggest difference between 2.4GHz and 5GHz Wi-Fi is the data bandwidth — 5GHz offers connection speeds up to about one gigabit, whereas 2.4GHz connections top out about 300 megabits. 2.4GHz Wi-Fi also works better through walls and over long distances than 5GHz.

1 Like

Thanks for this, but I don’t think it’s a speed issue. I leave the remote for a while to connect, but on 2.4 it connects immediately, whereas on 5 it won’t at all. That seems like it’d be the opposite of what I’d expect if it were a speed issue. Also, everything is happening within a few metres of the router & laptop.

1 Like

Tried yet again on 5 Ghz only, but also with a restart of the router, and it works. I think most likely something up with the router. Will keep an eye on it.

1 Like

That’s really interesting, can you please give me the router model you have?

It’s this one - https://help.cosmote.gr/system/templates/selfservice/gnosis/files3/Speedport_Plus_User_Manual_eng.pdf
Supplied by one of the main telecoms co’s in Greece. It sometimes doesn’t like Plex too, if that’s of any interest /help.

1 Like

If any other thoughts come to mind that can help me with this please pass them on. Spent last night listening via Origin & had to continually switch the router from 2.4 only to 5 only, back again, so that Remote would connect for a little while, but each time stopped after a few mins. Each reset of the band would give me some time, but it would lose it again. If there are any settings I could feed this router to tell it relax and let me use the Remote properly that would be great. Otherwise do I perhaps need to buy my own router?
PS also, sometimes, Remote would seem to be able to see the computer, but I’d get a “Request Error” message when trying to connect it. See uploaded pic.

I’ve gone a whole day without remote dropping out after turning off WMM on the router. Thought you might like to know.
Fingers crossed…

1 Like

Do you remember the mode WMM was set before you disabled it?

The only setting I’d done anything with was switch the on to off, but the numbers etc. are visible in the attached pic.

I do not think it’s router, it’s more likely the modem in your device. I had to buy the USB dongle with 5G modem to make my bussines laptop connect to WiFi after changing router.