A3.5 keeps needing to install SysOptimizer, any advice?

So, I’ve given up with AS, to my ear 3.5 sounds far superior - warmer, more analogue, and bass has more punch. Setup: macmini 2012, hiface2 usb to coax, metrum acoustic dac linked to luxman 507z, speakers Klipch cornwall IV. AS has it’s positives, better ui, more resolving and ability to play radio, but these do not outweigh the brittleness and brightness of AS, in my opinion.

Now to the question, why does 3.5 repeatedly ask me to install SysOptimizer, I am asked to do so roughly three times daily and this has only started recently? Any advice is appreciated.


I have same problem but it happened after installing OS Ventura.
Unfortunately there is no support for this version.
I think they could solve this problem, because many still use this version of Audirvana.

1 Like

Even if there is no additional function update, they must update the operating system (ex: 3.5.51)

You can try deleting it preferences file:

Apple hide the Home Folder in User Library at some time depending on OS System… When you have clicked your Home Folder, and cannot see the Library Folder in there, just do a ‘‘cmd J’’ to show the folder settings preferences and see at the bottom… click Show Library Folder and then you’ll have access to the rest forever.

Close A+:
Go to the Main Library Folder… PrivilegedHelperTools folder…
Trash All the files in that folder from A+ (that folder install SysOptimizer)
Go to the Main Library Folder… LaunchDaemons Folder…
Trash All the files in that folder from A+ (SystemOptimizer and prefs files)

Restart Mac, restart A+.
It will ask to install sys opt
for the last time?


While a fix would be a nice thing and wonderful gesture it doesn’t make much sense based on the current direction Audirvāna has decided to take.
Perhaps the best thing to consider is keeping a computer on a version of OS that was fully 3.5 compliant. We have to realize that updating your OS isn’t the best idea if you want to use a software that has been sundowned.
Just my thoughts and opinions. Probably the reality going forward.


Version 3.5 is a legacy version that means it is not supported anymore. If you want to keep it running, keep it on a computer where you do not update the operating system.

1 Like

Yes, it would be best to leave it with a compatible operating system.
In my case I use Origin more and I leave v3.5 just for Qobuz.
When I’m going to use it, I need to press Enter and it’s already working.

But I think as a gesture to all those who buy Audirvana software, a little tweak to fix this problem would be nice.

But you are right in your comment.

1 Like

This, to me at least, is the essence of the problem Audirvana faces.
The software is updated, which in turn may potentially cause problems with the OS it’s installed upon.
Conversely, the OS changes which causes problems with Audirvana.
It’s a never-ending circle of grief.
Whilst Audirvana ‘may’ sound better to many on here (I have my doubts), I’d still rather use a dedicated streamer solution as the vast majority of the ball-ache has (hopefully) been removed and I can enjoy the music, as opposed to sorting the problems.

1 Like

Same here, but I do have an Air that I’ve left on Catalina OS as a backup plan.

I once had two laptops with three different Microsoft OS to support my customers.

Problem what problem?

You should see the crazy volume of update related issues on the other products site so many different hardware and implementation options it’s insane.
None of the computer based playback solutions are impervious to this stuff.
Sometimes it’s better to keep it simple or just be an appliance operator and forgo the computer induced hives.

1 Like

It really helps on the Monterey, maybe it will help on the Ventura as well.

Thank you very much for your clear guidance. I had same issue in my mac but it was completely solved.

1 Like

Thanks from me for solving my dilemma - having removed Studio I was facing this issue constantly. I’d removed the PrivilegedHelper tool, it was the LaunchDaemon that had eluded me.

Like others, I am deluded with the Studio and its issues with being installed on 2 machines. Plenty of other reasons too, but GBP65 a year for a music player is insane - I don’t pay much more for Apple Music, with unlimited music. I will keep using 3.5 as long as possible and then buy a dedicated NAIM streamer.

Thats finally done it for me under Monterey as well.
Whatever people have to say about Studio and Origin: on my system A+ 3.5.5. sounds by far the better. Great to be back.

I also have this problem, running Sonoma 14.2. I have looked in my Library folder and I don’t have any of the folders that you mentioned. Also did a Spotlight search and nothing comes up - what am I missing? Thanks for the support - Louis

you have checked in the right library of macOS?

Also, have you seen that thread on Sonoma…

I had not seen the thread on Sonoma, but all the discussion seems to discuss “Origin” or "Studio’. I’m running 3.5.5. Is Origin available to replace 3.5.5? or can I download a fresh version of 3.5.5 to see if that cleans this problem up. I tried the suggestions in the Sonoma thread with no luck. And my “Library” folder does not have the folders mentioned in the previous thread.

Remove the photo of your serial number you are on a public thread…

Yes you can clear your installation and download it again, but it won’t change anything.

Try to go in your home folder…library… preferences… close audirvana, found the audirvana .plist preference and trash it. Restart mac, restart Audirvana and see :grinning:

Apple hide the Home Folder in User Library at some time depending on OS System…
When you have clicked your Home Folder, and cannot see the Library Folder in there,
just do a ‘‘cmd J’’ to show the folder settings preferences and see at the bottom…
click Show Library Folder and then you’ll have access to the rest forever.

You can also try to reset your PRAM on your mac since it is also related to sound…

Here is how to reset your PRAM:
Shut down your machine. Yes, all the way down, not sleep or logging out.
Press the Power button, after you hear the ’bong’ press those
4 keyboard keys at the same time:
Command + Option + P + R
Let them press till you hear a second ‘bong’ it will reset the sound, can reset also your screen…
second bong will be louder, then let go of the 4 keys and it will start normally.

Thanks for keeping me honest - sorry about that content with the key info. I have deleted the two .plist files and restarted the Mac - No luck. Had to re-register - OK, but sysoptimizer still broken. Maybe I’ll just turn it off.

Screenshot 2023-12-18 at 7.22.08 PM